"no root file system is defined" at install

Bug #90949 reported by winni on 2007-03-09
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)

Bug Description

kubuntu 7.04 rc5 X86 alternate CD
choosing the partitioner says "no root file system is defined please correct this from the partitioning menu".
As partitioning method I have tried all four methods cd rom retriever, entire disk, largest continuous free space and entire disk LVM. After pressing enter I get a red screen containing this error message. It is not possible to leave the message, pressing enter or back always shows that message.
board: Asus TUV4X with Celeron 1400 512 MB Ram
Primary Master HD IC25N020 20GB 2,5"
Primary Slave CDRW Philips PCRW5232P
It is possible to partition and format the harddisk from Sidux, so the harddisk should be ok.

Thanks for any suggestions

this is a biggie,

please ask in irc.freenode.net #ubuntu+1

if no-one knows, or it has also happened on something else please let an MOTU know, Laserjock would be a good bet

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the output of 'lspci -vv' and 'lspci -vvn' from Ubuntu on the system? Thanks in advance.

winni (winni) wrote :

the CD does not offer a console. I have started a Sidux CD to get the console, please find the result in the attached files.
I have also checked MD 5 of the CD and burned a new cd, ok.
Thanks for your help

winni (winni) wrote :

Now it works.
I am using a different harddisk, manual in the partition manager appears and lets me partition the disk.
The not working disk is a Hitachi Travelstar 20GB 4200 rpm Model IC25N020ATCS04-0 from March 03. The disk seems to be ok when using a different OS.
Please let me know if you want further information, otherwise its working for me.

Brian Murray (brian-murray) wrote :

Were both hard disks connected to your system in the same way? Thanks again.

winni (winni) wrote :

yes, both harddisks are connected the same way. Bios shows primary master, comes up as hda.
i did some testing on the old harddisk:

1. 20GB harddisk, 5GB primary NTFS partition running Windows XP, rest empty. Partitioner does not offer Manual. All available options lead to a red window saying "no root file system defined".

2. 20GB harddisk, 5GB primary NTFS partition running Windows XP. 5GB ext3 on hda5, 1GB swap on hda6. Partitioner does not offer Manual. All available options lead to a red window saying "no root file system defined".

3. 20GB harddisk, no partition defined. Partitioner does offer Manual, installation ok.

4. 100GB harddisk, 5GB primary NTFS partition running Windows XP, rest empty. Partitioner Partitioner does offer Manual, installation ok.

It looks like the partitioning program does not like the NTFS partition on hda1. Strange that on the 100GB harddisk the same setup is working. I have tried the 20GB harddisk in my old laptop, but unfortunately the setup program does not start at all.

Isriya Paireepairit (markpeak) wrote :

I have the same problem with Ubuntu Feisty Herd 5 alternate install. The harddisk has both NTFS, FAT32 and EXT3 partition.

When I boot up to partitioner screen, the "manual" option is missing and there is "0" instead. Four guided options are remained but not usable.

Isriya Paireepairit (markpeak) wrote :

More detail. After facing this problem, I reinstall the system with Edgy Alternate CD and it detects my disk correctly.

zoolook (nbensa) wrote :


I've faced this problem today. Three boxes. Two had Windows XP, one Windows Vista Home (Basic or whatever is called...)

So I fired up VMware, installed Windows XP inside it, and then I tried to install Kubuntu 7.04RC5 i386 alternate. Baaamm!!! I got for the forth time today "no root file system defined."

The partition table is attached (png image from vmware)

Colin Watson (cjwatson) wrote :

Thanks for your report. Please see the Herd 5 release notes on ubuntu-devel-announce, in which this bug was described. This is also bug 89004.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers