Ubuntu

Precise Desktop 64Bit: libc6 fails to install if "install 3rd party software" is selected

Reported by Brendan Donegan on 2011-11-29
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Martin Pitt
Precise
High
Martin Pitt

Bug Description

Trying to install the Precise Alpha1 release candidate (64-bit) on VirtualBox on a 32-bit Ubuntu guest, ubiquity crashed while installing the system and asked me to file a bug.

TEST CASE
1. Use Precise Desktop AMD64 and start the installation
2. In step 'Prepare' select 'Download Updates while installing' and 'Install third party software'
3. Proceed with the installation

EXPECTED RESULT:
The system installs

ACTUAL RESULT:
The installation fails and the following error is displayed in the logs:
Nov 29 11:53:58 ubuntu ubiquity: dpkg: libc-bin: dependency problems, but removing anyway as you requested:
Nov 29 11:53:58 ubuntu ubiquity: libc6 depends on libc-bin (= 2.13-20ubuntu5).
Nov 29 11:53:58 ubuntu ubiquity: (Reading database ...
Nov 29 11:53:59 ubuntu ubiquity: 123003 files and directories currently installed.)
Nov 29 11:53:59 ubuntu ubiquity: Removing libc-bin ...
Nov 29 11:53:59 ubuntu ubiquity: Processing triggers for man-db ...
Nov 29 11:53:59 ubuntu ubiquity: Can't exec "locale": No such file or directory at /usr/share/perl5/Debconf/Encoding.pm line 16.
Nov 29 11:53:59 ubuntu ubiquity: Use of uninitialized value $Debconf::Encoding::charmap in scalar chomp at /usr/share/perl5/Debconf/Encoding.pm line 17.
Nov 29 11:54:06 ubuntu ubiquity: Selecting previously unselected package libc-bin:i386.
Nov 29 11:54:06 ubuntu ubiquity: (Reading database ...
Nov 29 11:54:06 ubuntu ubiquity: 122953 files and directories currently installed.)
Nov 29 11:54:06 ubuntu ubiquity: Unpacking libc-bin:i386 (from .../libc-bin_2.13-20ubuntu6_i386.deb) ...
Nov 29 11:54:07 ubuntu ubiquity: (Noting disappearance of libc-bin, which has been completely replaced.)
Nov 29 11:54:07 ubuntu ubiquity: Preparing to replace libc6 2.13-20ubuntu5 (using .../libc6_2.13-20ubuntu6_amd64.deb) ...
Nov 29 11:54:08 ubuntu ubiquity: Can't exec "locale": No such file or directory at /usr/share/perl5/Debconf/Encoding.pm line 16.
Nov 29 11:54:08 ubuntu ubiquity: Use of uninitialized value $Debconf::Encoding::charmap in scalar chomp at /usr/share/perl5/Debconf/Encoding.pm line 17.
Nov 29 11:54:10 ubuntu ubiquity: Unpacking replacement libc6 ...
Nov 29 11:54:11 ubuntu ubiquity: Selecting previously unselected package libc6:i386.
Nov 29 11:54:12 ubuntu ubiquity: Unpacking libc6:i386 (from .../libc6_2.13-20ubuntu6_i386.deb) ...
Nov 29 11:54:13 ubuntu ubiquity: Processing triggers for man-db ...
Nov 29 11:54:19 ubuntu ubiquity: dpkg: dependency problems prevent configuration of libc6:
Nov 29 11:54:19 ubuntu ubiquity: libc6 depends on libc-bin (= 2.13-20ubuntu6); however:
Nov 29 11:54:19 ubuntu ubiquity: Package libc-bin is not installed.
Nov 29 11:54:19 ubuntu ubiquity: Package libc-bin:i386 is not configured yet.
Nov 29 11:54:19 ubuntu ubiquity: dpkg: error processing libc6 (--configure):
Nov 29 11:54:19 ubuntu ubiquity: dependency problems - leaving unconfigured
Nov 29 11:54:19 ubuntu ubiquity: No apport report written because the error message indicates its a followup error from a previous failure.
Nov 29 11:54:19 ubuntu ubiquity:
Nov 29 11:54:19 ubuntu ubiquity: Errors were encountered while processing:
Nov 29 11:54:19 ubuntu ubiquity: libc6

WORKAROUND:
Do not select to install 3rd party software during installation

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity 2.9.5
ProcVersionSignature: Ubuntu 3.2.0-2.5-generic 3.2.0-rc3
Uname: Linux 3.2.0-2-generic x86_64
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
CasperVersion: 1.292
Date: Tue Nov 29 11:56:20 2011
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129)
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

confirmed with an amd64 install and third party software selected.

Changed in ubiquity (Ubuntu Precise):
importance: Undecided → Critical
status: New → Triaged
milestone: none → precise-alpha-1
tags: added: rls-mgr-p-tracking
description: updated
summary: - 12.04 64Bit Alpha1 installer crashed in VirtualBox
+ 12.04 64Bit: libc6 fails to install if "install 3rd party software" is
+ selected
summary: - 12.04 64Bit: libc6 fails to install if "install 3rd party software" is
- selected
+ Precise Desktop 64Bit: libc6 fails to install if "install 3rd party
+ software" is selected
Martin Pitt (pitti) wrote :

Seems somehow ubuntu-restricted-addons removes libc-bin and installs libc6-bin:i386. This really shouldn't happen, libc-bin is Multi-Arch: foreign and thus should satisfy :i386 package dependencies, too.

Colin Watson (cjwatson) wrote :

It looks like this is just because libc6 was at different versions on i386 and amd64. This should sort itself out once the versions are in sync; respin images if necessary.

Michael Terry (mterry) wrote :

The basic idea here is that installing libc-bin:i386 is removing libc-bin and thus the system gets in an awkward state (here, it's that libc demands libc-bin, but there is no version of it installed after removing it).

You can reproduce this most simply by just running:
sudo apt-get install libc-bin:i386

Which removes libc-bin and fails to complete because ldconfig is not in PATH.

Exception during installation:
Nov 29 11:54:19 ubuntu plugininstall.py: SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
Nov 29 11:54:19 ubuntu plugininstall.py:

tags: added: testcase
tags: added: installer-crash
Martin Pitt (pitti) wrote :

With the newly posted ISOs (20111129.1) this should work again. Confirmation appreciated. Thanks for the report!

Changed in ubiquity (Ubuntu Precise):
status: Triaged → Fix Released
Jean-Baptiste Lallement (jibel) wrote :

reopening, 2 new duplicates have been reported.

Changed in ubiquity (Ubuntu Precise):
status: Fix Released → Triaged
importance: Critical → High
description: updated
Changed in ubiquity (Ubuntu Precise):
milestone: precise-alpha-1 → precise-alpha-2
Martin Pitt (pitti) on 2011-12-02
Changed in ubiquity (Ubuntu Precise):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers