Preparing partition step in installer fails

Bug #88930 reported by Joachim Ziegler on 2007-03-01
4
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

I've just tried to install feisty-desktop-i386.iso (Xubuntu version) on my T21 laptop, which has already 7 partitions. (The bug described here did not occur with Xubuntu 6.10, which I've installed successfully on the same machine.)

In step 5 (of 7) of the installing procedure, I select "Manual".

- I want to mount /dev/hda1 (ntfs) to /media/windows
- I want to set the mount point of /dev/hda2 to / and check the "Format?" button
- I want to set the mount point of /dev/hda6 to /home (which is my old /home) without the formatting option

Bugs observed and reproduced:

- Editing partition /dev/hda1 does not allow to change the proposed mount point /media/hda1
- The formatting option of the button of "/" disappears
- Editing partition /dev/hda7: "Use as" field is empty (I have to set it to ext3 by hand)
- The mount point /home of /dev/hda6 disappears (it is reset to the empty string)
- The format button of /dev/hda6 is checked for formatting and cannot be unchecked

All in all, the Desktop CD is useless for me, for it would destroy my /home.

description: updated
description: updated
Joachim Ziegler (ziegler) wrote :

I think I have to withdraw this bug report, but please read on.

In fact, the installation process *has destroyed* my /home partition, but I'm not sure any more whether the bug has been in the installer or on my hard drive.

The installer informed me about a tiny extra partition of some 8 MBs. I have no idea where this partition suddenly came from.

After trying the install process (which aborted with an error message I don't remember any more), I tried to boot my old 6.10 Xubuntu. I got an error message saying "bad superblock on /dev/hda7". fsck refused to work.

My /home was lost. I started gparted to examine the partitions and discovered the tiny extra partition /dev/hda6. As I said, I have no idea where this suddenly came from. As far as I remember, my /home was my old /dev/hda6 and I never had a /dev/hda7. gparted said that it could not detect the file system type of /dev/hda7, so my /home was lost.

I used gparted to merge /dev/hda6 and /dev/hda7 into a new parition...

and now the installation process proceded without any problems.

None of the bugs reported above appeared again.

I am writing this now on my freshly installed Feisty Fawn.

Nathan Handler (nhandler) wrote :

Thank you for reporting this bug. Since you are no longer sure if the bug was in ubiquity or your hard drive, and you have also successfully installed Ubuntu on your computer, this bug is no longer valid. I am changing the status of this bug report to 'Invalid' to reflect that. If you still feel that this bug is valid, feel free to change the status back to 'New'.

Changed in ubiquity:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers