Ubuntu 11.10 fails to install on a nvidia onboard RAID0

Bug #877986 reported by rumpl on 2011-10-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Tried to install ubuntu 11.10 alongside with Win7 on a asus p5n32-e sli with nvidia raid on-board.

Have tried different types of raid configs and also installing with the default "install with window7"

First times the installer went through, but only used 1 part of the mirrored RAID1 (although gparted in the installer detected the RAID1 as 1 disk ( /dev/mapper/nvidiablablabla)
Reboot: Grub did not display the windows installation anymore, since Win7 was installed on both HDs mirrorde as it was a mirror.

then, when making boot-repair from yanubuntu, this seemed to install grub in the /dev/mapper/nvidiablabla MBR, but then the startup failed from grub with: invalid environment block

So I reconfigured the RAID set to a raid0, cleared the disks with the raid manager, installed windows again.
Started the installation with the ubuntu 11.10 cd again and.... grub failed to install on /dev/mapper/nvidiaxxxxx

This happens with manual installation, with the guided install.

Also tried to install grub on a different partition, not on the /dev/mapper/nvidiaxxxxx disk directly, but no success.

Jordi Serra Sosa (jordi1-0) wrote :

booted from live CD, followed the steps in this post:
https://help.ubuntu.com/community/Boot-Repair

then danced like a '60s drugged space monkey ;)

I reported the same problem with the Ubiquity installer of Ubuntu 11.04 (64 bit) in hopes that it would have been sorted out by 11.10, but it isn't.

Last version of Ubiquity that seems to install fine on NVIDIA SATA stripe to my knowledge was with Ubuntu 10.10. My workaround on computers with NVIDIA SATA stripe set is to install Maverick and then let Update Manager upgrade to Oneiric.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Max la Menace (t-schnell-75) wrote :

Same problem here, i tried to install Ubuntu 11.10 on a raid0 (Nvidia on-board raid).
At the end of the installation i get the message "grub failed to install on /dev/mapper/nvidiaxxxxx"
I also tried the alternate installation CD with out any success, same for multiple grub recovery tools.

The only workaround that i found is the same as mentioned in post N°2 by installing Ubuntu 10.10 and than upgrade to Ubuntu 11.10. But even then, the system is not stable, 1 of 2 boot session crash just after choosing Ubuntu from the Grub menu.

On the same raid, Windows 7 is running as good as it can.

rumpl (rumplstielz) wrote :

Well, I finaly installed on only 1 HD and not on the RAID. Have read a lot of posts throughout the internet, that this RAID stuff from nvidia is not used properly by ubuntu and other linux distros (even if you are able to install the system on it ;-) )
BTW: Installation worked with Ubuntu 10.10, when I installed it the first time. Think all that inconveniance has to do with entries written on the HDDs by the on-board raid controller, as the first installation with 10.10 worked fine, but at this time, the system was brand new and RAID has not been used before on that system.

Max la Menace, your boot crash could have something to do with Bug #791089, which also affects me. You could try to blacklist the nv_tco. Maybe this solves at least your 2nd problem.

Phillip Susi (psusi) wrote :

11.10 reached end of life some time ago and is no longer supported. Can you reproduce this on 14.04 or 14.10?

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers