Oneiric 20111011 Ubiquity bootloader install fail on /dev/sda

Bug #872845 reported by jerrylamos on 2011-10-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

"an error occurred and it is not possible to install the bootloader at the specified location"
The specified location is IDE /dev/sda the main hard drive on this Aspire One nebook with Windoze 7, Meerkat, and the target pre-release image Ocelot install.
The install is running off the USB stick
There is also a usb hard drive
bootloader fails on /dev/sda the internal hard drive and /dev/sdc the USB hard drive.
Continuing without boot loader. Good luck, since Grub is now screwed up on the main hard drive.
Attempted to do manual sudo update-grub and it claimed it "can't find device for / (is /dev mounted?)"
Will try reboot on usb hard drive....

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ubiquity 2.8.7
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
CasperVersion: 1.285
Date: Wed Oct 12 08:52:22 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111011)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

jerrylamos (jerrylamos) wrote :
tags: added: iso-testing
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
jerrylamos (jerrylamos) wrote :

zsync'd the 20111012 image to try install again. Same error.

1. /dev/sda is a 250 GB hard drive with Ocelot, Meerkat, Windozzz 7.

2. /dev /sdb is a USB hard drive with Ocelot and another partition I was installing 20111012 onto from a USB stick /dev/sdc

The Aspire 1 netbook is set to boot from the USB hard drive /dev/sdb if it is plugged in.

3. After install well up, it got an "error" installing grub on the
USB hard drive. No way around it. I chose to continue install without boot loader.

4. Booted from /dev/sda and did sudo update-grub and sudo grub-install /dev/sda allowing grub to see the Ubuntu's on /dev/sdb..

5. Then booted old Ocelot on /dev/sdb and did sudo update-grub and sudo grub-install /dev/sdb

6. Finally was able to boot the USB hard drive selecting the new install.

Any clue what the "error" is?

Jerry

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers