"Unmount partitions?" and "Failed to unmount partitions" dialogs are over-tall

Bug #862270 reported by Matthew Paul Thomas on 2011-09-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Dimitri John Ledkov

Bug Description

ubiquity 2.7.35, Ubuntu 11.10 beta 2

1. Trigger the "Unmount partitions that are in use?" dialog. (For example, start up a live session from an ISO on the disk that will be installed to.)
2. Trigger the "Failed to unmount partitions" dialog.

The dialogs have lots of unnecessary vertical padding. Probably this is because they haven't been converted from GTK2 to GTK3. Compare bug 825959 and bug 844014.

Related branches

Matthew Paul Thomas (mpt) wrote :
Matthew Paul Thomas (mpt) wrote :
description: updated
summary: - "Unmount partitions" dialog is over-tall
+ "Unmount partitions?" and "Failed to unmount partitions" dialogs are
+ over-tall
Changed in ubiquity (Ubuntu):
status: New → In Progress
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in ubiquity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.13.4

---------------
ubiquity (2.13.4) raring; urgency=low

  [ Colin Watson ]
  * Huge pile of minor changes to make ubiquity compatible with pep8 1.3.

  [ Dmitrijs Ledkovs ]
  * Clear "Read release notes or update the installer" if neither action
    are possible. (LP: #1066302)
  * If there is only one disk & use_device recipe is used, change next step
    button to "Install Now". (LP: #1050044)
  * When auto-partitioning is not possible, allow to manually partition
    the same drive installation medium is on. (LP: #1053030)
  * Fix the question_dialog height-for-width (LP: #862270)
  * Fonconfig-voodoo is gone, not sure if some other "fontconfig"ury
    should be called instead. (LP: #1043031)
  * Fix partman test_windows_only: if resize option is available, use_disk
    should be available as well.
  * Fix test_translated, after moving question dialog into glade from
    construction by hand.
  * Automatic update of included source packages: base-installer
    1.122ubuntu14, debian-installer-utils 1.91ubuntu6, flash-kernel
    3.0~rc.4ubuntu28.

  [ Martin Pitt ]
  * ubiquity/gtkwidgets.py: Don't use GObject.constants, just use the
    constants from GObject as intended. Fixes a crash with pygobject
    3.7.2.
  * Use glib API from the GLib GI module instead of GObject. The latter
    has been deprecated for a long time and triggers warnings with pygobject
    3.7.2.
 -- Dmitrijs Ledkovs <email address hidden> Tue, 27 Nov 2012 11:47:01 +0000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers