uiquity crashes when installing grub (kubuntu feisty herd4)

Bug #86176 reported by Frank Bob on 2007-02-19
4
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Tried to install feisty using kubuntu herd4 LiveCD. The installer seemed ok until it tried to install grub (to hda). Installer crashed and suggested I submit a bug report.

I was installing feisty to hda3 and I already have dapper installed in hda1.

Traceback (most recent call last):
  File "/usr/lib/ubiquity/bin/ubiquity", line 201, in <module>
    main()
  File "/usr/lib/ubiquity/bin/ubiquity", line 196, in main
    install(args[0])
  File "/usr/lib/ubiquity/bin/ubiquity", line 56, in install
    ret = wizard.run()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde-ui.py", line 328, in run
    self.process_step()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde-ui.py", line 820, in process_step
    self.progress_loop()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde-ui.py", line 611, in progress_loop
    (ret, realtb))
RuntimeError: Install failed with exit code 1
Traceback (most recent call last):
  File "/usr/share/ubiquity/install.py", line 1468, in <module>
    install.run()
  File "/usr/share/ubiquity/install.py", line 391, in run
    self.configure_bootloader()
  File "/usr/share/ubiquity/install.py", line 1216, in configure_bootloader
    "GrubInstaller failed with code %d" % ret)
InstallStepError: GrubInstaller failed with code 1

Frank Bob (frankbob) wrote :
Frank Bob (frankbob) wrote :
Frank Bob (frankbob) wrote :

I added manually the grub menu.lst section to be able to boot feisty in the list that already included the dapper kernels.

When I rebooted and tried to boot into feisty, it didn't work and grub told that hda3 didn't contain a recognized file system. It turns out that the hda3 partition was formatted in ext3 and had feisty installed on it but the partition table had hda3 listed as W95 FAT (LBA) or something like that. hda3 contained a windows install earlier. I used cfdisk to edit the partition table and switch hda3 to type 83. Now grub can boot into feisty and I'm using it to type this.

Maybe this was the reason the installer wasn't able to install grub.

Andreas Moog (ampelbein) wrote :

This bug report is being closed due to your last comment regarding this being fixed. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in ubiquity:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers