While installing ubiquity takes 100% CPU time

Bug #85796 reported by Sandlord on 2007-02-17
8
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

While installing ubiquity takes 100% CPU time.
I think this is a bug since the scripts installer.py, dpkg-reconfigure and others called by ubiquity use only 1-4 % of the CPU time ....

Brian Murray (brian-murray) wrote :

Thanks for your bug report. Which version of Ubuntu were you trying to install where you noticed this? Thanks in advance.

Brian Murray (brian-murray) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and feel free to submit bug reports in the future.

Changed in ubiquity:
status: Needs Info → Rejected
Thomas R. N. Jansson (tjansson) wrote :

I have the same problem which experinced installing kubuntu 7.04 on two different IBM laptops, a T40 and X30. I tried to solved be reniceing the ubiquity process since this prolonged the installation quite a bit. I am not sure when the ubiquity starts to max out.

At first I though it was related to the T40 on which I installed first and dismissed it as a hardware failure but since it is present on the X30 as well I think the bug is for real.

Thomas R. N. Jansson (tjansson) wrote :

I hope I have provied enough information for the bug to be reopened otherwise I will be happy to give more information.

Changed in ubiquity:
status: Rejected → Unconfirmed
Changed in ubiquity:
assignee: brian-murray → nobody
Hervé Fache (rvfh) wrote :

Still present in Intrepid alpha 3...

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. If possible could you please add the log reports as indicated at https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs ? Thanks in advance.

Changed in ubiquity:
status: New → Incomplete

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Sorry but there is no log to attach: just run this installer, open a
terminal and type 'top'. You'll see ubiquity taking any CPU that's not
used by the 'real' installation process.

This is the case even on my Core 2 Duo laptop at 2GHz.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQCVAwUBSJN9YllS0WUwk11ZAQLBkwQAxlO24TruFnUn6GcVUd3Rnw9vCAvXv9M6
RPSVX209ga8LoT8p/Q7uoeCOWV5Ye+GUnTuK6BFOnxSTcp2ojPeM0a7fqxjVO5RJ
WtxxNhw3e4BhwMRToS6/Q8lkFkn7BrTp1t8ZJKJbI/otfMyq8u6F7ht5LLjRvjYS
zxurT1lKTkE=
=g29y
-----END PGP SIGNATURE-----

Hervé Fache (rvfh) wrote :

Installing Kubuntu Intrepid alpha 6 now and this bug is still as present as ever. The installation is slowed down by the time Ubiquity takes for itself.

Examples:
- when entering user name, hence nothing happening
- when showing page 6, the installation details
- when creating FS's/copying files

Daniel T Chen (crimsun) on 2008-09-21
Changed in ubiquity:
status: Incomplete → New
Gaetan Nadon (memsize) wrote :

I am trying to reproduce the problem so we have a complete bug report. I am not sure I understand the situation, here's what I did so you can tell me if it is right. I used a virtual box so I at least I get the steps right.
- Boot with Live CD (hardy)
- Start System Monitor to monitor CPU usage
- Initiate Install from desktop icon
The issue you raised is that the Live CD session and, by association, the installation process are abnormally slow. Looking into to it, you found that the ubiquity process is using up all the CPU, leaving little for the installation script doing the real install work.

Is this description accurate?
If this description is not the scenario you reported, would you please detail the steps to reproduce?

For my part, I have not noticed any abnormal behaviour, CPU usage was normal.

Thank you for taking the time to report this bug and helping to make Ubuntu better.

BugSquad

Changed in ubiquity:
status: New → Incomplete
Hervé Fache (rvfh) wrote :

Your description is correct. I should be able to try an install on Monday
(first day of new job)... I'll report again then.

Colin Watson (cjwatson) wrote :

I don't see any reason why this bug should be closed. It looks to me as though it could easily be an issue specifically with the KDE frontend; it is not obvious that Gaetan was trying Kubuntu rather than Ubuntu.

Changed in ubiquity:
status: Incomplete → Confirmed
Gaetan Nadon (memsize) wrote :

You're right! I retested with kubuntu-8.10-desktop-amd64 (in a VirtualBox) and found nothing abnormal. Ubiquity CPU usage ranges from 50% to 70% at most. Installation time is quite normal.

kahuna (kahuna) wrote :

I installed kubuntu-9.10-desktop-amd64 on VirtualBox and on a real machine and I see the same behavior you described on both situations. 100% cpu usage by ubiquity process.

Phillip Susi (psusi) wrote :

I am unable to reproduce this on 13.10, are you?

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers