No mount point options listed during manual partitioning

Bug #85713 reported by Stephen Gornick on 2007-02-17
72
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Colin Watson
Hardy
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

The pull-down menu for Mount Point does not list any options.

To reproduce,
In the installer, at Step 5 "Prepare disk space", select "Manual" then click the Forward button.
This displays the next step, "Prepare partitions".
Right-click on "free space" and select "New".
A dialog box titled "Create partition" is displayed.
Click on the pull-down selection for "Mount point:" field.
No items are shown in the list.

Expected results:
The following list should be displayed in the pull-down selector:
/ - the root file system
/boot - static files of the boot loader
/home - user home directories
/tmp - temporary files
/usr - static data
/var - variable data
/srv - data for services provided by the system
/opt - add-on application software packages
/usr/local - local hierarchy

The selector is the only way to enter the mount point -- the field will not let the user enter the mount point as text either.

Workaround:
After specifying the new partition, user can right-click on the partition name and select "Edit". A dialog box "Edit partition" is displayed, and the Mount point: pull-down selector now will show the list of mount points from above.

Recommended:
The full list of mount points should exist in the Mount point pull-down selector.

Ubuntu 7.04 Feisty Herd-4 i386

Related branches

Colin Watson (cjwatson) wrote :

Yes, this is a to-do entry in the code already :-)

Changed in ubiquity:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Stephen Gornick (sgornick) wrote :

Appears to have been fixed in Feisty Herd-5.

Changed in ubiquity:
status: Confirmed → Fix Released
Stephen Gornick (sgornick) wrote :

Oops, my mistake. Fix not yet in Feisty, as-of Herd-5. I saw entries in the "Mount point:" pull-down list in the "Edit partition" dialog box and confused myself. This bug is for the same pull-down list which has no entries in the "Create partition" dialog box.

Changing status back to "Confirmed".

Changed in ubiquity:
status: Fix Released → Confirmed
Henrik Brink (henrikbrink) wrote :

I had the same problem when installing Herd 5, but I was able to enter the mount point manually in the text entry, so I didn't have to do the workaround.

But still, the options should be shown. I just wanted to second that.

Fabián Rodríguez (magicfab) wrote :

Confirming this happens on Herd 5, 64-bit Alternate CD install with an IDE -hard disk equiped system. I don't have access to the hardware, just relaying the information.

jhansonxi (jhansonxi) wrote :

I also encountered this problem with Xubuntu Herd5 i386 LiveCD.

Stephen Gornick (sgornick) wrote :

Problem persists in Feisty Beta i386 LiveCD.

Matthias Klose (doko) wrote :

An option "Do not mount" is missing from the drop down menu (the alternate installer offers this option)

Jesus Gamio (jgamio) wrote :

I have the same problem in Feisty Release. i386 LiveCD

The problem persists in Gutsy final release!

This is a Ubuntu 7.10 "Gutsy Gibbon" Desktop CD (final release) installation screenshot, illustrating the problem. As you can see, the "Mount point:" list is empty.

sporkland (jhuffaker) wrote :

Even worse for me in 7.10 is that:
1. There are no names in the drop down (I don't really care about this, though)
2. The text I do enter is being replaced by /home or /usr whatever it's whim at the time seems to be.

I'd like to setup with a / and /localdisk different partitions (other machines are like this) and it won't allow me to. When I exhaust the list of names it is pulling from, it won't let me enter any name. There is plenty of space on / for whatever Ubuntu needs (50GB) and I'm going to mount home from a remote server.

I think I'm going to need to drop back to the more "manual" install disk to get this to work.

Bug still visible in Hardy (8.04) beta livecd 2008-02-28

tuharsky (tuharsky) wrote :

I also am interested about this bug.

Przemek K. (azrael) wrote :

Hardy Alpha 5 is affected too.

Still present in Hardy alpha livecd (build 20080317.1).

LarryJ (larry-foxgulch) wrote :

This is present in Ubuntu 8.04 Hardy Beta LiveCD Desktop also. Instead of the drop down list of mount points, there is a small orange square displayed when the mount point drop down is clicked. The user is left to guess what mount points are valid.

Colin Watson (cjwatson) on 2008-04-09
Changed in ubiquity:
assignee: nobody → kamion
status: Confirmed → In Progress
Colin Watson (cjwatson) on 2008-04-09
Changed in ubiquity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.8.3

---------------
ubiquity (1.8.3) hardy; urgency=low

  [ Colin Watson ]
  * Make all text in the partitioner translatable (LP: #144741).
    Unfortunately we don't have time to get translations in place for 8.04,
    but there ought to be time to do this for 8.04.1. This also involved
    moving the "Undo changes to partitions" button to a second line in order
    to avoid excessive horizontal growth.
  * Adjust po-debconf flags in ubiquity/install/copying_error/md5, so that
    ${FILE} doesn't get translated.
  * Offer a list of mount points when creating a partition (LP: #85713).
    Adjust this list (and also that offered when editing a partition) if the
    file system is changed to FAT or NTFS.
  * Guard against division by zero while copying files (LP: #211503).
  * Ensure that "Location for the new partition" always defaults to
    "Beginning" (LP: #207810).
  * Stop X forwarding code from breaking if we aren't running within X
    (LP: #214211).

  [ Evan Dandrea ]
  * Update the translations from Rosetta.
  * Automatic update of included source packages: debian-installer-utils
    1.50ubuntu3, localechooser 1.42ubuntu5, partman-basicfilesystems
    56ubuntu4.

  [ Jonathan Riddell ]
  * Fix exception in edit partitions dialogue use in kde_ui
  * Add minimum size to partition_edit_dialog.ui, closes LP: #203626
  * Fix buttons on question dialogue to use supplied text, closes LP: #203660

 -- Evan Dandrea <email address hidden> Thu, 10 Apr 2008 04:22:15 -0400

Changed in ubiquity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments