KDE OEM Mode Hang On Shutdown

Bug #856418 reported by Scott Kitterman on 2011-09-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson

Bug Description

Testing an OEM install for Kubuntu Oneiric Beta 2. After prepare for shipping, system shutdown hangs (looks like KDE fails to stop). After switching to a VT and rebooting, 'customer' configuration worked fine, so prepare for shipping is working.

tags: added: iso-testing
tags: added: rls-mgr-o-tracking
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

It'd be helpful to know if this was on a virtual machine or on real hardware.

Evan (ev) wrote :

Can you elaborate on why you think this is a ubiquity problem? Presumably you're shutting down from the menu at this point.

Please boot with --debug to collect upstart logs and try to shut down again, attaching /var/log/syslog when it fails. Also, can you try:
dbus-send –session –type=method_call –dest=org.kde.ksmserver /KSMServer org.kde.KSMServerInterface.logout int32:0 int32:2 int32:2

Cheers

Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
status: New → Incomplete
assignee: Evan Dandrea (ev) → nobody
Scott Kitterman (kitterman) wrote :

The reason I think it's related to OEM mode is that I could always shut down
fine in non-OEM mode tests for Beta 2, but the OEM mode tests always hung.

Colin Watson (cjwatson) on 2011-10-03
Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

I've reproduced this and am working on it. /var/log/syslog is uninformative even with --debug. Restarting from the menu succeeds if oem-config-prepare has not been run, but hangs if it has. That dbus-send command does nothing as far as I can see.

Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
Colin Watson (cjwatson) wrote :

Removing /var/lib/oem-config/run before rebooting makes no difference.

Colin Watson (cjwatson) wrote :

I think the problem is that after running oem-config-prepare there are several KDE processes running as root:

  dbus-launch --autolaunch <blah> --binary-syntax --close-stderr
  //bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
  kdeinit4: kdeinit4 Running...
   \_ kdeinit4: klauncher [kdeinit] --fd=8
  kdeinit4: kded4 [kdeinit]
  /usr/bin/knotify4

Changed in ubiquity (Ubuntu):
status: Confirmed → In Progress
Colin Watson (cjwatson) wrote :

I'm pretty sure that the problem is that we're running kdialog as root at the end of oem-config-prepare. We should run just the part that requires root as root, and display the dialog as an ordinary user.

(This holds for the GTK+ frontend as well, even though it doesn't cause a fatal problem there.)

Colin Watson (cjwatson) on 2011-10-03
Changed in ubiquity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.8.2

---------------
ubiquity (2.8.2) oneiric; urgency=low

  [ Colin Watson ]
  * Preserve ordering of disks returned by partman-auto rather than
    shuffling them based on dictionary ordering (LP: #770711). This uses
    collections.OrderedDict, which requires Python >= 2.7.
  * Run only those parts of oem-config-prepare that require root access as
    root; in particular displaying confirmation dialogs is now done as the
    calling user, which avoids KDE confusion (LP: #856418).
  * Go back to killing update-apt-cache's process group, but this time make
    sure that it's in a separate process group and make more of an effort to
    ensure that it terminates (LP: #743359).
  * Update translations from Launchpad.

  [ Stéphane Graber ]
  * Make ubiquity also update gsettings (LP: #800760)
    - Add a new gsettings module similar to the gconftool one
    - Update ubiquity-dm for gconf to gsettings migration
    - Get PROXY configuration from gsettings
    - Update gtk_ui to set/restore gsettings values
  * Update copy_network_config to work with Network Manager now storing
    everything system wide.
 -- Stephane Graber <email address hidden> Mon, 03 Oct 2011 17:31:46 -0400

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers