Time Zone selection shows about 20 different "New York"s and doesn't autoselect my location

Bug #837054 reported by Jeff Lane on 2011-08-29
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu Geonames
Medium
Unassigned
ubiquity (Ubuntu)
Medium
Ubuntu Installer Team

Bug Description

This is an install test of Oneiric B1 on a VBox VM. I'm running 64bit Oneiric on a 64bit VM.

When the timezone selection opens up after installation begins, my time zone is not automatically selected as it has been in previous versions. When I type in New York, a selection box opens up listing New York about 20 - 30 times, most of them being identical entries, some being weird, like "New York borg" and "New York kenti".

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ubiquity 2.7.17
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
CasperVersion: 1.279
Date: Mon Aug 29 18:32:33 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110829)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jeff Lane (bladernr) wrote :
tags: added: iso-testing
Jeff Lane (bladernr) wrote :

Blank TZ map as described

Jeff Lane (bladernr) wrote :

So many New Yorks, so little time

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

I can confirm with other cities like Paris. The list contains weird names (Lungsod ng Paris - Île-de-France, France ), wrong spelling (París - Paris - Île-de-France, France) - looks like a spanish spelling - and duplicates

Changed in ubiquity (Ubuntu):
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
importance: Undecided → Medium
status: New → Triaged
Evan (ev) wrote :

http://geoname-lookup.ubuntu.com/?query=New%20York returns:
[{"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York borg", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "Lungsod ng New York", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }, {"name" : "New York kenti", "admin1" : "New York", "country" : "United States", "longitude" : "-74.005970", "latitude" : "40.714270" }]

Changed in ubuntu-geonames:
importance: Undecided → Medium
status: New → Confirmed
Julian Olivien (julianolivien) wrote :

I got many many identical entries for "Frankfurt" (Germany) today as well as for "Frankfurt (Oder)" in my installation of today's lubuntu i386.

Further, there were two entries for Omsk, Russia.

Sergio Benjamim (sergio-br2) wrote :

http://geoname-lookup.ubuntu.com/?query=Sao%20Paulo returns:

[{"name" : "Sao Paulo", "admin1" : "São Paulo", "country" : "Brazil", "longitude" : "-46.636110", "latitude" : "-23.547500" }, {"name" : "Sao Paulo", "admin1" : "São Paulo", "country" : "Brazil", "longitude" : "-46.636110", "latitude" : "-23.547500" }, {"name" : "Sao Paulo", "admin1" : "São Paulo", "country" : "Brazil", "longitude" : "-46.636110", "latitude" : "-23.547500" }, {"name" : "Sao Paulo", "admin1" : "São Paulo", "country" : "Brazil", "longitude" : "-46.636110", "latitude" : "-23.547500" }, {"name" : "Sao Paulo", "admin1" : "Amazonas", "country" : "Brazil", "longitude" : "-62.900000", "latitude" : "-7.233330" }, {"name" : "Sao Vicente de Paulo", "admin1" : "Rio de Janeiro", "country" : "Brazil", "longitude" : "-42.259720", "latitude" : "-22.724440" }]

The correct could be:

[{"name" : "Sao Paulo", "admin1" : "São Paulo", "country" : "Brazil", "longitude" : "-46.636110", "latitude" : "-23.547500" } , {"name" : "Sao Vicente de Paulo", "admin1" : "Rio de Janeiro", "country" : "Brazil", "longitude" : "-42.259720", "latitude" : "-22.724440" }]

There isn't 4 Sao Paulo city, and neither Sao Paulo in Amazonas!!! take a look in municipalities' list of Brazil:

http://pt.wikipedia.org/wiki/Anexo:Lista_de_munic%C3%ADpios_do_Brasil#S

Colin Watson (cjwatson) wrote :

Not entirely a duplicate: as indicated in bug 740884, the client may well need to filter the list returned by the server.

Sergio Benjamim (sergio-br2) wrote :

I don't understand... filter list that has many repeated localization? For me this bug is duplicate of bug 740884

This bug is on the installer. That bug is on the date and time
indicator.

Sergio Benjamim (sergio-br2) wrote :

Sorry about that, now I undertand.

Jackson Doak (noskcaj) wrote :

the bug also affects quantal

tags: added: quantal
Carla Sella (carla-sella) wrote :

I had 5 choices for Rome timezone during test of Precise 12.04.1 iso: http://cdimage.ubuntu.com/precise/daily-live/20120817.3/precise-desktop-amd64.iso.

Can the code that makes the query to geoname-lookup not uniquely identify them by latitude and longtitude?

no longer affects: ubiquity (Ubuntu Oneiric)
Steve Langasek (vorlon) wrote :

This is not a bug in the installer, but in the data source, which is Ubuntu Geonames (linked bug task). The source for which appears to be lp:~ubuntu-geonames-hackers/ubuntu-geonames/trunk.

The source needs to be fixed to not include this duplicate info - that will correct the issue for all historical installer images as well.

Changed in ubiquity (Ubuntu):
status: Triaged → Invalid
Steve Langasek (vorlon) wrote :

Dmitrijs has volunteered to look at this.

Changed in ubuntu-geonames:
assignee: nobody → Dmitrijs Ledkovs (dmitrij.ledkov)
Dimitri John Ledkov (xnox) wrote :

The fix is committed in the sense of being available in the lp:ubuntu-geonames. It is still currently pending deployment. After it will be deployed, there will be 4 slightly different New Yorks instead of 20.

Changed in ubuntu-geonames:
status: Confirmed → Fix Committed
assignee: Dmitrijs Ledkovs (dmitrij.ledkov) → nobody
assignee: nobody → Dmitrijs Ledkovs (dmitrij.ledkov)
assignee: Dmitrijs Ledkovs (dmitrij.ledkov) → nobody
Carla Sella (carla-sella) wrote :

I get five choices for timezone Rome while testing this ISO: http://cdimage.ubuntu.com/daily-live/20120903.4/quantal-desktop-armhf+omap4.img on a Panda board.

Carla Sella (carla-sella) wrote :

I get five choices for timezone Rome while testing this ISO: http://cdimage.ubuntu.com/daily-live/20120905.2/quantal-desktop-armhf+omap4.img on a Panda board.

Dimitri John Ledkov (xnox) wrote :

@ Carla Sella

There is no need to continue to test & reproduce this bug. The bug is confirmed and it is being worked on. Simply choose on the very top that this bug affects you, and you will be notified when it is fixed.

Please wait until the bug is marked as fixed released.

Dimitri John Ledkov (xnox) wrote :

the updates that fix this bug have been deployed to the webservice used to provide this functionality.
I am pleased to announce this but is fix released. \0/

Changed in ubuntu-geonames:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers