Nothing displayed on embedded terminal.

Bug #830946 reported by Jean-Baptiste Lallement on 2011-08-22
126
This bug affects 15 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Stéphane Graber
Oneiric
Low
Ubuntu Installer Team
Precise
Medium
Stéphane Graber

Bug Description

Oneiric Desktop 20110821

TEST CASE:
1. Launch ubiquity and start the installation
2. click on the small arrow at the bottom of the ubiquity window to open the terminal

Result:
The embedded terminal stays empty during all the installation process because the font is too big and not properly formatted. Screenshot attached
Scrolling allows to view the terminal log.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
Date: Mon Aug 22 11:22:10 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110821)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
tags: added: regression-release
tags: added: iso-testing
Changed in ubiquity (Ubuntu Oneiric):
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
status: New → Confirmed

Still present in today daily build (17-Sep-2011 08:40)

tags: added: testcase
description: updated
Gema Gomez (gema) wrote :

Found this issue again: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/856344, still present during beta 2 testing.

Changed in ubiquity (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
Evan (ev) wrote :

As mentioned on IRC, I don't think this is sufficiently high priority to get fixed in 11.10. It's a UI nit that does not affect whether the installation can successfully complete.

Changed in ubiquity (Ubuntu Oneiric):
importance: Medium → Low
milestone: ubuntu-11.10 → none
Greg A (etulfetulf) wrote :

If this bug is not going to be fixed, it seems to me that it would make sense to disable the "triangle" - to completely remove the option to see the embedded terminal.

The installer is the one of the first things seen when encountering Ubuntu, and it stays on screen for some time. Having broken functionality like this in the release of a "precise" version of the OS would be embrassing in my opinion.

Changed in ubiquity (Ubuntu Precise):
importance: Low → Medium
Changed in ubiquity (Ubuntu Precise):
status: Confirmed → Triaged
Changed in ubiquity (Ubuntu Oneiric):
status: Confirmed → Triaged
status: Triaged → Won't Fix
Steve Langasek (vorlon) on 2012-02-08
Changed in ubiquity (Ubuntu Precise):
assignee: Ubuntu Installer Team (ubuntu-installer) → Evan Dandrea (ev)
Steve Langasek (vorlon) on 2012-03-04
Changed in ubiquity (Ubuntu Precise):
assignee: Evan Dandrea (ev) → Stéphane Graber (stgraber)
Benjamin Kerensa (bkerensa) wrote :

It would seem that this should be fixed before 12.04 release since it has been avoided in 11.10 that or the embedded terminal toggle should be disabled.

Stéphane Graber (stgraber) wrote :

Commited a fix to ubiquity's trunk setting the font to Ubuntu Mono 8 which is small enough to allow for two lines of text to appear in the console and still big enough to be readable.

Changed in ubiquity (Ubuntu Precise):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.9.25

---------------
ubiquity (2.9.25) precise; urgency=low

  [ Colin Watson ]
  * Fix debug message when failing to create the migration-assistant page.
  * Ensure that the migration-assistant page is shown in
    test_pages_fit_on_a_netbook.
  * Make the migration-assistant tree view expand again (LP: #946123).

  [ Stéphane Graber ]
  * gtk_ui: Set virtual terminal font to "Ubuntu Mono 8" so in most cases
    two lines of text can now be displayed. (LP: #830946)
  * Change ubiquity/text/webcam_heading to be generic (LP: #926493)
  * Switch from xklavier to Xkl using gobject introspection.
    The code is still disabled though because of bug #950087.
  * Automatic update of included source packages: flash-kernel
    2.28ubuntu41, netcfg 1.68ubuntu13, partman-base 153ubuntu2, partman-
    target 76ubuntu2, preseed 1.50ubuntu1, tzsetup 1:0.26ubuntu11.
 -- Stephane Graber <email address hidden> Thu, 08 Mar 2012 12:32:02 -0500

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers