ubiquity crashed with TypeError: cell_data_func() takes exactly 4 arguments (5 given)

Bug #829987 reported by Paul Hoell on 2011-08-20
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Evan
Oneiric
High
Evan

Bug Description

This happened after the installer set up the disks and (probably) asked me if i wanted to import user profiles, i couldn't really see anything, because there was lots of text missing in the window.
The install itself went on even though the crash report kept popping up.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: ubiquity 2.7.15
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
CasperVersion: 1.279
Date: Sat Aug 20 12:11:17 2011
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64+mac (20110820)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/4117/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with TypeError: cell_data_func() takes exactly 4 arguments (5 given)
Traceback: TypeError: cell_data_func() takes exactly 4 arguments (5 given)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Paul Hoell (hoellp) wrote :

This crash has the same stack trace characteristics as bug #194688. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
tags: added: regression-retracer
Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: iso-testing
visibility: private → public
affects: ubiquity (Ubuntu) → migration-assistant (Ubuntu)
Changed in migration-assistant (Ubuntu):
importance: Undecided → High
assignee: nobody → Evan Dandrea (ev)
Colin Watson (cjwatson) wrote :

ubiquity (2.7.25) oneiric; urgency=low

  [ Colin Watson ]
  * /apps/metacity/general/num_workspaces should be an int, not a boolean.
  * Automatic update of included source packages: flash-kernel 2.28ubuntu29.

  [ Evan Dandrea ]
  * Don't try to connect signals on the release notes label in the oem-
    config version of the language page, as it doesn't exist there.
  * Construct a GtkTreeCellDataFunc with the correct number of arguments
    in the migration assistant plugin (LP: #829987).
  * Don't let the text wrap for the language names in oem-config.

  [ Stéphane Graber ]
  * Properly sort the keyboard list (LP: #770320)

 -- Colin Watson <email address hidden> Wed, 31 Aug 2011 20:52:07 +0100

affects: migration-assistant (Ubuntu Oneiric) → ubiquity (Ubuntu Oneiric)
Changed in ubiquity (Ubuntu Oneiric):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers