do something more sensible if grub device is set to empty

Bug #82816 reported by Ankur Kotwal on 2007-02-02
2
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: ubiquity

In the advanced options, I set the grub device to an empty string as I did not want my existing grub conf overwritten. The installer crashed at 94% when the grub install failed. The message box displayed contained the following:

We're sorry; the installer crashed. Please file a new bug report at https://launchpad.net/ubuntu/+source/ubiquity/+filebug (do not attach your details to any existing bug) and a developer will attend to the problem as soon as possible. To help the developers understand what went wrong, include the following detail in your bug report, and attach the files /var/log/syslog and /var/log/partman:
Traceback (most recent call last):
  File "/usr/lib/ubiquity/bin/ubiquity", line 185, in ?
    main()
  File "/usr/lib/ubiquity/bin/ubiquity", line 180, in main
    install(args[0])
  File "/usr/lib/ubiquity/bin/ubiquity", line 56, in install
    ret = wizard.run()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 310, in run
    self.process_step()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 879, in process_step
    self.progress_loop()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 654, in progress_loop
    raise RuntimeError, ("Install failed with exit code %s\n%s" %
RuntimeError: Install failed with exit code 1
Traceback (most recent call last):
  File "/usr/share/ubiquity/install.py", line 1448, in ?
    install.run()
  File "/usr/share/ubiquity/install.py", line 385, in run
    self.configure_bootloader()
  File "/usr/share/ubiquity/install.py", line 1195, in configure_bootloader
    raise InstallStepError(
InstallStepError: GrubInstaller failed with code 1

Thanks for taking the time to report this bug. Unfortunately we can't fix it, because your description didn't include enough information.

Please include the information requested from https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs as separate attachments.

Colin Watson (cjwatson) wrote :

Cristian is incorrect; we do not need more information about this bug.

At the moment setting the grub device to the empty string won't do what you want (see also bug 90575, although this isn't really a duplicate of that. We should do something about this.

Changed in ubiquity:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) wrote :

Following the fix for bug 130445, we now have a more straightforward way (a checkbox) to skip installing the boot loader, and validation code added to fix bug 90575 will stop you entering the empty string here. Between those two changes, I think this bug is fixed.

Changed in ubiquity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers