livecd install crash during partitioning

Bug #82757 reported by Nils Grundback on 2007-02-01
0
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Tried to do a hard drive installation from the feisty hord 2 livecd on my apple iBook G4 800 Mhz laptop. During step 6 (partitioning) it crashed.

I guess it first tried to do some default suggestion but failed, I got some error message that it didn't find any free disk space. When I click ok it stalled for a while and then crashed with the error message below.

I have a 120 GB samsung hard disk with 2 pratitions each 60 GB (already partitioned and formated in mac os x). The first is a journaled HFS+ partition for mac os x and the second is a UFS formated partition. I would like to install ubuntu on the second partition.

Error message:

Traceback (most recent call last):
  File "/usr/lib/ubiquity/bin/ubiquity", line 185, in ?
    main()
  File "/usr/lib/ubiquity/bin/ubiquity", line 180, in main
    install(args[0])
  File "/usr/lib/ubiquity/bin/ubiquity", line 56, in install
    ret = wizard.run()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 310, in run
    self.process_step()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 867, in process_step
    self.process_autopartitioning()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 922, in process_autopartitioning
    choice = self.get_autopartition_choice()[0]
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 1620, in get_autopartition_choice
    raise AssertionError, "no active autopartitioning choice"
AssertionError: no active autopartitioning choice

Nils Grundback (nilsg) wrote :
Nils Grundback (nilsg) wrote :
Brian Murray (brian-murray) wrote :

Thanks for your bug report. This is actually a duplicate of bug 76976 and has been fixed in the latest version of ubiquity. You could run `sudo apt-get update && sudo apt-get install debconf ubiquity`to get the latest version when running the Live CD or you could wait for Herd 3 which will be released shortly.

Changed in ubiquity:
status: Unconfirmed → Rejected
status: Rejected → Unconfirmed
Nils Grundback (nilsg) wrote :

I get the same error/crash when I manually reformat the UFS partition to ext3 with gparted (from within the livecd) and then try to do the hard disk installation.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers