Installer creates no BIOS boot partition on UEFI system, system becomes unbootable after automatic update

Bug #820723 reported by Lev Kandel
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

A clean install of Natty on a UEFI (ASUS P8P67) system gives me this layout:

$ sudo parted /dev/sda print
Model: ATA Corsair CSSD-F12 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 17.4kB 20.0MB 20.0MB fat16 boot
 2 20.0MB 111GB 111GB ext4
 3 111GB 120GB 8569MB linux-swap(v1)

The installation is successful and the system boots fine. But subsequently, the automatic update replaces grub-efi with grub-pc and the system becomes unbootable (grub-install complains: "This GPT partition label has no BIOS Boot Partition; embedding won't be possible!")

I tried reinstalling the system from scratch and got exactly the same problem again. I also tried "upgrading" the broken system from LiveUSB instead of reinstalling it from scratch, but that didn't help. Eventually I fixed the problem by manually reinstalling grub-efi instead of grub-pc. In Question #166162, I was advised that the installer should have created a bios_grub partition, hence this bug.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubiquity (not installed)
Uname: Linux 3.0.0-0300-generic x86_64
Architecture: amd64
Date: Wed Aug 3 22:20:40 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: Upgraded to natty on 2011-07-14 (21 days ago)

Revision history for this message
Lev Kandel (y5b2rqi02) wrote :
tags: added: ubiquity-2.6.10
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Timothy Jones (timjones17) wrote :

I had the same problem as Lev:

Clean install of Natty 64-bit on a Sapphire Pure Fusion Mini E350 AMD E-350 APU (1.6GHz, Dual-Core) Hudson M1 Mini ITX. After running the automatic update the system becomes unbootable and the grub rescue> prompt appears.

Lev's solution of manually loading grub-efi fixed the problem.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

This looks like it might be a duplicate of bug 811485 (?)

Revision history for this message
Rod Smith (rodsmith) wrote :

This bug's title is misleading. The BIOS Boot Partition is required (or at least recommended), as the partition's name suggests, on *BIOS-based* systems. On UEFI-based systems, this partition is NOT required.

The bug reported seems to be that a proper installation of grub-efi (GRUB for EFI/UEFI systems) is being replaced by an improper installation of grub-pc (GRUB for BIOS systems) when GRUB is updated. Since grub-pc tries to install to a BIOS Boot Partition on GPT disks, it generates the reported error message, but that message is misleading.

Revision history for this message
Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 879858, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions