partition editor and mount point selector should display the same labels of the "computer" place

Bug #81676 reported by Vincenzo Ciancia on 2007-01-26
6
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Wishlist
Unassigned
Nominated for Feisty by Vincenzo Ciancia

Bug Description

Binary package hint: ubiquity

During installation from live cd, I can browse my hard drive partitions from the "computer" place, however there is no simple way to know to what partition, in the partition editor and mount point preparation dialog, a volume in "computer://" points to. Everything is there to allow people to browse their hard drives before partitioning, if I open a terminal window and type "mount" after opening volumes in computer://, I can solve my problem, however it is uncomfortable.

In the partition editor, names of partitions should reflect their name in "computer://", and, for each partition shown in computer://, there should be a link allowing to directly browse the partition.

In the mount point preparation screen, labels should be the same shown in "computer://". Finally, we should check if, after changing a label in the partition editor, "computer://" will reflect changes immediately or file a separate bug on that.

Adam Niedling (krychek) wrote :

This is not a bug. Please suggest your ideas to brainstorm.ubuntu.com . Please specify the version of Ubuntu you're using when you report a bug.

Changed in ubiquity:
status: New → Invalid
Vincenzo Ciancia (vincenzo-ml) wrote :

For me this is an usability bug. You need to have a coherent way to name partitions in the installation system, not because of purely estetic reasons, but because the only way to know the contents of a partition is by going trough "my computer". There is no way to browse partitions from the partition editor (which would make this usability problem disappear, too, in a much more elegant way).

Without being an "hacker" you have no way to tell which partition you are actually going to resize. The release of ubuntu does not matter since all releases of ubuntu are affected by this problem.

I personally don't care if you want to close this bug. Since in my opinion this is debatable, tough, I kindly ask you to at least try to discuss if this is a bug or not on the ubuntu-devel mailing list. Please try to understand that I ask you this for just one reason: usability bugs are always questionable, but I reported many of them and don't want my (very basic and rough) analysis work to be completely wasted.

I can try to make you change your mind on this being a bug as follows: the solution to this problem, which exists, is not to implement a new component, but rather to fix current code by adding one more piece of information to the partition label in the partition editor. This is a matter of not too many lines of code I suppose, while brainstorm seems to be oriented towards missing components in ubuntu and new features.

If there is another way to tell what are the contents of the partition you're going to resize (e.g. because you have three windows partitions on a drive and want to tell which one is the empty one), just tell me, I may be wrong in my considerations.

Changed in ubiquity:
status: Invalid → New
Gaetan Nadon (memsize) wrote :

Hi Vincenzo,

I agree with the issues you raised. I also ran into this while installing or just wanting to browse files on a specific partition. I have recently joined the BugSquad team so I read about the bug process and so on. I had never seen the Ubuntu Brainstorm yet. I must say I was pleasantly surprised. I read many ideas to ensure they were similar in scope to what you suggested, and they were. In fact, others have already reported your issues plus some more, e.g. "Display volume labels in the Ubuntu installer". 395 members have voted for this idea.
http://brainstorm.ubuntu.com/idea/9042/

I could be wrong, but I think Ubuntu made a conscious decision of handling usability issues through brainstorm rather than through bug reports. I think it is much more effective. You may also use the ubuntu-devel-discuss mailing list. An alternative which would retain this bug report is for me to confirm it and for the Bug Control team to set the importance to "wishlist". Let me know which way you prefer.

Thank you for taking the time to report this issue and helping to make Ubuntu better.

BugSquad

Changed in ubiquity:
status: New → Incomplete
Ralph Janke (txwikinger) on 2009-10-04
Changed in ubiquity (Ubuntu):
importance: Undecided → Wishlist
Charlie Kravetz (charlie-tca) wrote :

Thanks for submitting this bug. I am confirming it as a wishlist bug. It would be very nice to have all mount points descibed the same.

Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers