Live session switches to VT console briefly

Bug #813065 reported by Chad A. Davis on 2011-07-19
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Stéphane Graber
Oneiric
High
Stéphane Graber

Bug Description

ISO testing ubuntu/lucid-desktop-amd64.iso from 2011-07-19

Expected: "Try ubuntu" to load the desktop as a live session
Actual: After clicking "Try ubuntu", first switches to a VT console, then switches back before starting the desktop.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: ubiquity 2.2.27
ProcVersionSignature: Ubuntu 2.6.32-33.70-generic 2.6.32.41+drm33.18
Uname: Linux 2.6.32-33-generic x86_64
Architecture: amd64
Date: Tue Jul 19 18:25:09 2011
LiveMediaBuild: Ubuntu 10.04.3 LTS "Lucid Lynx" - Release amd64 (20110719.1)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity

Related branches

Chad A. Davis (chadadavis) wrote :
Colin Watson (cjwatson) on 2011-07-20
summary: - Live sesssion switches to VT console briefly
+ Live session switches to VT console briefly
tags: added: ubiquity-2.2.27
Chad A. Davis (chadadavis) wrote :

Affects Oneiric daily ISO (2011-09-01, from Beta 1 ISO testing)

tags: added: oneiric
Chad A. Davis (chadadavis) wrote :

Also affects kubuntu (ISO from kubuntu-oneiric-desktop-amd64+mac.iso from 2011-09-21)

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Brian Murray (brian-murray) wrote :

I was able to recreate this using an Oneiric amd64 desktop CD image from today - 2011-10-03.

Changed in ubiquity (Ubuntu):
importance: Medium → High
status: New → Confirmed
Brian Murray (brian-murray) wrote :

This is actually likely a casper bug.

affects: ubiquity (Ubuntu) → casper (Ubuntu)
Steve Langasek (vorlon) on 2011-10-04
Changed in casper (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
tags: added: rls-mgr-o-tracking
Steve Langasek (vorlon) wrote :

Targeting for oneiric.

There will always be a switch from graphics to text mode here, because the ubiquity menu session has to drop to make room for the "try ubuntu" live session - kill one X server, start the next. What we shouldn't have, though, is any text on this screen when we do so.

The exact text contents there are going to depend on the timing of plymouth vs. /etc/init/rc. The messages generated while plymouth is still running should all be redirected, but once plymouth shuts down they'll go to the console (and are meant to for debuggability if things break partway through). So something needs to take care of clearing the console once we're satisfied that we have a successful boot.

The best time to do this would be right before ubiquity shuts down the first X session. In fact, we might want to arrange to do the same thing from the DM on the running system at shutdown.

BTW, Colin says that these messages should also be logged to /var/log/boot.log, but I'm not sure that's the case when plymouth has already exited.

Steve Langasek (vorlon) wrote :

Bug #22819 tracked how this was handled once for usplash.

Changed in casper (Ubuntu Oneiric):
assignee: Ubuntu Installer Team (ubuntu-installer) → Stéphane Graber (stgraber)
Stéphane Graber (stgraber) wrote :

Just commited a fix for this to ubiquity's trunk that will be part of ubiquity 2.8.3.

Unfortunately I couldn't reliably reproduce this issue in a VM, so it'd be great if you could re-test with tomorrow's daily build (assuming we have ubiquity 2.8.3 on it).

Changed in casper (Ubuntu Oneiric):
status: Confirmed → Fix Committed
affects: casper (Ubuntu Oneiric) → ubiquity (Ubuntu Oneiric)
Steve Langasek (vorlon) wrote :

Tested this patch out, it doesn't fix the issue. I think stdin/stdout for ubiquity-dm isn't attached to the right place, with the result that the 'clear' command has no effect.

Setting back to triaged; merge proposal pending.

Changed in ubiquity (Ubuntu Oneiric):
status: Fix Committed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.8.3

---------------
ubiquity (2.8.3) oneiric; urgency=low

  * Skip LTSP from the list of networks to copy to the target.
    This is a temporary network created by Edubuntu's LTSP live.
  * Fix PROXY url as the gsettings host key already contains http://
  * Only disable set the gsettings keys once in gtk_ui (LP: #657086)
  * Properly handle keys in gsettings that are empty/not set.
  * Don't crash when the no-proxy list is empty. (LP: #867620)
  * Clear the console just before killing X in ubiquity-dm. (LP: #813065)
 -- Stephane Graber <email address hidden> Tue, 04 Oct 2011 21:01:09 -0400

Changed in ubiquity (Ubuntu Oneiric):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers