Oneiric installer crash: not enough space to unpack kernel headers, different size needed for btrfs

Bug #806784 reported by Glen Ditchfield on 2011-07-07
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Ubuntu Installer Team
Oneiric
Medium
Evan
Precise
Medium
Ubuntu Installer Team

Bug Description

Installer crash while running through ISO test case "Desktop Manual Partitioning (Ubiquity)" http://testcases.qa.ubuntu.com/Install/DesktopManual with image http://cdimage.ubuntu.com/kubuntu/daily-live/20110705/oneiric-desktop-i386.iso.

I had enough free disk space, was plugged in to a power source, and was *not* connected to the Internet.
I selected manual partitioning, removed 6000 MB from the last partition, and created a new partition formatted with btrfs and mounted at "/".
I chose time zone Canada/Central and keyboard English (US)/English (US).
The progress dialog reached "Installing system 64%", then threw up the "Installer crashed" dialog.

Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :
tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Error from the log:
Jul 6 18:21:50 ubuntu ubiquity: Unpacking linux-headers-3.0-3 (from .../linux-headers-3.0-3_3.0-3.4_all.deb) ...
Jul 6 18:22:31 ubuntu ubiquity: dpkg: error processing /cdrom//pool/main/l/linux/linux-headers-3.0-3_3.0-3.4_all.deb (--unpack):
Jul 6 18:22:31 ubuntu ubiquity: unable to install new version of `/usr/src/linux-headers-3.0-3/arch/blackfin/include/asm/tlbflush.h': No space left on device

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
summary: - Oneiric installer crash
+ Oneiric installer crash: not enough space to unpack kernel headers

Looks like perhaps we need to use different size limits for the special case of btrfs.

Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
tags: added: oneiric
tags: added: ubiquity-2.7.10

Exception during installation:
Jul 6 18:22:54 ubuntu ubiquity: Error in function:
Jul 6 18:22:54 ubuntu plugininstall.py: SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
Jul 6 18:22:54 ubuntu plugininstall.py:

tags: added: installer-crash
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Steve Langasek (vorlon) on 2011-09-22
summary: - Oneiric installer crash: not enough space to unpack kernel headers
+ Oneiric installer crash: not enough space to unpack kernel headers,
+ different size needed for btrfs
Changed in ubiquity (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Medium
tags: added: rls-mgr-p-tracking
removed: rls-mgr-o-tracking
Michael J Kane (wa1pjg) on 2011-10-13
Changed in ubiquity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
Changed in ubiquity (Ubuntu Oneiric):
status: Fix Released → Confirmed
Steve Langasek (vorlon) on 2011-10-26
tags: added: rls-p-tracking
Steve Langasek (vorlon) on 2011-11-16
Changed in ubiquity (Ubuntu Precise):
milestone: none → ubuntu-12.04
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
Changed in ubiquity (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Dunkirk (david-davidkrider) wrote :

So what's the upshot here? I'm being forced into trying btrfs because there seems to be a bug with 10.10, ext4, and (my) SSD. If I can't get this installed, what's the alternative? Fall back to 11.04? Is there no workaround to get 11.10 installed on btrfs?

Dunkirk (david-davidkrider) wrote :

Answering myself with the obvious. The 11.04 installer doesn't seen have a problem here. I'll finish installing, and just do a dist-upgrade.

Dunkirk (david-davidkrider) wrote :

Uh... nevermind. As soon as it installed 3.0.0 on the new version, it blew up just like before. I'm concluding that btrfs on Ubuntu is considered harmful.

There's two hours I'll never get back.

Sergey Galtsev (sam-j811) wrote :

Am I reading it right, that short of not using btrfs there is no workaround?

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 220961, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Changed in ubiquity (Ubuntu Oneiric):
status: Won't Fix → Confirmed

I just downloaded the oneiric server iso, and tried to install oneiric on a KVM virtual machine. It fails with writing the linux-image-3.0.0-16-server package, where it tries to write some kernel modules (.ko file). By switching to virtual console 4, I could see the error message, which is: No space left on device.

This is in error, as there was plenty of space on all of the filesystems. All had the btrfs, except /boot, which had ext4.
In the end, I could finish the installation by letting the installer choose its own partitioning, and choice of filesystems.
This time around, the system has lvm, with separate filesystems for /, /usr, /var, /tmp and /boot. And swap.
/boot is now ext2, and all others except swap are ext4.

But now, after installing and logging into the system, apt-get dist-upgrade fails with the same error: No space left on device. Again in the same linux-image package.

So now I cannot dist-upgrade. So it does not seem like a btrfs error to me, since the same erroneous `No space left on device´ now happens again. No filesystem is full, /var is only 14% full, and all others less than that.

I think the error is somewhere in the apt system, maybe in the way it calculates disk space, or possibly the error is in the linux-image package itself.

I really do not understand why this bug is closed and marked Won't Fix. After all, how is it possible to succesfully install if you simply let the installer run its course? It will fail every time.

Seems like an extremely CRITICAL bug to me: it prevents you from installing oneiric server.

If you're getting "No space left on device" when there is in fact space
free, then that's not a problem with either the installer or apt; the
problem must be at least as low-level as the kernel.

Since you mention that you're installing in KVM, you should also check
that there is sufficient space on the host disk, of course.

@cjwatson: The bug is gone if I install a precise pangolin system instead, with the same specs otherwise (i.e. as a KVM virtual machine, same partition layout, same filesystem sizes and types, etc.). Precise installs just fine, no problems at all.

My guess is that it is a problem with the kernel package that oneiric wants to upgrade to.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments