OEM Install fails with - KeyError: "The cache has no package named 'python2.6-minimal'" - without network connection.

Bug #806349 reported by Colin Ian King on 2011-07-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Oneiric
High
Colin Watson

Bug Description

Failure mode: ISO testing, OEM Desktop install.

ISO Image: http://cdimage.ubuntu.com/daily-live/20110705.1/oneiric-desktop-amd64.iso
H/W: Dell Inspiron 6400 laptop
Test case: http://testcases.qa.ubuntu.com/Install/DesktopOem, failed on Case ID: uoi-002 (Desktop Ready For End User)

Got ubiquity error (see attached photo).

Colin Ian King (colin-king) wrote :
Colin Ian King (colin-king) wrote :

Attached: gzip tar of /var/log

tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

The error from the log is
Jul 6 08:23:43 oem-MM061 plugininstall.py: Exception during installation:
Jul 6 08:23:43 oem-MM061 plugininstall.py: Traceback (most recent call last):
Jul 6 08:23:43 oem-MM061 plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1653, in <module>
Jul 6 08:23:43 oem-MM061 plugininstall.py: install.run()
Jul 6 08:23:43 oem-MM061 plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 55, in wrapper
Jul 6 08:23:43 oem-MM061 plugininstall.py: func(self)
Jul 6 08:23:43 oem-MM061 plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 150, in run
Jul 6 08:23:43 oem-MM061 plugininstall.py: self.configure_python()
Jul 6 08:23:43 oem-MM061 plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 310, in configure_python
Jul 6 08:23:43 oem-MM061 plugininstall.py: cachedpython = cache['%s-minimal' % python]
Jul 6 08:23:43 oem-MM061 plugininstall.py: File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 177, in __getitem__
Jul 6 08:23:43 oem-MM061 plugininstall.py: raise KeyError('The cache has no package named %r' % key)
Jul 6 08:23:43 oem-MM061 plugininstall.py: KeyError: "The cache has no package named 'python2.6-minimal'"
Jul 6 08:23:43 oem-MM061 plugininstall.py:

Can you confirm that the system was disconnected from the network (it looks like there's no wired network and wireless was not configured) ?

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
summary: - Installer crashed, http://cdimage.ubuntu.com/daily-live/20110705.1
- /oneiric-desktop-amd64.iso
+ OEM Install failed - KeyError: "The cache has no package named
+ 'python2.6-minimal'"

Just to confirm, the laptop was not connected to the network (no ethernet connection and the wireless was not yet associated with my Access Point)

Jean-Baptiste Lallement (jibel) wrote :

It is reproducible when running an OEM install without network connection.

Thanks.

Changed in ubiquity (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
importance: Medium → High
status: Incomplete → Triaged
summary: - OEM Install failed - KeyError: "The cache has no package named
- 'python2.6-minimal'"
+ OEM Install fails with - KeyError: "The cache has no package named
+ 'python2.6-minimal'" - without network connection.
Colin Watson (cjwatson) on 2011-07-06
Changed in ubiquity (Ubuntu Oneiric):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.7.11

---------------
ubiquity (2.7.11) oneiric; urgency=low

  [ Luke Yelavich ]
  * Use at-spi2 dbus launcher to start the at-spi2 daemon
  * Determine accessibility state from gsettings using the gsettings command,
    to make sure privileges are dropped

  [ Colin Watson ]
  * Handle the case where one of the packages returned by 'pyversions -s' or
    'py3versions -s' is not installed (LP: #806349).
  * Add --config=Mode:0644 to debconf-copydb call, as otherwise we leave
    /var/cache/debconf/config.dat mode 0600 in the installed system,
    breaking the first run of some package management frontends
    (LP: #442941).
  * Provide build-arch and build-indep debian/rules targets.
  * Automatic update of included source packages: console-setup
    1.57ubuntu21, flash-kernel 2.28ubuntu26.
 -- Colin Watson <email address hidden> Thu, 07 Jul 2011 23:28:05 +0100

Changed in ubiquity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers