Ubuntu

ubiquity crashed with ValueError in command(): I/O operation on closed file

Reported by Taro on 2011-06-04
344
This bug affects 54 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Oneiric
High
Unassigned
Precise
High
Dimitri John Ledkov

Bug Description

Binary package hint: ubiquity

I got this problem when I was trying clicking the Install Ubuntu 11.04 from the desktop on Asus 1215B red.

TEST CASE
1. Boot from a Live media
2. At Ubiquity Greeter click on 'Try Ubuntu' and start a live session
3. Start ubiquity
4. Proceed to step 'Prepare'
5. Click on 'Continue' then quickly click on 'Quit' on the main dialog then 'Quit' on the confirmation dialog before the UI switches to step 'partman'

Note:
Timing seems important and you need to repeat steps 3 to 5 and clicking at slightly different moment until it crashes. It is easier to reproduce on low-end hardware than VM.
Also I reproduced it more often with other languages than english.

ACTUAL RESULT
This crash or UI hang

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: ubiquity 2.6.10
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Fri Jun 3 21:24:09 2011
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/3371/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with ValueError in command(): I/O operation on closed file
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Taro (taroo) wrote :
Taro (taroo) on 2011-06-04
description: updated
visibility: private → public
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
tags: added: oneiric
Brian Murray (brian-murray) wrote :

One of the duplicates contains the following in the description, "I open it to install Ubuntu and select advanced then when reaching select partition I cancel it, so it crashed.", perhaps that will recreate it.

tags: added: bugpattern-written
removed: bugpattern-needed oneiric
tags: added: oneiric
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in ubiquity (Ubuntu):
importance: Medium → High
Changed in ubiquity (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
John Woodley (johnmwoodley) wrote :

I am using Ubuntu 11.04 Desktop x64 Live
I am adding 2 screen shots of the message.

I first browsed a failed install from the Live disk which failed because my USB hardware (COOLMAX) froze. I then attached the Hard drive internally to attempt another install after unmounting from browsing the file system. I then while the Install Ubuntu 11.04 was running decided to open Disk Utility and then wanted to check the Partition integrity which it could not while the install interface was running but before making changes, I quit. Once I quit the install, I was able to run the File system check which complete as clean and the Application problem (Sorry, the program "ubiquity" closed unexpectedly) happened.

So here I am, and only have the screen shots of when receiving the message.

John Woodley (johnmwoodley) wrote :

Adding the /var/logs/ Logs dated today from the Live session.

Not sure where the apport log went when the report was generated as it told me this was already a reported issue, I am just trying to add what I did to help you figure out the issue.

tags: added: ubiquity-2.6.10
Istarion-rus (istarion-rus) wrote :

I had installed Ubuntu 11.04 on my 1215B black. He can't wake up after suspend, but working correctly, how i can see.

Istarion-rus (istarion-rus) wrote :

Sorry, I've not saw about 64 bit platform. I'm installed x86 from flash drive using unetbootin from Arch Linux AUR. Yesterday.

Colin Watson (cjwatson) on 2011-08-26
Changed in ubiquity (Ubuntu Oneiric):
milestone: ubuntu-11.10 → ubuntu-11.10-beta-2
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Steve Langasek (vorlon) wrote :

Long-lived bug, but it seems to be a corner case (only happens when cancelling out of advanced partitioning?). Turfing for oneiric.

Changed in ubiquity (Ubuntu Oneiric):
status: Triaged → Won't Fix
Steve Langasek (vorlon) on 2011-09-23
Changed in ubiquity (Ubuntu):
milestone: ubuntu-11.10-beta-2 → none
tags: added: iso-testing
tags: added: rls-mgr-p-tracking
removed: rls-mgr-o-tracking
Steve Langasek (vorlon) on 2011-10-26
tags: added: rls-p-tracking
Steve Langasek (vorlon) on 2011-11-16
Changed in ubiquity (Ubuntu Precise):
milestone: none → ubuntu-12.04
Omer Akram (om26er) wrote :

Currently experiencing the same issue on today's live build, will now restart the live session to check if the issue happens again. reported as bug 894788

Colin Watson (cjwatson) wrote :

I believe that this is ultimately a regression caused by the fix for bug 756920 (ubiquity r4693). In order to try to ensure that the boot loader choice was recorded in debconf in every possible code path, this was done in exit_ui_loops as a sort of "finally" handler. However, exit_ui_loops is only supposed to do frontend interaction, and (as this bug demonstrates) it isn't safe for it to attempt to talk to debconf. I think a correct fix would move this out of exit_ui_loops again and try to find a safer way to fix the original bug.

Barry Warsaw (barry) on 2012-03-19
Changed in ubiquity (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Barry Warsaw (barry)
status: Triaged → In Progress
Barry Warsaw (barry) wrote :

I've tried various scenarios for reproducing this and have failed. There's also bug 942111 which describes seeing this problem on bare metal install while wifi is setting up, but I don't have such hardware to test that on. If you have any other suggestions for reproducing this reliably in a hardware-independent way, please follow up. Despite Colin's comments in #9, I'm reluctant to change this code without a test case.

Changed in ubiquity (Ubuntu Precise):
assignee: Barry Warsaw (barry) → Canonical Foundations Team (canonical-foundations)
status: In Progress → Incomplete
description: updated
description: updated
Changed in ubiquity (Ubuntu Precise):
status: Incomplete → Confirmed
Brian Murray (brian-murray) wrote :

I was able to recreate this by choosing something else in the partitioning choice and then clicking quit while "Scanning disks..." was still displayed and clicking "Quit" in the are you sure dialog. As mentioned in the description this needs to happen very quickly for the internal error dialog to be raised.

Changed in ubiquity (Ubuntu Precise):
status: Confirmed → Triaged
Barry Warsaw (barry) wrote :

Hi Brian. I've tried your recipe in #11 several times on various configurations (two completely different VM systems - I don't have a native machine to install on) and I am still unable to reproduce this. I'm probably just not being quick enough.

I always reproduce the crash on bare hardware (Mac booted from CD) not in VMs when I quit Ubiquity from the manual partitioner. It doesn't depend on the speed at which I quit Ubiquity.

Barry let me know if I can provide more information. You can also test from a Live session on your Mac since the test is non-destructive (as long as you don't click on 'continue' in partman ;))

Colin Watson (cjwatson) on 2012-04-04
Changed in ubiquity (Ubuntu Precise):
assignee: Canonical Foundations Team (canonical-foundations) → Colin Watson (cjwatson)
Colin Watson (cjwatson) on 2012-04-04
Changed in ubiquity (Ubuntu Precise):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.7

---------------
ubiquity (2.10.7) precise; urgency=low

  [ Colin Watson ]
  * Fix partman plugin to preseed grub-installer/bootdev in a cleanup method
    rather than exit_ui_loops, since talking to debconf in the latter isn't
    safe (LP: #792652). Adjust how maybe_update_grub gets the default boot
    device to avoid regressing LP #756920.

  [ Stéphane Graber ]
  * Add support for Windows 8 user directory detection.
  * Make wubi work when the OS data partition is different from the boot
    partition. (LP: #772470)
  * Call gsettings through dbus-launch in an hope to ensure its changes
    are saved to disk. (LP: #960096)
  * Make ubiquity depend on dbus-x11 for dbus-launch.
  * Update compat/os-proper to make a different cache when listing OS
    data partitions. (LP: #772470)
  * Automatic update of included source packages: migration-assistant
    0.6.12.
 -- Stephane Graber <email address hidden> Wed, 04 Apr 2012 20:56:08 -0400

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
RobinJ (robinj) wrote :

What do you mean "Fix released"? It just happened to me on the "stable" version.
Ubuntu 12.04 LTS, AMD64, running Unity 3D

Clean3d (clean3d) wrote :

I also experienced this bug today after choosing "install Ubuntu" for 12.04 and connecting to my wireless network.

On Thu, Apr 26, 2012 at 04:36:12PM -0000, RobinJ wrote:
> What do you mean "Fix released"? It just happened to me on the "stable" version.

Please open a new bug. We fixed one cause of this; therefore this
symptom must have multiple causes, and your problem would be better
tracked in a new bug, where we can analyse it afresh.

The crash program leaded me to this bug. I get this bug exiting the ubiquity on partition part.

k65 (petersanders65) wrote :

I also experience this with the Ubuntu 12.04 stable image. And since the crash program alse led me to this bug I agree with Luiz Angelo Daros de Luca that it would be kinda weird to create a new bug for it..

brewmanz (brewmanz) wrote :

I went through some Ubunty 12.04 install steps. Booted from CD onto Ubuntu 11.10 box, did not unmount drives, then decided not to do it just yet. I cancelled install & got this error

Ed Smith (resmith) wrote :

I was sent to this page after getting an error trying to QUIT out of Ubuntu install. I had deleted the HP_TOOLS partiiton and resized the Windows partition on my HP laptop and then the installation procedure said that something needed to be done to the disk partitions. I didn't know how to respond so tried to Quit by hitting the Quit button. And then I got this error.

Will Bellman (wbellman) wrote :

On my end I had gone into the "Something else" option on the hard drive setup portion of the tool.

I got this in the terminal window: (ctrl-alt-f1)

[paraphrasing since no cut and paste]

ata1.00 exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata1.00 BDMA2 Stat 0x282c1309
ata1.00 Failed command: READ DMA
ata1.00 cmd c8/00:08:00:01:00/00:00:00:00:00/e0 tag 0 dma 4096 in
               res 51/40:00:06:01:00/00:00:00:00:00/00 Emask 0x9 (media error)
ata1.00 status: { DRDY ERR }
ata1.00 error: { UNC }

[loops, I think I got everything}

My secondary drive in theis machine is a terabyte drive known for eccentricity. I believe it's the first on the ata chain.

Anushaath (anushaath-p) wrote :

It's just the first day of ubuntu 12.04 and i'm having this problem.Please someone fix this one, my first impression of ubuntu is gitting bad...

Changed in ubiquity (Ubuntu):
assignee: Colin Watson (cjwatson) → Anushaath (anushaath-p)
Stéphane Graber (stgraber) wrote :

This bug has been marked as fixed, as Colin said before, if you're still seeing similar symptoms, please file a new bug.
Also, please don't change the assignee unless you're actually the one working on the fix (which isn't the case here).

Changed in ubiquity (Ubuntu):
assignee: Anushaath (anushaath-p) → Colin Watson (cjwatson)
Maximo (rartayer) wrote :

Besides the actual bug, when I try to open an app from the left bar PC freezes and shows vertical irregular dotted lines in different colours and I have to shut down the PC from the I/O button. Before anything I made a regular scan to see if the CD/DVD is well recorded and no problems.

Jesse Moorman (moorman-jesse) wrote :

I was trying to install 12.04 32 bit on a SanDisk Extreme 16GB SD card (C10, U1, 45MB/s) in the MMC slot on my Sony Vaio VPCCW27FX notebook (January 2010 vintage). Ubuntu recognized my hardware, and paused the installation to advise creation of a Swap partition on the SD card. Ubuntu then warned that it might take a long time. Knowing that Ubuntu actually installs rather fast, even on slow HDDs, I thought it would be no problem, but it took a really long time and I eventually chose "Quit." I did this first on the initial bootup from the CD, and Ubuntu then loaded the Live session. So I tried it again with the desktop icon, and Ubuntu showed the Swap partition taking up the entire 16 GB. When I tried to move on to the installation (maybe I tried to change the Swap partition, or to re-write it as 1500 MB), Ubuntu said it needed to write previous operations to disk, and then it took another very long time. When I Quit again, I got this error.

Joe Upham (myeweb) wrote :

I actually ran into this bug as well. I tried several times to install 12.04 LTS 64 bit on a empty hard drive through a live USB Drive. I have found that this is caused by trying to install while the options for downloading updates and the third party software is checked. i am currently installing without the updates and 3rd party software and it is running fine.

dotnetCarpenter (activ876) wrote :

I just ran into this bug doing exactly what Brian Murray (brian-murray) wrote in the second comment, with a 12.04 LTS 32 bit version of Ubuntu (downloaded Saturday the 26th of May 2012).
"One of the duplicates contains the following in the description, "I open it to install Ubuntu and select advanced then when reaching select partition I cancel it, so it crashed.", perhaps that will recreate it.|

My variation was that I tried to resize a HFS+ (Mac) partition before quitting the installation. The live usb was created using usb-creator-gtk on another ubuntu box.

I'm running a faikraid and during install ubuntu fails while creating the swap partition. This is the bug that comes up.

Charly (rafis3) wrote :

well try sudo remove compix this will also remove unity and then
install cairo-dock.

beleive me it will be a big relief to your memory and the comp is fast

tested on 12.04

On 6/4/12, Keith Nicholson <email address hidden> wrote:
> I'm running a faikraid and during install ubuntu fails while creating
> the swap partition. This is the bug that comes up.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/792652
>
> Title:
> ubiquity crashed with ValueError in command(): I/O operation on closed
> file
>
> Status in “ubiquity” package in Ubuntu:
> Fix Released
> Status in “ubiquity” source package in Oneiric:
> Won't Fix
> Status in “ubiquity” source package in Precise:
> Fix Released
>
> Bug description:
> Binary package hint: ubiquity
>
> I got this problem when I was trying clicking the Install Ubuntu 11.04
> from the desktop on Asus 1215B red.
>
> TEST CASE
> 1. Boot from a Live media
> 2. At Ubiquity Greeter click on 'Try Ubuntu' and start a live session
> 3. Start ubiquity
> 4. Proceed to step 'Prepare'
> 5. Click on 'Continue' then quickly click on 'Quit' on the main dialog
> then 'Quit' on the confirmation dialog before the UI switches to step
> 'partman'
>
> Note:
> Timing seems important and you need to repeat steps 3 to 5 and clicking at
> slightly different moment until it crashes. It is easier to reproduce on
> low-end hardware than VM.
> Also I reproduced it more often with other languages than english.
>
> ACTUAL RESULT
> This crash or UI hang
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: ubiquity 2.6.10
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic x86_64
> NonfreeKernelModules: wl
> Architecture: amd64
> Date: Fri Jun 3 21:24:09 2011
> ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
> InterpreterPath: /usr/bin/python2.7
> LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
> ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
> ProcEnviron: Error: [Errno 13] Permission denied: '/proc/3371/environ'
> PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
> SourcePackage: ubiquity
> Title: ubiquity crashed with ValueError in command(): I/O operation on
> closed file
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups:
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/792652/+subscriptions
>

vel (raccoondogvel) wrote :
Download full text (3.9 KiB)

Originally tried to install BlenderBuntu 11.10 onto a USB flash drive (drive alpha); BIOS doesn't detect it as bootable (skips to default boot from HD to windows). Thought it was a problem with the drive, tried installing on 2nd (drive beta - overwriting "security software" included with drive); still no detection. Burned a boot installation CD and proceeded to partition both drives wih 6 GB FAT32 6GB ext4 rest swap (16GB drive alpha), install to... ext4 I'm guessing (no idea if it succeeded); reboot on install completion and no boot. Retried process with other USB flash drive and same result.

Gave Ubuntu 12.04 a shot. In Windows, downloaded desktop ISO and utility linked from Ubuntu website that allowed me to write the image straight to the USB flash drive (drive alpha - partitioning / formatting from previous attempt intact). On restart, no boot. Back in windows, performed the same procedure on drive beta. Reboot... instead of getting the installation screen that a CDROM bootable installation setup would give me, it leaves me on the same black screen you see when the BIOS finishes listing hard drive S.M.A.R.T. info and BIOS IRQ assignments with a message saying something along the line of "kernel not found" or path to or something, the next line a colon followed by I guess me having to enter the path to said kernel. (No previous knowledge of what a kernel file looked like, so I rebooted).

(omitting various live test runs of U12.04LTS desktop from cd boots)
(omitting attempt to CD-boot, install 12.04 to drive alpha - forgot the outcome)

CD booting the Ubuntu 12.04 installer (onto drive beta), I tell it to Upgrade existing 11.10 install to 12.04. On the screen after that where it requires me to hit next, a popup appears and says partition /cdrom must be unmounted before it can continue... I was like, "Huh?" I thought I was installing from said CD mount... I click next to disregard, and the system seemed to hang. Clicking previous, next, hitting the x on the popup - no sound or activity from any drives or CD. Soft rebooted.

2nd attempt at above install on (beta). Same steps, though this time, my CD wasn't making any noise (on Ubuntu, it always maxes out the drive rpm on any reads, it's very noticeable). Chose Upgrade existing 11.10 to 12.04. The next screen, instead of the previous "unmount /cdrom" prompt, tells me I need to make my partition larger than 2.5 GB to install. Strange, though, as the next screen which is the partition manager setup, tells me my USB drive is 6GB FAT32 1GB ext4 1GB something else, remainder swap (I don't know at what point the middle ext4 turned into two drives). Also strange is that, on all my previous install attempts and live sessions, my two FAT32 drives connected through my ancient Promise ATA 100 raid (not configured for any striping) aren't showing up in the manager this time. At any rate, deleted the 1/1/rest partitions (left 6GB FAT32 unchanged) and went something with 6/6/rest FAT32/ext4/swap. Tried hitting next, gave me "can't install without a file system yet being defined" message (which I've seen trying from trying BlenderBuntu manual partitioning - it's always stopped me). Cleared the message; thi...

Read more...

Solaris (kamshadman) wrote :

I stopped hardware configuration/partitioning. I quit from installation process. the system couldn't get back to desktop cd live.

Colin Watson (cjwatson) on 2012-09-24
Changed in ubiquity (Ubuntu):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.12.3

---------------
ubiquity (2.12.3) quantal; urgency=low

  * Do not preseed grub-install, if we are not proceeding to install. This
    should fix ValueError, I/O operation on closed file (LP: #1027648)
    (LP: #792652)
  * Automatic update of included source packages: yaboot-installer
    1.1.22ubuntu2.
 -- Dmitrijs Ledkovs <email address hidden> Mon, 24 Sep 2012 11:23:57 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubiquity (Ubuntu Precise):
status: Fix Released → Triaged
assignee: Colin Watson (cjwatson) → Dmitrijs Ledkovs (xnox)
Changed in ubiquity (Ubuntu Precise):
status: Triaged → In Progress

Hello Taro, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.21 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello Taro, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.22 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Dimitri John Ledkov (xnox) wrote :

(reopened after a dupe bug #1027648 got filed)

Triggering this bug is inherently racy. I have tried to trigger it back & forth myself with precise-daily image and did not manage so. Second time around, this bug was brought to our attention through crash database.

The statistics for this crash signature are here: https://errors.ubuntu.com/bucket/?id=%2Fusr%2Flib%2Fubiquity%2Fbin%2Fubiquity%3AValueError%3Awatch_debconf_fd_helper%3Aprocess_input%3Await%3Acleanup%3Apreseed%3A%3Clambda%3E%3Acommand

There are no reports for versions 2.10.21, 2.10.22 and 2.10.23 which are currently in precise-proposed testing.

Please consider this bug verified for precise SRU.

Colin Watson (cjwatson) on 2012-12-19
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.23

---------------
ubiquity (2.10.23) precise-proposed; urgency=low

  * Honour base-installer/kernel/altmeta when deciding which kernels to
    install or keep installed.

ubiquity (2.10.22) precise-proposed; urgency=low

  [ Dmitrijs Ledkovs ]
  * Make user-setup-encrypted-swap wait until partitioning has finished
    before attempting to adjust /target/etc/fstab. (LP: #1024343)
    (LP: #1068178)

  [ Colin Watson ]
  * Don't remove kernel headers just because we're removing signed kernel
    images of the same flavour (LP: #1070427).

ubiquity (2.10.21) precise-proposed; urgency=low

  [ Colin Watson ]
  * Fix missing parentheses that caused removable installation media
    sometimes to be selected as the default GRUB device (LP: #987418).
  * Support UEFI Secure Boot (LP: #1075181):
    - Try to install a signed kernel if base-installer asks for one, and
      don't leave signed kernels installed if it doesn't.
    - If the SecureBoot EFI variable is set, then ensure that
      grub-efi-amd64-signed and shim-signed remain installed.
    - Copy the signed kernel from /cdrom if it is not in the squashfs. If
      there is a signed kernel there but no unsigned one, then use sbattach
      to remove the signature and construct the unsigned kernel on the fly.
  * Automatic update of included source packages: base-installer
    1.122ubuntu7.2, grub-installer 1.68ubuntu5.1.

  [ Mario Limonciello ]
  * Don't let oem-config crash from an invalid server return on the timezone
    page. (LP: #887879)

  [ Dmitrijs Ledkovs ]
  * Do not preseed grub-install, if we are not proceeding to install. This
    should fix ValueError, I/O operation on closed file (LP: #1027648)
    (LP: #792652)
  * Prevent progress label to expand & shrink the window (LP: #1046241)

  [ Jonathan Riddell ]
  * Change from a KApplication to a QApplication to avoid using DBus, DBus
    as needed by KApplication no longer works with our multiple user changes
    LP: #1055967
 -- Colin Watson <email address hidden> Thu, 06 Dec 2012 17:20:32 +0000

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.