kubuntu installer crashes daily-live 6-1-11: AttributeError: 'QCheckBox' object has no attribute 'set_sensitive'

Bug #791446 reported by cpatrick08 on 2011-06-01
64
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Mackenzie Morgan
Oneiric
High
Mackenzie Morgan

Bug Description

Binary package hint: ubiquity

i downloaded the daily-live iso for kubuntu and when i go to install the installer crashes i get the following error message when it crashes

Traceback (most recent call last):
  File "/usr/lib/ubiquity/plugins/ubi-prepare.py", line 242, in check_returncode
    if not super(PageKde, self).check_returncode(args):
  File "/usr/lib/ubiquity/ubiquity/plugin.py", line 44, in wrapper
    return target(self, *args, **kwargs)
  File "/usr/lib/ubiquity/plugins/ubi-prepare.py", line 93, in check_returncode
    self.prepare_download_updates.set_sensitive(state)
AttributeError: 'QCheckBox' object has no attribute 'set_sensitive'

Related branches

cpatrick08 (cpatrick08) wrote :
cpatrick08 (cpatrick08) wrote :

it asked me to upload /var/log/partman also but i could not find the file on the live usb drive

tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Error from the logs:Jun 1 17:02:15 ubuntu ubiquity[6142]: Exception in KDE frontend (invoking crash handler):
Jun 1 17:02:15 ubuntu ubiquity[6142]: Traceback (most recent call last):
Jun 1 17:02:15 ubuntu ubiquity[6142]: File "/usr/lib/ubiquity/plugins/ubi-prepare.py", line 242, in check_returncode
Jun 1 17:02:15 ubuntu ubiquity[6142]: if not super(PageKde, self).check_returncode(args):
Jun 1 17:02:15 ubuntu ubiquity[6142]: File "/usr/lib/ubiquity/ubiquity/plugin.py", line 44, in wrapper
Jun 1 17:02:15 ubuntu ubiquity[6142]: return target(self, *args, **kwargs)
Jun 1 17:02:15 ubuntu ubiquity[6142]: File "/usr/lib/ubiquity/plugins/ubi-prepare.py", line 93, in check_returncode
Jun 1 17:02:15 ubuntu ubiquity[6142]: self.prepare_download_updates.set_sensitive(state)
Jun 1 17:02:15 ubuntu ubiquity[6142]: AttributeError: 'QCheckBox' object has no attribute 'set_sensitive'

Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
summary: - kubuntu installer crashes daily-live 6-1-11
+ kubuntu installer crashes daily-live 6-1-11: AttributeError: 'QCheckBox'
+ object has no attribute 'set_sensitive'
cpatrick08 (cpatrick08) wrote :

no problem do you know when it is expected to be fixed

Mackenzie Morgan (maco.m) wrote :

It's trying to speak GTK to a Qt object. First-draft patch is being tested now.

Changed in ubiquity (Ubuntu):
assignee: nobody → Mackenzie Morgan (maco.m)
status: Confirmed → In Progress
Scott Kitterman (kitterman) wrote :

First draft didn't do so well. If you need to make a Kubunt oneiric install in the meantime, us the alternate installer. It's been tested to work.

cpatrick08 (cpatrick08) wrote :

it should go in the release notes for alpha 1 since it is released today or the kubuntu one should be delayed

Mackenzie Morgan (maco.m) wrote :

Have a patch for this. Don't have a patch for where the live installer fails 5 minutes later.

Changed in ubiquity (Ubuntu):
milestone: none → oneiric-alpha-2
vmc (vmclark) wrote :

Still fails as of daily-live 6-9-11. Exact same failure as first posted.

Hoa Le (leth5591) wrote :

Today I tried the June 14 build of Kubuntu 11.10 daily-live CD. Same error message. Don't know how to copy and attach the 2 files /var/log/syslog and /var/log/partman.

By the way, I was attempting to install Kubuntu on a separate partition in a Windows 7 box with AMDX2 Athlon CPU and Geforce 7300GT (Nvidia driver). The disk was burned from the iso file, hash checked, then error checked before installing.

Mackenzie Morgan (maco.m) wrote :

Folks, you don't need to keep saying "it's still broken" -- the bug doesn't
say "Fix Released," does it?

vmc (vmclark) wrote :

Then fix it, or get someone with enough talent to fix it ! Its been over two weeks.

Charlie Kravetz (charlie-tca) wrote :

Bug reports are handled by humans, the majority of whom are volunteers, so please bear this in mind. If a developer is kind enough to begin working this issue, it is to all of our advantages not to be insulting and demanding. If you can fix a bug, jump in. If you can not, perhaps you want to triage bugs so the developers have more time to devote to fixing them? With over 1000 bugs a month reported, we should be grateful if a developer is able to get to the bug we are experiencing.

Mackenzie Morgan (maco.m) wrote :

There's a patch waiting for a code review. If you'd like to be
helpful, then test it so there's some test data for the reviewer to go
on.

Mackenzie Morgan (maco.m) wrote :

(Not that fixing this bug would make it possible for you to install
Kubuntu anyway -- there's some backend API changes that need to be
sorted out causing it to crash on the keyboard page)

Mackenzie Morgan (maco.m) wrote :

The change to fix committed means it's now in Ubiquity's bzr branch, but it won't be Fix Released until the next Ubiquity release (which happens every few days or week or so)

Changed in ubiquity (Ubuntu Oneiric):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.7.9

---------------
ubiquity (2.7.9) oneiric; urgency=low

  [ Colin Watson ]
  * Use pycompile (python-minimal) rather than py_compilefiles
    (python-central).
  * Add lightdm to lists of display managers in Upstart jobs (LP: #798328).
  * Automatic update of included source packages: base-installer
    1.119ubuntu3, netcfg 1.63ubuntu1.

  [ Mackenzie Morgan ]
  * make ubi-prepare.py handle cases where prepare_download_updates
    is Qt too (LP: #791446)
 -- Colin Watson <email address hidden> Thu, 16 Jun 2011 23:20:29 +0100

Changed in ubiquity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Hoa Le (leth5591) wrote :

It's great that the fix was released. When can I expect to find it in the daily build? In other words, how do I know a daily build has the fix so that I can install Kubuntu?

Mackenzie Morgan (maco.m) wrote :

I would expect today's to have it, but you still can't install from a
live cd because there are more bugs to fix. You have not been
prevented from installing altogether though. Alternate CDs have been
working fine this whole time.

cpatrick08 (cpatrick08) wrote :

can it be installed from live cd yet

Mackenzie Morgan (maco.m) wrote :

Should be able to now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments