ubiquity doubles stated filesystem size requirements

Bug #784020 reported by Radomir Dopieralski on 2011-05-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity
Incomplete
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

The download page on xubuntu.org says that it requires 2GB of disk space, whereas the installer refuses to install unless you have at least 4.4GB of free disk space.

Elizabeth K. Joseph (lyz) wrote :

The ubiquity installer itself sets a hard requirement of 4.4G and Xubuntu is caught in that, the alternative installer should not be impacted by the same limitation, made a note about it on the site and doing some tests.

Changed in xubuntu-website:
status: New → In Progress
Jonathan Marsden (jmarsden) wrote :

This is not a fixed limit in ubiquity, based on my own tests.

Rather, ubiquity now takes the value in casper/filesystem.size and doubles it, or something close to that!

The doubling is a new thing, added ~3 weeks before the 11.04 release, which was unexpected and upsetting.

In response, I made a quick unofficial hack of the Lubuntu 11.04 ISO that just edited that one file to contain a lower number, and then adjusted the md5sum.txt file to match, and that changed ISO will install in 2.7 GB (I was wary of going too low... I could probably have done 2.1GB or so).

I strongly suspect that the Xubuntu 11.04 ISO can be similarly trivially edited to reduce the size that ubiquity thinks it needs.

Jonathan Marsden (jmarsden) wrote :

Julien Lavergne pointed us to

  http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk/revision/4653

as the probable cause of this issue. See discussion on the lubuntu-dsktop mailing list, the thread starts with

  https://lists.launchpad.net/lubuntu-desktop/msg03777.html

Jonathan Marsden (jmarsden) wrote :

Changed bug title to more accurately reflect source of issue.

Related bug to ubiquity project, at least minimally.

summary: - download page lies about disk size requirements
+ ubiquity doubles stated filesystem size requirements
Jonathan Marsden (jmarsden) wrote :

One solution to this issue that could work for both Ubuntu and for the low-disk-space variants Xubuntu and Lubuntu would be to check for a new file casper/minimum-diskspace, and to use that value (in bytes) if it exists, otherwise use the old approach of casper/filesystem.size "plus a bit" -- where "a bit" needs to really be a "small bit"! Then Xubuntu and Lubuntu can use the "old way", and the bigger distributions can set a specific and exact minimum size requirement by creating the new casper/filesystem.size file when they need more space.

Is this workable? I am willing to attempt a patch to do that, if it would be likely to be accepted.

The underlying cause of this seems to be the ubiquity team making a late change to accommodate Ubuntu and Kubuntu installations, without checking what the impact would be on the other variants that are more disk-space sensitive.

I suggest that it would be better for everyone if all relevant Ubuntu variants were considered, and tested, when changes like this are made to ubiquity in future.

Colin Watson (cjwatson) wrote :

We track ubiquity bugs using the ubiquity package in Ubuntu, not using the ubiquity project.

Changed in ubiquity:
status: New → Invalid
Elizabeth K. Joseph (lyz) wrote :

Website has been updated for what is currently true in Natty, marking website portion of this bug as Fix Released.

Changed in xubuntu-website:
status: In Progress → Fix Released
Jonathan Marsden (jmarsden) wrote :

I think the root cause of the issue may be the conflation of two distinct properties: disk space occupied by the OS when installed, and the extra free disk space needed, over and above that, for it to install and then boot successfully. This second value is what is currently being "guessed" within ubiquity, with unfortunate results.

Therefore, perhaps we should have casper/filesystem.size represent the installed filesystem size for the installed distribution, and casper/filesystem.min-free-diskspace for the additional space needed.

This would mean an end to the "fudge factor " approach in this ubiquity code, it would simply add the two values together to compute the minimum disk size needed for an install. If the second file is missing, fine, treat that value as zero (or even use a fudge factor, for improved backward compatibility?). Each flavour of Ubuntu would be responsible for creating an appropriate filesystem.min-free-diskspace file.

Simon Quigley (tsimonq2) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. If you test it and it is still an issue, kindly upload the updated logs by running only once:
apport-collect 784020

and any other logs that are relevant for this particular issue.

Changed in ubiquity:
status: Invalid → Incomplete
Simon Quigley (tsimonq2) on 2018-04-03
Changed in ubiquity (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers