Ubiquity GTK should have useful accessible names set in the Glade .ui files instead of using the variable names

Bug #781385 reported by Mackenzie Morgan on 2011-05-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Evan

Bug Description

Binary package hint: ubiquity

Installing Ubiquity with Orca enabled results in things like "live underscore installer" being read aloud instead of useful widget names. Setting useful accessible names in Glade instead of assigning accessible_name = variable_name in Python would be better.

Changed in ubiquity (Ubuntu):
assignee: nobody → Mackenzie Morgan (maco.m)
importance: Undecided → Medium
tags: added: iso-testing
Evan (ev) wrote :

This was a purposeful change so that we can get at the widgets in LDTP without relying on knowing their text content beforehand:
http://bazaar.launchpad.net/~ev/+junk/ubiquity-ldtp-tests/view/head:/test_ubiquity.py

Do you know a way to provide screen readable text while still exposing each widget as a static string?

Maco
On Sep 23, 2011 5:31 AM, "Evan Dandrea" <email address hidden> wrote:
> This was a purposeful change so that we can get at the widgets in LDTP
without relying on knowing their text content beforehand:
>
http://bazaar.launchpad.net/~ev/+junk/ubiquity-ldtp-tests/view/head:/test_ubiquity.py
>
> Do you know a way to provide screen readable text while still exposing
> each widget as a static string?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/781385
>
> Title:
> Ubiquity GTK should have useful accessible names set in the Glade .ui
> files instead of using the variable names
>
> Status in “ubiquity” package in Ubuntu:
> New
>
> Bug description:
> Binary package hint: ubiquity
>
> Installing Ubiquity with Orca enabled results in things like "live
> underscore installer" being read aloud instead of useful widget names.
> Setting useful accessible names in Glade instead of assigning
> accessible_name = variable_name in Python would be better.
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/781385/+subscriptions

Mackenzie Morgan (maco.m) wrote :

You know that loop you have that resets every widget's accessible name to
it's variable name? Maybe use that *only* during LDTP testing so that
properly translated accessible names can be provided for users in the actual
release by commenting out that loop.

Maco
On Sep 23, 2011 5:31 AM, "Evan Dandrea" <email address hidden> wrote:
> This was a purposeful change so that we can get at the widgets in LDTP
without relying on knowing their text content beforehand:
>
http://bazaar.launchpad.net/~ev/+junk/ubiquity-ldtp-tests/view/head:/test_ubiquity.py
>
> Do you know a way to provide screen readable text while still exposing
> each widget as a static string?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/781385
>
> Title:
> Ubiquity GTK should have useful accessible names set in the Glade .ui
> files instead of using the variable names
>
> Status in “ubiquity” package in Ubuntu:
> New
>
> Bug description:
> Binary package hint: ubiquity
>
> Installing Ubiquity with Orca enabled results in things like "live
> underscore installer" being read aloud instead of useful widget names.
> Setting useful accessible names in Glade instead of assigning
> accessible_name = variable_name in Python would be better.
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/781385/+subscriptions

Alan Bell (alanbell) on 2011-09-23
Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: rls-mgr-o-tracking
Alan Bell (alanbell) wrote :

Can we stop doing this now or do automated tests need to run up to release? I would like to have the opportunity to test the installer with the correct sound output so we can document it prior to release, there is no point doing videos of the install process if it is reading out the variable names rather than the text it should say because that would be misleading. I would point out that the only way the LDTP tests work at all is by leveraging the work that has been put into accessibility, so breaking accessibility just to make the testing easier is a bit harsh. Could the tests not use the regular accessible names to find widgets?

Alan Bell (alanbell) wrote :

I temporarily commented out the add_widget bit that breaks the labels on a live CD and discovered that one of the descriptions is "Upgrade Ubuntu to 11.04"

http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/ubiquity/oneiric/view/head:/gui/gtk/stepPartAsk.ui#L233

It is hard to properly test the screen reader install if it is reading out stuff that it shouldn't do on the real install which is masking problems that we should really be fixing

Evan (ev) wrote :

I'm happy to implement the suggestion that Mackenzie has made.

Evan (ev) on 2011-09-26
Changed in ubiquity (Ubuntu):
assignee: Mackenzie Morgan (maco.m) → Evan Dandrea (ev)
status: Confirmed → Fix Committed
milestone: none → ubuntu-11.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.7.37

---------------
ubiquity (2.7.37) oneiric; urgency=low

  [ Evan Dandrea ]
  * Only set the ATK widget names to their GtkBuilder counterparts when
    --ldtp is set (LP: #781385)
  * Provide a means of preseeding an oem-config frontend (LP: #820514).
  * Terminate the updates download process before we get to
    remove_extras (LP: #743359).
  * Automatic update of included source packages: console-setup
    1.57ubuntu26, grub-installer 1.68ubuntu2, hw-detect 1.81ubuntu3,
    netcfg 1.68ubuntu5, partman-base 151ubuntu2.
  * Update translations from Launchpad.

  [ Colin Watson ]
  * Install new files from grub-installer >= 1.66.
 -- Evan Dandrea <email address hidden> Wed, 28 Sep 2011 12:15:46 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Attila Hammer (hammera) wrote :

Generaly, lot of Ubiquity GTK controls are the fix is full good, for example check boxes, and installer screen awailable buttons.
Now, Orca screen reader full right spokening the hungarian localized translated labels this controls.

Unfortunately for example the third screen if Ubiquity detecting my machine have more operating systems, with radiobuttons Orca spokening following style the radiobuttons labels:
Wonderful spokening the radiobutton labels with hungarian localized labels, but spokening an english text after with the translated label.
The text is following, for example if have more operating system my machine:
If first focused the radiobutton group the first selected radiobutton label:
"Ubuntu telepítése melléjük
Ubuntu telepítése melléjük
Install Ubuntu alongside."
When I moving the next radiobutton group with DOWN arrow key:
"Merevlemez törlése, és az Ubuntu telepítése
Replace Windows with Ubuntu"
When I moving the last radiobutton element:
"Valami más
Kézi beállítás
Speciális"
For example, The third radiobutton element texts all translated with hungarian language.
Future, need decreasing the duplicated output spokening for example with radiobuttons related, for example if the real label and accessible field declared labels are equals. Perhaps this type work need scheduling with next LTS release development.

You possible easyest verify this results in Ubiquity 2.7.38 with following steps if you talking a non english locale:
1. Boot a daily live CD with containing Ubiquity 2.7.38 version.
2. When Ubiquity main screen is presenting, you press CTRL+S keystroke.
3. Customize Orca Screen Reader preferences with your speech sinthesizer needs.
4. Try installing Ubuntu. Enough to you going the third step with installation process.

I will be doing a clean installation with my testing partition and verify other installer screens, if this is easyest your work. I have possibility to generate manualy with full uptodated Oneiric daily live CD.
Your openion possible fix this type problem before final Oneiric release, or have full freeze now?
Schedule this type fix with next LTS development release, or possible applying this fix for example with Oneiric with updated daily live CD's after final release is publicated?

I would like thank you everybody this wonderful result for example with buttons, and check boxes related with Ubiquity GTK installer screen.

Attila

Download full text (3.5 KiB)

Hy,

I verified entire installation process for Orca screen reader, and the
results is fantastic with a11Y declared labels related.
I only found minor problems, with perhaps need fixing next LTS release
if impossible to fix this type problems in Oneiric branch.
Easyest fix problems:
1. With continue button not yet have mnemonic letter, perhaps GTK3 use
different style builtin continue factory button?
For example, the Back button have mnemonic letter.

2. If selected the manual partitioning and the user modify a partition,
with mount point edit box and mount point combo box the label text is
not spokened. Perhaps not associated this labels with the
mnemonic_widget property, or not have declared a11y label this two control.
With Orca flat review command I see the mount point label text.
I reporting separate bug this issues? I welcome trying making a patch
this problems related if I have enough time.

An importanter issue:
After Ubiquity not ask other installation related questions, real
already installing the system. Of course presenting the slideshow, but
impossible to review what actual task doing the installer. With Orca
flat review I only see an unlabelled toggle button, and the progress bar.

I remember wrong with the third installation screen with radiobuttons
related. If I detected right, <accessibility> related part passed labels
texts are not presenting translated with hungarian language (the
radiobutton title labels and the desc related labels), for example with
stepPartAsk.ui file:
The use device radiobutton related properties is following:
             <child>
               <object class="GtkRadioButton" id="use_device">
                 <property name="visible">True</property>
                 <property name="can_focus">True</property>
                 <property name="receives_default">False</property>
                 <property name="use_action_appearance">False</property>
                 <property name="xalign">0</property>
                 <property name="draw_indicator">True</property>
                 <property name="group">resize_use_free</property>
                 <signal name="clicked"
handler="part_ask_option_changed" swapped="no"/>
    <accessibility>
     <relation type="labelled-by" target="use_device_title"/>
    </accessibility>

Look the use_device_title label related properties, the translation
property for label text is correct setted:
                         <child>
                           <object class="GtkLabel" id="use_device_title">
                             <property name="visible">True</property>
                             <property name="can_focus">False</property>
                             <property name="xalign">0</property>
                             <property name="yalign">0</property>
                             <property name="label"
translatable="yes">Replace Windows with Ubuntu</property>
                           </object>

Very interesting, if I ran intltool-update hu command with ubiquity
source directory/po directory, I doesn't see this new a11Y related messages.
When I looked Launchpad have perhaps new translatable messages with
Ubiquity GTK interface relat...

Read more...

I know about that. It reads twice in English too. I have an idea what to do
about it.

Maco
On Sep 30, 2011 3:06 AM, "Attila Hammer" <email address hidden> wrote:

Attila Hammer (hammera) wrote :

Hy Maco,

Thank you your answer. If not changing this bugreport status, and not a
big request, Please send me a notification when possible testing this
problem fix for non english language locales.
With prewious I wrote other smaller A11y related issues I need reporting
a new bugreport?

Attila

Mackenzie Morgan (maco.m) wrote :

Don't worry about it. It's not just a localization problem. In English it
speaks the real text and the filler text too. This means it will, for
example, always mention Wi> Hy Maco,
>
> Thank you your answer. If not changing this bugreport status, and not a
> big request, Please send me a notification when possible testing this
> problem fix for non english language locales.
> With prewious I wrote other smaller A11y related issues I need reporting
> a new bugreport?
>
> Attila
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/781385
>
> Title:
> Ubiquity GTK should have useful accessible names set in the Glade .ui
> files instead of using the variable names
>
> Status in “ubiquity” package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: ubiquity
>
> Installing Ubiquity with Orca enabled results in things like "live
> underscore installer" being read aloud instead of useful widget names.
> Setting useful accessible names in Glade instead of assigning
> accessible_name = variable_name in Python would be better.
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/781385/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers