Kubuntu installer uses wrong character encoding

Bug #771446 reported by Chad A. Davis on 2011-04-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

During the kubuntu install from a live CD, after choosing the German keyboard and typing a German name with German accents (when asked for your full name), the characters are displayed incorrectly (screenshot attached).
I believe that the keyboard map is correct. All of the non-accented characters seem to be mapped to the right keys at least. I also tried the French keyboard layout (with the installer still running in German), where the keyboard map also seems correct. With French, the accented characters also do not display correctly.

This is all during the end-user setup after an OEM install. In another install (non-OEM), I ran the kubuntu installer in English and used the German keyboard and the characters are correctly displayed. So, the problem seems to be either a result of the installer being in German, or the result of the environment that is setup after the OEM install.
---
Architecture: amd64
DistroRelease: Ubuntu 11.04
LiveMediaBuild: Kubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
Package: ubiquity 2.6.10
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Tags: natty
Uname: Linux 2.6.38-8-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Evan (ev) wrote :

Can you please run the installer in debug mode (press Try Ubuntu, then run `ubiquity -d` in a terminal window). When the install completes, please run `sudo apport-collect 771446`. This should give us a much clearer picture of what's going on.

Thanks!

Changed in ubiquity (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected natty
description: updated

apport information

apport information

apport information

apport information

apport information

Chad A. Davis (chadadavis) wrote :

This is repeatable. The encoding during the install in OEM mode is correct (tested in the hostname field).
The problem is during 'oem-config --only'. The environment is localized correctly, text in the UI is displayed correctly, the correct keyboard is being used, but entering accented, non-ASCII, characters results in the wrong characters being displayed.

Is it possible to re-run oem-config-prepare (without a full OEM install) and somehow debug the 'oem-config --only' step?

I have a similar experience.

I re-installed kubuntu-11.04-alternate-i386 on my netbook.

The keyboard set-up wizard correctly identified the keyboard as locale 'gb' however in use several key mappings are incorrect, system locale is correctly set to 'gb'.

Following some feedback on the KDE Forums my keyboard is now working.

In System Settings...Input Devices...Keyboard under the Layouts tab 'Configure layouts' was disabled. As soon as I enabled it an entry appeared for a 'us' keyboard.

I replaced the 'us' layout with 'gb' and now the keyboard mappings work as expected.

Is it possible that although the installer correctly identified the keyboard it failed to apply the right layout?

tags: added: ubiquity-2.6.10
Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers