Ubiquity disk requirements are excessive

Bug #771401 reported by Jonathan Carter on 2011-04-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
Oneiric
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

Through the Beta and RC releases, Edubuntu installed fine on my 8GB virtual disks.

In the final isos, Ubiquity doesn't allow me to progress past the initial checks page since I don't have 14.1GB free space available

We can specify that Edubuntu requires a 20GB disk in the release notes, but this is suboptimal since there's no reason why it couldn't work just as fine on a 10GB (or even smaller) disk.

I suspect this will affect other releases too.

Related branches

tags: added: iso-testing
description: updated
Brian Murray (brian-murray) wrote :

In bug 745148 Evan says:

"I've increased the minimum size to double the size of the install, or roughly 5.2 GB. This is just above the minimum size set by the official documentation:"

So this may affect other releases but not as much as it does Edubuntu since its install size is larger than Ubuntu's.

tags: added: natty
Changed in ubiquity (Ubuntu Oneiric):
importance: Undecided → Medium
milestone: none → oneiric-alpha-1
Changed in ubiquity (Ubuntu):
milestone: oneiric-alpha-1 → none
Changed in ubiquity (Ubuntu Oneiric):
status: New → Confirmed
Changed in ubiquity (Ubuntu Oneiric):
milestone: oneiric-alpha-1 → ubuntu-11.10-beta-1
Stéphane Graber (stgraber) wrote :

Just pushed a fix to ubiquity setting a maximum size of 8GB as long as the user still has 20% of free space.
For Edubuntu, this will appear as 8.6GB in ubiquity.

Changed in ubiquity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.7.21

---------------
ubiquity (2.7.21) oneiric; urgency=low

  [ Stéphane Graber ]
  * Explicitly bind "activate-link" as it seems to be the only way to actually
    catch that signal. (LP: #830895)
  * If the user didn't select a photo, just continue without configuring it.
    (LP: #836934)
  * Instead of forcing the color on all elements, only do it for elements
    where it's actually required. Fixes weird backgrounds in ComboBoxes (LP: #830923)
  * Set a maximum install size of 8GB as long as the user still has 20% of free
    space. (LP: #771401)

  [ Evan Dandrea ]
  * Set the timezone location to the default (LP: #830940).
  * Automatic update of included source packages: user-setup
    1.28ubuntu19.
 -- Evan Dandrea <email address hidden> Tue, 30 Aug 2011 17:16:54 +0100

Changed in ubiquity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers