Prefers to install to USB rather than to HD

Bug #770711 reported by Chad A. Davis on 2011-04-26
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Oneiric
High
Colin Watson

Bug Description

Binary package hint: ubiquity

Booting from the live CD with a persistent USB stick inserted, the installer recognizes the USB stick, prompts to unmount (probably shouldn't do this when the device is the persistent partition, however). The installer then defaults to installing to the USB stick. This can be changed to the hard drive, but it's unclear why the USB stick would be the default: sorted by name, sda is before sdc, sorted by size 320GB is before 1GB. This is new behavior. This worked correctly last week, whereby not unmounting the persistent partition still defaulted to installing to the hard drive.

This is with the ISO for amd64+mac from 20110425.2

Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :

Problem also occurs with Kubuntu

Evan (ev) on 2011-04-28
Changed in ubiquity (Ubuntu):
importance: Undecided → Low
milestone: none → oneiric-alpha-1
Changed in ubiquity (Ubuntu):
milestone: oneiric-alpha-1 → oneiric-alpha-2
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
Martin Pitt (pitti) on 2011-07-07
Changed in ubiquity (Ubuntu):
milestone: oneiric-alpha-2 → oneiric-alpha-3
Changed in ubiquity (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
Martin Pitt (pitti) on 2011-08-31
Changed in ubiquity (Ubuntu):
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2
Changed in ubiquity (Ubuntu):
status: New → Confirmed
description: updated
Colin Watson (cjwatson) on 2011-09-20
Changed in ubiquity (Ubuntu Oneiric):
importance: Low → High
Steve Langasek (vorlon) on 2011-09-23
Changed in ubiquity (Ubuntu Oneiric):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
tags: added: rls-mgr-o-tracking
Colin Watson (cjwatson) on 2011-10-01
Changed in ubiquity (Ubuntu Oneiric):
assignee: Ubuntu Installer Team (ubuntu-installer) → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

I think the problem is that the ordering is taken from whatever order the disks happen to come out of a dictionary, so it's essentially random.

Changed in ubiquity (Ubuntu Oneiric):
status: Confirmed → Triaged
Colin Watson (cjwatson) on 2011-10-03
Changed in ubiquity (Ubuntu Oneiric):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.8.2

---------------
ubiquity (2.8.2) oneiric; urgency=low

  [ Colin Watson ]
  * Preserve ordering of disks returned by partman-auto rather than
    shuffling them based on dictionary ordering (LP: #770711). This uses
    collections.OrderedDict, which requires Python >= 2.7.
  * Run only those parts of oem-config-prepare that require root access as
    root; in particular displaying confirmation dialogs is now done as the
    calling user, which avoids KDE confusion (LP: #856418).
  * Go back to killing update-apt-cache's process group, but this time make
    sure that it's in a separate process group and make more of an effort to
    ensure that it terminates (LP: #743359).
  * Update translations from Launchpad.

  [ Stéphane Graber ]
  * Make ubiquity also update gsettings (LP: #800760)
    - Add a new gsettings module similar to the gconftool one
    - Update ubiquity-dm for gconf to gsettings migration
    - Get PROXY configuration from gsettings
    - Update gtk_ui to set/restore gsettings values
  * Update copy_network_config to work with Network Manager now storing
    everything system wide.
 -- Stephane Graber <email address hidden> Mon, 03 Oct 2011 17:31:46 -0400

Changed in ubiquity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers