Sorting non-English list: French installer sorts accented names at end of alphabet

Bug #770320 reported by Chad A. Davis on 2011-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Ubuntu Installer Team
Oneiric
Low
Ubuntu Installer Team

Bug Description

Binary package hint: ubiquity

Installing the natty release candidate (2011-04-25) from the live CD in French shows the list of countries during the keyboard selection. However, Éthiopie is listed at the end of the alphabet, presumably because of the accented E at the beginning of the name. This was probably not noticed as a bug before, because French often drops the accent on capital letters, but this seems to show that the sorting is not ignoring the accents, as it should (at least for French).

Related branches

Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :

Also applies to the Kubuntu installer on the live CD

Chad A. Davis (chadadavis) wrote :

Problem also applies to German where accented characters (e.g. again Ethiopia / Äthiopien) are sorted to the end of the alphabet, due to incorrect sorting of accented characters.

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Confirmed with ubiquity 2.6.10.
'Éthiopie' is at the end of the list while it should be listed after 'Estonie'

Changed in ubiquity (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Evan (ev) on 2011-04-26
Changed in ubiquity (Ubuntu):
milestone: none → oneiric-alpha-1
Changed in ubiquity (Ubuntu):
milestone: oneiric-alpha-1 → oneiric-alpha-3
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
Changed in ubiquity (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
Martin Pitt (pitti) on 2011-08-31
Changed in ubiquity (Ubuntu):
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2
Changed in ubiquity (Ubuntu Oneiric):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.7.25

---------------
ubiquity (2.7.25) oneiric; urgency=low

  [ Colin Watson ]
  * /apps/metacity/general/num_workspaces should be an int, not a boolean.
  * Automatic update of included source packages: flash-kernel 2.28ubuntu29.

  [ Evan Dandrea ]
  * Don't try to connect signals on the release notes label in the oem-
    config version of the language page, as it doesn't exist there.
  * Construct a GtkTreeCellDataFunc with the correct number of arguments
    in the migration assistant plugin (LP: #829987).
  * Don't let the text wrap for the language names in oem-config.

  [ Stéphane Graber ]
  * Properly sort the keyboard list (LP: #770320)
 -- Colin Watson <email address hidden> Wed, 31 Aug 2011 20:52:07 +0100

Changed in ubiquity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments