Ubuntu

Cannot manually specify a mount point in the manual partitoner

Reported by Ronald McCollam on 2011-04-22
172
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Colin Watson
ubiquity (Ubuntu)
High
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

When creating partitions or selecting existing partitions in the manual partitioning tool, the mount point box does not accept keyboard input. The dropdown still works, so the default values (/, /home, etc.) can still be selected, but a new one cannot be specified. The partition size spinbox still works correctly, so keyboard input is definitely working.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubiquity 2.6.9
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Fri Apr 22 15:50:07 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110422)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:ubiquity
Adolfo Jayme (community): Disapprove on 2014-04-02
Ondrej Pačay: Pending requested 2013-12-11
Ronald McCollam (fader) wrote :
tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report. Confirmed with ubiquity 2.6.10 (Ubuntu Desktop 20110423)

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Evan Dandrea (ev) on 2011-04-26
Changed in ubiquity (Ubuntu Natty):
status: Triaged → Won't Fix
Changed in ubiquity (Ubuntu):
importance: Medium → High
milestone: none → oneiric-alpha-1
Evan Dandrea (ev) on 2011-04-26
Changed in ubiquity (Ubuntu):
status: Triaged → Fix Committed
asasoft (asasoft) wrote :

For Natty , workaround, copy and paste inside the text box works for me.

Erick Brunzell (lbsolost) wrote :

I know I'll get yelled at because Scott Kitterman recently told me to just add "ubuntu-release-notes" to the bug, but I'll be dogged if I can see how to do that properly ;^(

I do think we need a clear explanation of the work-around included in the release notes.

Sorry to be a bit slow catching on at times but we all learn from our mistakes.

Scott Kitterman (kitterman) wrote :

"Also affects project" is where you find it.

asasoft (asasoft) wrote :

From "Try Ubuntu" run the installer, alt+f2 run gedit , type your custom mount point , select and copy the text to paste in the installer.

From "Install Ubuntu" you can't alt+f2 or run gedit so, go to system settings type your custom mount point in the filter box, select and copy the text to paste in the installer.

I can't explain more clearly , my English bad.

Colin Watson (cjwatson) wrote :

Release-noted:

 * The manual mount point entry box in the desktop installer's partitioner does not accept keyboard input. The drop-down still works, so various standard mount points may be selected, but custom ones cannot. This was noticed too late to be corrected for 11.04. In the meantime, you can mount partitions manually later, or use the alternate install CD. (Bug:769043)

Changed in ubuntu-release-notes:
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Released
Colin Watson (cjwatson) wrote :

I've now also belatedly noticed the workaround mentioned by asasoft, and added that to the release note.

On Thu, 2011-04-28 at 15:45 +0000, Colin Watson wrote:
> I've now also belatedly noticed the workaround mentioned by asasoft, and
> added that to the release note.

Hello.

Well I resolved by creating a file on desktop, entering /xxx and /yyy,
and copy paste.
No i have discovered minor problems with checking radio buttons, but i
check other button and move around with keyboard.

Anyway thank for answer.

>

soreau (oreaus) wrote :

For what it's worth, I have the exact same problem with natty official release desktop live cd. This was not the case in previous releases. Fortunately I figured out copy/paste, although cumbersome, worked.

Sad! But oh well will affect the pros who are comfortable with mount points anyway. The beginners won't probably see the screen so ok i guess. can't they just fix and respin the ISOs? so at least people downloading e.g. 2 weeks from now don't see the problem?

Dooitze de Jong (dooitze) wrote :

I think this problem must be solved in 11.04. Even though 11.04 has been released, this bug must be fixed in 11.04.

Reuben Firmin (reubenf) wrote :

I didn't set up mounts for 4 of my disks as a result of this bug. Two of the unmapped partitions were unmountable after install (see 773770 for error messages, which differed). After much gnashing of teeth, I figured out that fsck'ing was the fix. However, it's obviously bad that the filesystem was somehow corrupted by not being mapped.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.7.0

---------------
ubiquity (2.7.0) oneiric; urgency=low

  [ Evan Dandrea ]
  * Prevent the OOM killer from selecting ubiquity. See LP #770865.
  * Ensure that the partition ComboBoxEntry can be focused
    (LP: #769043).
  * Hide the other pages when starting the slideshow so that verbose
    languages that cause the window to grow do not leave lots of
    whitespace on the slideshow (LP: #770253).
  * Don't offer the download updates option when there is no Internet
    connection. See LP: 651932.
  * Provide access to the keymaps most-relevant for the currently
    selected language in the keyboard indicator (LP: #656777).
  * gnome-settings-daemon no longer daemonizes (LP: #788859).
  * Automatic update of included source packages: partman-auto
    93ubuntu16.

  [ Colin Watson ]
  * Re-enable alpha warning for oneiric.
  * Make ubiquity/nonfree_package preseedable, and allow it to contain
    multiple whitespace-separated package names.

  [ Mario Limonciello ]
  * In automatic ubiquity mode, don't clobber grub-installer/bootdev
    because of the U/I widget not being populated. Fixes preseeded
    grub-installer/bootdev.
 -- Evan Dandrea <email address hidden> Tue, 31 May 2011 14:56:14 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers