Ubiquity crashes on "Installing the 'grub2' package"

Bug #768051 reported by Syncopated on 2011-04-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

I was trying to install 64-bit Natty Beta-2 from a USB flash drive with the ISO image onto a Samsung 900X3A, released 1-2 months ago. This machine has a SSD. I think it may also support EFI, if that makes any difference.

Syncopated (joshchia) wrote :
Syncopated (joshchia) wrote :
Evan (ev) wrote :

Apr 21 04:39:06 ubuntu grub-installer: info: architecture: amd64/efi
Apr 21 04:39:07 ubuntu grub-installer: info: Identified partition label for /dev/sda2: gpt
Apr 21 04:39:08 ubuntu grub-installer: dpkg: warning: there's no installed package matching grub
Apr 21 04:39:08 ubuntu grub-installer: dpkg: warning: there's no installed package matching grub-legacy
Apr 21 04:39:08 ubuntu grub-installer: dpkg: dependency problems prevent removal of grub-pc:
Apr 21 04:39:08 ubuntu grub-installer: grub-gfxpayload-lists depends on grub-pc (>= 1.99~20101210-1ubuntu2).
Apr 21 04:39:08 ubuntu grub-installer: dpkg: error processing grub-pc (--purge):
Apr 21 04:39:08 ubuntu grub-installer: dependency problems - not removing
Apr 21 04:39:08 ubuntu grub-installer: Errors were encountered while processing:
Apr 21 04:39:08 ubuntu grub-installer: grub-pc

Chris Ball (chris-ubuntu) wrote :

I just hit the same problem; the installer crashes when "Installing grub2.." is visible. I'm installing from the beta2 amd64 desktop ISO, and it's an EFI machine.

Jean-Baptiste Lallement (jibel) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 765270, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Syncopated (joshchia) wrote :

I just tried installing using a bootable USB with the live image from the daily build of Apr 22, and the problem is gone. I was able to successfully install Natty on my system.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments