Ubiquity proceeds to use free space without warning

Bug #766265 reported by Erick Brunzell on 2011-04-19
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
ubiquity (Ubuntu)
High
Colin Watson
Natty
Undecided
Unassigned
Oneiric
High
Ubuntu Installer Team
Precise
High
Colin Watson

Bug Description

Release note:

If there is at least 5.2 GB of unpartitioned space available on a disk, the installer will elect to create an Ubuntu partition in that space for the "Install Ubuntu alongside ..." option. While the normal "Install Ubuntu alongside ..." option has a second page for resizing a partition, this variant does not. Pressing "Install Now" will immediately start the installation.

Original bug report follows:

Binary package hint: ubiquity

This is really a continuation of bug 652852. Please just begin reading about post #35, and apologies in advance if I'm just being impatient.

We've progressed greatly with this and I know it's not been easy for the ubuntu-installer team, particularly Colin and Evan, but I'm still concerned about the option to "use largest continuous free space" being lumped into "install alongside".

I have read the spec provided by Evan:

https://docs.google.com/View?id=dfkkjjcj_101gnkrpg5v#4_5_1_Automatic_partitioning_o_8475526086986065

Maybe I'm misunderstanding what this means, [maps to resize_use_free or use_biggest_free] ????????????

But ATM the fact is that "install alongside" will use as little as 10GB, which IMHO is good, but having chosen "alongside" and having no opportunity to verify what the installer is going to do certainly freaked me out the first time. Quite factually if adequate unallocated space exists and you choose "install alongside" the installation just begins - period!

Several questions come to mind. I've not tried it yet but what if I had adequate free space on each of two drives? How about adequate free space on a USB flash drive?

It just seems scary to have the installation begin with no idea what it's doing. Does that make sense?

I'm just trying to avoid any nightmare scenarios for noobs.

OT but I have tried the 'live-upgrade' and 'wubi-if-4-primaries-exist' options and they appear to work great, of course it's impossible to recreate every potential scenario.
---
Architecture: i386
DistroRelease: Ubuntu 11.04
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110422)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110422)
Package: ubiquity 2.6.9
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Tags: natty natty
Uname: Linux 2.6.38-8-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Erick Brunzell (lbsolost) wrote :

If someone wants to reproduce this simply begin with an existing install, use gparted to create adequate free space (the smallest I've tried ATM is 10GB), then during installation choose "install alongside". You'll see that the installation just begins with no additional option or warning offered.

I find that a bit scary.

DanielRoesler (diafygi) wrote :

I usually make 8GB free space that I would like to install Ubuntu on. Will it automatically choose that size? What about a 6GB free space? What is the minimum space?

Why can't there just be an option for installing on free space (like there used to be)? It was so easy, and merging this into "Alongside" seems to be creating a lot of hesitation for users.

tags: added: iso-testing
Erick Brunzell (lbsolost) wrote :

In this last test I was using the 20110421.1 iso-testing image and I used about 8GB unallocated space. It completed as I've come to expect, creating sdb6 & 7:

Model: ATA WDC WD800JB-00JJ (scsi)
Disk /dev/sdb: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 69.5GB 69.5GB primary ext4
 2 69.5GB 80.0GB 10.5GB extended
 6 69.5GB 75.8GB 6274MB logical ext4
 7 75.8GB 77.9GB 2132MB logical linux-swap(v1)
 5 77.9GB 80.0GB 2136MB logical linux-swap(v1)

So, I'd really just like either Evan Dandrea or Colin Watson's opinion about this.

I'd certainly be willing to accept a won't fix ATM, then we can wait and see what happens. I mean I can't see how this could possibly result in lost data or anything of that nature.

Worst case scenario, Ubuntu ends up in an unallocated space that was not intended for use, but since it was free space it shouldn't be a big deal.

And I'm very reluctant to see any major changes made this late in the dev cycle.

If it gets a won't fix I can put it to rest with a clear conscience :^)

apport information

tags: added: apport-collected natty
description: updated

apport information

apport information

apport information

apport information

I had to satisfy my curiosity this AM, so using the new 20110422 i386 image I first copied all of my data off of my 4GB flash drive (the only one I have ATM) and chose the install alongside option. Fairly typical partition scheme for me otherwise:

ubuntu@ubuntu:~$ sudo parted -l
Model: ATA WDC WD5000AAKS-0 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 32.3kB 43.3GB 43.3GB primary ext4 boot
 2 43.3GB 86.2GB 42.8GB primary ext3
 3 86.2GB 129GB 43.0GB primary ext3
 4 129GB 500GB 371GB extended
18 129GB 151GB 21.8GB logical ext4
14 151GB 172GB 21.1GB logical ext4
15 172GB 193GB 21.1GB logical ext4
16 193GB 215GB 21.4GB logical ext4
17 215GB 236GB 21.4GB logical ext4
13 236GB 258GB 22.0GB logical ext4
12 258GB 280GB 21.6GB logical ext3
11 280GB 301GB 21.7GB logical ext4
10 301GB 323GB 21.8GB logical ext4
 5 323GB 374GB 50.8GB logical ext3
19 374GB 377GB 3208MB logical fat32
20 377GB 378GB 1089MB logical ext3
 6 378GB 432GB 53.6GB logical ext3
 7 432GB 487GB 54.9GB logical ext3
 8 487GB 498GB 10.7GB logical ext3
 9 498GB 500GB 2517MB logical linux-swap(v1)

Model: ATA WDC WD800JB-00JJ (scsi)
Disk /dev/sdb: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 77.9GB 77.9GB primary ext4
 2 77.9GB 80.0GB 2136MB extended
 5 77.9GB 80.0GB 2136MB logical linux-swap(v1)

Model: Crucial Gizmo! (scsi)
Disk /dev/sdc: 4010MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags

Warning: Unable to open /dev/sr0 read-write (Read-only file system). /dev/sr0
has been opened read-only.
Error: /dev/sr0: unrecognised disk label

Then it appeared to proceed w/o warning as I'm accustomed to, and the message displayed in the first attached screenshot appeared so I was fairly sure that it was going to use the 4GB flash drive.

I then clicked on Continue to be certain, and sure as the world it partitioned the flash drive as shown in the second screenshot attached.

So, I think this could be a real problem, eh? At the very least worth a mention in the release notes.

Erick Brunzell (lbsolost) wrote :

Here's proof of what it did.

Erick Brunzell (lbsolost) wrote :

How bad could that be if someone has a memory card or flash drive in the PC when starting to install and expected "alongside" to offer a true "alongside" option?

Erick Brunzell (lbsolost) wrote :

Somewhat OT, but there is no place on the iso-tracker to report this, I just did a 'replace' test and things worked perfectly!

The "upgrade distroX to distroY" was a pure stroke of genius. I still need to perform a 'Wubi if 4 primaries exist' test with this iso but I'd bet it still works OK - you know I'll complain if it doesn't.

Quite honestly IMHO this is the last major obstacle with this version of ubiquity. Considering the way ubiquity works in other regards there are two choices to fix the UI:

1) Have ubiquity display what it's going to do after selecting "alongside" even if it's going to use free space.

2) have ubiquity present using free space as a different option.

Of course this late in the dev cycle I'm inclined to think this is best addressed in the release notes.

Sorry to just ramble, now onto the Wubi test.

Evan (ev) wrote :

Marking this as Won't Fix for Natty. There's no way this is getting UI work days from release.

Changed in ubiquity (Ubuntu Natty):
status: New → Won't Fix
Evan (ev) wrote :

This occurs when the installer chooses a large amount of free space to install into instead of resizing a partition. Because the former does not need any further interaction from the user, and because it visually does not follow the two partitions presented next to one another that the resize page does, it is not given an additional page. The button text is changed to "Install Now" to reflect this.

This is intended behavior, but the inconsistency in the way the side-by-side option is presented dependent on what is happening underneath the covers is worth a look in O.

Changed in ubiquity (Ubuntu):
milestone: none → oneiric-alpha-1
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

"The button text is changed to "Install Now" to reflect this."

No, it's not. That would at least be some indication that the the install was really going to begin right then. I just repeated a test to be certain and the attached screenshot shows exactly what does happen.

The shot on the left displays that I've chosen alongside with 10GB free, and the shot on the right displays exactly what happens when you click on forward. You'll notice it does display "installing" at the bottom, which rapidly changes to "detecting file systems" and the "quit" button has disappeared, the back button is grayed out (non-functional), so the only way to quit is to hit the reset button on the box.

The next screen to appear is "Where are you". Now, If you know in advance what the installer is likely to do that should be OK, something we can revisit in Oneiric for sure, and I definitely agree that it would be foolish at this point to fiddle with ubiquity.

I do however believe we need to make some mention of this in the release notes (not real sure how to word that though). Keep in mind that posts #4 thru #10 reflect what happened when I had a blank 4GB flash drive plugged in, albeit intentionally to prove my point.

I've helped troubleshoot quite a few boot problems where someone had mistakenly left a memory card from a camera or such inserted and ended up cussing grub when the problem was actually located between the chair and the keyboard :^)

OTOH it shouldn't cause any data loss, at worst a wasted 20 minutes of install time and the simple reformatting of whatever drive/partition was mistakenly used.

Anyway I'm subscribing the release team so they can decide if this warrants a mention in the release notes.

Scott Kitterman (kitterman) wrote :

The best way to do that is add ubuntu-release-notes to the bug. I've done that now.

Evan (ev) on 2011-04-27
description: updated
Kate Stewart (kate.stewart) wrote :

Would be good to get this scheduled to be fixed early in Oneiric's cycle, if possible.

Changed in ubiquity (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
summary: - Natty ubiquity proceeds to use free space without warning
+ Ubiquity proceeds to use free space without warning
Changed in ubiquity (Ubuntu Oneiric):
milestone: oneiric-alpha-1 → none
importance: Undecided → High
Erick Brunzell (lbsolost) wrote :

Just trying to get my ducks in a row for Oneiric alpha1 iso-testing and I notice ubiquity is bumped to version 2.7.0.

If Evan or Colin (or any member of the live installer team) happen to read this, is there an updated version of this document:

https://docs.google.com/View?id=dfkkjjcj_101gnkrpg5v#4_5_1

Thanks in advance.

Erick Brunzell (lbsolost) wrote :

Just following up on this while performing Oneiric Alpha2 iso-testing.

Just to recap, if sufficient free space exists, and "install alongside" is selected, clicking on the forward button just begins the installation w/o warning.

I suppose one way to fix this would be to have the forward button change to "Install Now" if that's even possible?

Another would be to have "Use free space" as an entirely separate option, or still another would be to have a new window open just as it does if an actual resizing is going to take place.

tags: added: ubiquity-2.6.9
Erick Brunzell (lbsolost) wrote :

Just following up with Alpha 3 iso-testing images and I must say that changing the forward button to continue was a true stroke of genius! Also I finally got a router set up with a kvm switch so I can perform more tests in a shorter period of time and I've now been able to give this a closer look on my old Win XP box and I notice that the dialog very clearly explains what is going to happen if Windows exists.

I'm just thinking this may be good enough, or maybe I've just become accustomed to the behavior. I'd really like either Evan or Colin to comment and of course make a final decision.

I'm just thinking you have this working so well that I hate to see any extreme changes.

I won't bother with the Wubi by default if 4 primaries exist testing until Oneiric Beta, but aside from that I think we're in pretty good shape ...................... well bug 758013 needs more studying, but I think it has to do with packages only available through the partner repo or Medibuntu (I will follow up on that soon).

Erick Brunzell (lbsolost) wrote :

A new slant to this which may require either renaming this bug or filing a new one. This was from a Oneiric Alpha 3 iso-tesing image (20110803-i386).

I began with a one drive setup with Win XP on sda1 and Lubuntu Oneiric on sda3 with sda2 as SWAP, all primary partitions so I can easily test free space options and also delete any logical/extended partitions created during testing and replace them with another primary partition so I can perform the "Wubi if 4 primaries exist" option.

This is what parted showed before beginning:

Model: ATA WDC WD1600AAJB-0 (scsi)
Disk /dev/sda: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 32.3kB 43.1GB 43.1GB primary ntfs boot
 3 136GB 158GB 22.0GB primary ext4
 2 158GB 160GB 2338MB primary linux-swap(v1)

But when I tried to install there was no option whatsoever to install to the existing free space, please see the attached screenshot.

I personally think renaming this bug makes more sense than creating a new one because it all amounts to how we should offer the use of existing free space.

Erick Brunzell (lbsolost) wrote :

Actually this cries for reopening bug 652852.

I'm now thinking the only way to handle this is to somehow restore the option to "use largest continuous free space".

Easy to say, but I'm sure it's a nightmare to implement :^(

Time to get out the dartboard again. I'm honestly not just trying to be difficult.

I hope Colin and Evan know that I'm only trying to help.

Erick Brunzell (lbsolost) wrote :

I've been doing some testing related to bug 775124 and the two do somewhat play into a common problem. Of course hardware limitations make it impossible to test every given possibility but I try really hard.

Anyway I'd tried using an old blank 3.2GB ATA drive and it was a no go and I'm thinking that the disc space requirement should be treated the same as the power source and internet connection options, with the caveat that only the manual partitioning option should be offered if the disc space is below a specified number of MB/GB, probably with a strong warning in bold red font!

So just for fun I tried creating a free space of about 4.6GB and attempting an installation with the Ubuntu Oneiric Alpha 3 image but I get no option to use manual partitioning, the auto-install just begins :^(

That of course creates a new swap partition which gobbles up too much space, causing the installation to crash because there's not enough room for /. You see, at the very least one must always be offered the ability to use manual partitioning regardless of free space.

We do that in a few other scenarios by displaying a secondary screen showing what's going to happen, explaining that some partitions are hidden, and you can click to "use the advanced partitioning tool". I think using that tool needs to always be offered at some point.

Currently unexpected outcomes occur. I've not seen how this can result in data loss, but it certainly is annoying.

Erick Brunzell (lbsolost) wrote :

@ Colin and Evan,

Please see:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/775124/comments/13

I'll comment more here soon. If there's a newer spec sheet than the link below could you please give me a heads up:

https://docs.google.com/View?id=dfkkjjcj_101gnkrpg5v#2.7.14

Erick Brunzell (lbsolost) wrote :

Thought I should add a comment here. I'm really torn about this, first of all take into consideration that I'm now quite used to the behavior and since it's expected my personal opinion becomes biased. Recent improvements in the explanatory text tends to make me think we're OK in most common installation scenarios, but certainly the test cases in posts #9 and #21 still exist.

Also if someone has free space available on an existing drive and installs another blank drive smaller than the available free space on that existing drive, then selecting "install alongside" would end up installed in the wrong free space, but personally I think anyone with multiple drives should use the manual install (something else) option. Is it possible to make the installer truly foolproof?

At this point I feel that my personal opinion is nearly worthless regarding this issue, I certainly hate to see us introduce any radical changes this late in Oneiric and with P being LTS I'd be equally scared to mess around very much during it's dev cycle. And I don't see how this could result in data loss so at worst it's an inconvenience, that is a person may have to reformat the free space they didn't want to use and then reinstall properly.

Ultimately I'd like to hear Colin Watson's opinion on this.

Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
Steve Langasek (vorlon) wrote :

From comment #14, the behavior here is intentional and the only question is whether there is something that should be improved in the presentation. We're past UI / Feature Freeze now, and there's been no forward progress this cycle, so wontfix'ing this for oneiric.

Changed in ubiquity (Ubuntu Oneiric):
assignee: Canonical Foundations Team (canonical-foundations) → Ubuntu Installer Team (ubuntu-installer)
status: Confirmed → Won't Fix
Changed in ubiquity (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Ubuntu Installer Team (ubuntu-installer)
tags: added: rls-mgr-p-tracking
removed: rls-mgr-o-tracking
Changed in ubuntu-release-notes:
status: New → Fix Released
Steve Langasek (vorlon) on 2011-10-26
tags: added: rls-p-tracking
removed: rls-mgr-p-tracking
Steve Langasek (vorlon) on 2011-11-16
Changed in ubiquity (Ubuntu Precise):
milestone: none → ubuntu-12.04
Erick Brunzell (lbsolost) wrote :

Not surprisingly this behavior is still the same in the Precise 20111129 Lubuntu iso-testing images, and as I said in comment #25 I'm really torn on this. It's become such expected behavior that I wonder if this can even still be considered a valid bug?

Just to be clear, I personally don't think this is a high priority at all, and I feel sort of like the kid in the back seat continually asking, "are we there yet" ;^)

So I'm only reporting on this again now to hopefully have the installer team, really either Evan or Colin would be great, just sort of put this to rest for the duration of Precise testing.

Thanks to all for everything they do. I know it's very early in the Precise dev cycle but so far Precise looks very much like it will live up to it's name.

tags: added: precise
Colin Watson (cjwatson) wrote :

I don't really want to get into things like the situation in comment #21 as part of this bug. Those tend to be the responsibility of entirely separate bits of the codebase, even if they look superficially related, and generally it helps bug management if we restrict bugs to things that can be fixed by single logical changes. (In that case, I expect that perhaps partman-auto decided that it was unable to offer this option for some reason, perhaps due to restrictions of the awful MBR partition table format, or perhaps due to a bug. Multi-boot scenarios really stretch the MBR format, particularly when you're already close to the primary partition limit.) Likewise, issues due to the size fudge factors being wrong are definitely separate.

I'm also personally not very keen on adding more options back to the simplified automatic partitioning screen. This is a design tradeoff, and really this is Matthew Paul Thomas' bailiwick rather than mine; but personally I think it's OK to present a smaller (and hence less confusing) array of options, even if some of them may be ambiguous in the face of situations where there are multiple disks with free space. A "largest continuous free space" option could easily end up using a USB disk unintentionally, for instance, so is not necessarily better. My feeling is that making this clearer would require extensive design work, for example showing a graphical representation of the desired state of all the disks in your system, and that's starting to overload the automatic partitioning screen. I'm happy for design to continue thinking about this, obviously, but I am in no rush to make changes here that feel as though they could have very substantial knock-on effects in terms of other bugs they'd create. My feeling (which I admit isn't backed up by research) is that people with multiple disks will on the whole be more aware than average about what's on which disk, and thus will be more likely to select manual partitioning options anyway if it concerns them.

However, going back to comment #15, you note that the button is labelled "Continue" rather than "Install Now" when an "alongside" option is selected; and that *is* a clear bug. If you switch to a different option and then back, the button changes to "Install Now". I'll look into fixing that, at least.

Colin Watson (cjwatson) on 2011-12-13
Changed in ubiquity (Ubuntu Precise):
assignee: Ubuntu Installer Team (ubuntu-installer) → Colin Watson (cjwatson)
status: Confirmed → Fix Committed
Erick Brunzell (lbsolost) wrote :

I just tested the 20111213-i386 image and it still shows "continue" rather than "install now" if choosing alongside when adequate free space is available, then clicking on continue just begins the installation w/o further questions until you're asked about location.

I personally think, in keeping with the consistency of other installation options, that it should show a screen telling the user what is going to be done and offering the option to quit or use manual partitioning.

But I also don't want us to open a can of worms where we'd end up with something that could result in OS or data loss like bug 655950 :^(

Give me a couple of days to follow up. I'd like to try any and all scenarios I can think of, take some screenshots, and post it all at a forum thread so you can take a peak.

Lets please take time to decide on a plan of action before making any changes.

Erick Brunzell (lbsolost) wrote :

I'm into my third test now and I have to say things look real good .............. until you get to using unintentional free space. Stop and think ;^)

If you have more than one hard drive and select "Use entire disc" you then get another screen where you can select which "disc" you want to use - regardless of size. That is as it should be.

Why would we treat free-space with less regard than an actual disc?

I very seriously think the best "fix" to this is to present another "page" just as we do with a resize or use entire.

How badly could that break other parts of what I see as a great ubiquity?

I honestly don't think just changing the text of the "proceed" button depending on what's available is nearly as good as what I'm suggesting.

I also know I create headaches.

Erick Brunzell (lbsolost) wrote :

I was just going to add a comment, basically ubiquity no longer tries to use a 4GB flash drive as I'd once reported, but that's moot based on your Release note:

"If there is at least 5.2 GB of unpartitioned space available on a disk, the installer will elect to create an Ubuntu partition in that space for the "Install Ubuntu alongside ..." option. While the normal "Install Ubuntu alongside ..." option has a second page for resizing a partition, this variant does not. Pressing "Install Now" will immediately start the installation."

I'm curious though, does that also mean that you're going to change the text of the Continue button to "Install now"? And, if so, will it say install now regardless of the option chosen?

I really think it works out OK either way. We now offer a lot of options with ubiquity depending on what exists at the beginning of the installation and this is the only scenario that I find somewhat confusing. Even an upgrade via live CD (DVD) from Oneiric to Precise worked quite well for me :^)

I have one more test to perform ASAP to see where we're at with bug 657397 which I think is quite insignificant if it does still exist. I certainly applaud your efforts and those of everyone at Canonical. Precise is looking great.

As usual I'll wait until Beta 1 before trying the "Wubi if 4 primaries exist" test unless asked to test earlier.

Thanks for all you do.

On Tue, Dec 13, 2011 at 09:19:27PM -0000, Erick Brunzell wrote:
> I just tested the 20111213-i386 image and it still shows "continue"
> rather than "install now"

I haven't uploaded the fix yet. Wait 'til a day after this bug status
flips to "Fix Released" before retesting ...

Colin Watson (cjwatson) wrote :

On Wed, Dec 14, 2011 at 12:47:31AM -0000, Erick Brunzell wrote:
> Why would we treat free-space with less regard than an actual disc?
>
> I very seriously think the best "fix" to this is to present another
> "page" just as we do with a resize or use entire.

The problem is basically that the backend code would have to be
completely refactored to make this possible, because we're piggybacking
off existing code that only presents a single way to use free space -
changing that is a large job and I'm afraid we aren't going to have time
to do that for precise (we're low on installer development time for this
cycle and only have time for targeted fixes, not substantial feature
work).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.9.8

---------------
ubiquity (2.9.8) precise; urgency=low

  [ Colin Watson ]
  * GTK frontend:
    - Some automatic partitioning options change the text on the next button
      to "Install Now". Make sure that this works even when changing to the
      automatic partitioning page with one of those options automatically
      selected (LP: #766265).
  * Automatic update of included source packages: base-installer
    1.122ubuntu3, partman-auto 93ubuntu18, partman-basicfilesystems
    71ubuntu2.

  [ Stéphane Graber ]
  * Use username associated with uid 999 rather than hardcoding 'ubuntu'
    in Ubiquity. This is important now that casper sets the username and
    hostname based on media name. (LP: #290351)
 -- Colin Watson <email address hidden> Thu, 15 Dec 2011 18:57:10 +0000

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
Erick Brunzell (lbsolost) wrote :

@ Colin Watson,

This works well. I'm happy with it ;^)

This will make it easy to explain to noobs exactly what is going to happen.

Erick Brunzell (lbsolost) wrote :

I was performing some follow up testing and stumbled into bug 905628. I don't know if that's related to this change or not.

Erick Brunzell (lbsolost) wrote :

@ Colin Watson,

I think I have bug 905628 figured out, not sure we created it with this fix, but the 20111213 image was OK.

Anyway, now if you have an existing swap partition you must manually "swapoff" before beginning an automated install or you get a freeze as described in that bug report.

Sorry for causing you grief and additional work.

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/766265

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers