Change of proposed computer name causes error

Bug #760884 reported by Pjotr12345 on 2011-04-14
30
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

When installing Ubuntu 11.04, Ubiquity proposes a name for the computer, by which it will be identified on the network.

Changing this name causes an error: supposedly "the name is already in use on the network". This error shows for each and every name you try! So there's no solution.

As installation is already well under way at that time, this is quite a nuisance.

Evan (ev) wrote :

Are you sure there are not other computers on your network with that name already? What names did you try?

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Evan (ev) wrote :

I've made this a warning instead of an error for now, but I would still like to know the circumstances that trigged this for you.

Pjotr12345 (computertip) wrote :

I'm quite sure that there were no other computers on the network with that name. As a matter of fact, it was my home network and all of my other computers have different names. And they were all switched off at the time.

I tried about twenty different names, quite random ones in the end. Only characters and figures, no weird symbols or spaces. Nothing was accepted.

Until I used a random name with a dot in it, which was thankfully accepted (yay!) so I could go on. I was able to change this nonsensical name afterwards in /etc/hosts without a hitch....

I hope you can fix this before Natty final ships. A bit late in the day, but there's definitely something wrong in Ubiquity's computer name checker.

Pjotr12345 (computertip) wrote :

Off topic: /etc/hosts = /etc/hostname. Oops. :P

On topic: I was able to reproduce this Ubiquity error on two different computers. So I suppose that it must be easy for you (Evan Dandrea) to reproduce this error as well.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.6.6

---------------
ubiquity (2.6.6) natty; urgency=low

  [ Jonathan Riddell ]
  * bin/ubiquity-dm: use correct KDE wallpaper path

  [ Colin Watson ]
  * Don't copy keyboard-configuration questions to /target in OEM mode, and
    reset any values that come from the live filesystem build. oem-config
    will ask them later, and copying these confuses it (LP: #741304).
  * GTK frontend:
    - Avoid a crash if the automatic partitioning page is never displayed.

  [ Evan Dandrea ]
  * Remove the 'Bootloader device' line. See LP #726740.
  * Do not reset the bootloader choice unless it's absolutely necessary
    (LP: #756920). Thanks Stéphane Graber!
  * Move installation of the nvidia driver to after the removal of
    unneeded kernels. Divert update-initramfs for the duration and
    trigger it afterwards (LP: #759804).
  * Make the 'name already exists on the network' warning message not
    block the user from moving forward (LP: #760884).
  * Briefly shut down the debconf database to flush any changes before
    starting the parallel database (LP: #761094).
  * Fix removal of slideshow packages for non-GTK frontends
    (LP: #745607).
  * Set the locale again after the timezone page so that the slideshow
    can have country-specific translations (LP: #758658).
  * Automatic update of included source packages: base-installer
    1.116ubuntu2, choose-mirror 2.37ubuntu2, console-setup 1.57ubuntu19,
    flash-kernel 2.28ubuntu19, user-setup 1.28ubuntu15.
  * Update translations from Launchpad.

  [ Mario Limonciello ]
  * Show the oem-config slideshow in oem-config rather than the ubuntu one.
  * Uninstall the oem-config slideshow after install is done (LP: #759935).

  [ Julien Lavergne ]
  * Disable ubiquity panel for openbox session.

  [ Mackenzie Morgan ]
  * Make radio buttons use label wording for screen reader (LP: #749653)
 -- Evan Dandrea <email address hidden> Tue, 19 Apr 2011 11:45:53 +0100

Changed in ubiquity (Ubuntu):
status: Incomplete → Fix Released

From the changelog above:
>Make the 'name already exists on the network' warning message not block the user from moving forward

This doesn't sound like a complete fix. It is still nagging me with this message with todays iso as long as I have a network connection active. It never blocked me anyway.

Pjotr12345 (computertip) wrote :

Well, the network name issue doesn't block the install anymore. But it still wrongly reports that the network name exists already.

Worse: with the daily build of 20-4, Ubiquity apparently doesn't recognize the hard disk anymore, so it "hangs" in the slide show: no partitioning proposal.

Yes, I also got stuck in the slideshow (bug 767317). It is fixed in the current iso.

The problem originally reported here--or a very similar problem--still exists in the latest Oneiric daily-lives. Primarily since this bug seems to have been used to fix the related but different problem of duplicate computer names being an error rather than a warning during installation, and secondarily because I am not certain that the problem in Oneiric is precisely the same as this one, I have reported this as new bug 828181.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/760884

tags: added: iso-testing
Charlie Kravetz (charlie-tca) wrote :

This bug is back. It is present on the Xubuntu images, every install using the Precise daily-live images.

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in ubiquity (Ubuntu):
status: Fix Released → Triaged
importance: Undecided → Medium
Dan Kegel (dank) wrote :

This happens here, too, if my ISP's "name redirect service" is enabled.
http://dnssearch.rr.com/faq.php
Disabling that makes the problem go away!

So the bug is that the installer is getting fooled by the DNS server's fake response.
Before trusting the DNS service, it should do a random lookup
that should fail. If it succeeds, you know the service is lying.
Here's an untested patch against the previous version of ubiquity showing
one way to implement this.

Dan Kegel (dank) wrote :

The attachment "draft untested patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
tags: added: ubi-usersetup
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.9.20

---------------
ubiquity (2.9.20) precise; urgency=low

  [ Colin Watson ]
  * Restore old fallback code in case /cdrom/casper/filesystem.size doesn't
    exist (LP: #557388).
  * Fix some more uses of deprecated python-apt APIs.
  * ubiquity-dm: Try openbox after openbox-lubuntu (LP: #888107).
  * Thomson SA is now called Technicolor SA (LP: #856992).
  * Limit maximum length of username editing widgets to 32 (LP: #831319).
  * UTF-8-encode the syslog message when a geoname lookup fails, since it
    might include non-ASCII characters entered by the user (LP: #928891).
  * Run test suite under xvfb-run by default when running it from the
    command line. 'tests/run --no-xvfb' inhibits this behaviour for cases
    where it's useful to see the UIs constructed by the test suite.
  * Stop manually inserting newlines in hostname and username errors. GTK+
    3 seems to do a reasonable job of wrapping these by itself now.
  * Port the user page from GtkTable to GtkGrid, so that we get sensible
    height-for-width geometry management (LP: #830933).
  * Internationalise hostname and username validation errors (LP: #784825).

  [ Mario Limonciello ]
  * Have two separate failsafe attempts for 'fbdev' and 'vesa'. It's
    possible that /dev/fb0 will exist but be backed by a VGA framebuffer
    causing X to exit non-zero.

  [ Stéphane Graber ]
  * Use the Xubuntu wallpaper when available. (LP: #936572)
  * Detect bogus DNS servers and ignore them. (LP: #760884)
  * Automatic update of included source packages: base-installer
    1.122ubuntu5, choose-mirror 2.39ubuntu4.
 -- Stephane Graber <email address hidden> Tue, 21 Feb 2012 21:09:02 -0500

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
Aidan Fitzgerald (duckjr159) wrote :

I'm still getting this bug in 16.04. When I disconnect my computer from
the network, the fake error disappears, unlike in Bug 924511.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers