Release Notes Link in Ubiquity directs to ubuntu.com, not release notes

Bug #759870 reported by Jeff Lane on 2011-04-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Website - OBSOLETE
High
Unassigned
ubiquity (Ubuntu)
Medium
Canonical Foundations Team
Natty
Medium
Canonical Foundations Team

Bug Description

Binary package hint: ubiquity

Trying the Beta 2 ISO for 32bit Ubuntu as of 13 April. I'm doing an OEM install for ISO testing.

On the welcome page for Ubiquity, the link that says "You may wish to read the release notes" opens a Firefox browser and goes to www.ubuntu.com, it does not lead directly to release notes. This could be rather confusing if someone is expecting a direct link to "release notes".

tags: added: iso-testing
Evan (ev) wrote :

Can you paste the contents of .disk/release_notes_url from the CD that you used?

Thanks!

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

Confirmed with latest desktop iso.

here is the content of .disk/release_notes_url:
  http://www.ubuntu.com/getubuntu/releasenotes?os=ubuntu&ver=11.04&lang=${LANG}
which redirects to the release notes as expected.

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
milestone: none → ubuntu-11.04
status: Incomplete → Triaged
Changed in ubiquity (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Jeff Lane (bladernr) wrote :

http://www.ubuntu.com/getubuntu/releasenotes?os=ubuntu&ver=11.04&lang=${LANG}

If I try that directly, I'm redirected to the Ubuntu.com landing page... if I remove the lang= parameter, I get release notes.

When I was doing install testing and noticed this, I was using the Desktop isos as of 4/13. For language at the beginning, I chose the default of English in the Language Selection that pops up as soon as the ISO boots.

Also, I was booting the ISO as a CD device in a VirtualBox VM.

I also just tried this using the i386 DVD from yesterday and got the same result. Also of note: when Firefox opens when I click on the Release Notes link, I get the popup that tells me that FF is not the default browser.

Evan (ev) wrote :

Looks like a bug in http://www.ubuntu.com/getubuntu/releasenotes. As you suggest, it fails when the lang parameter is set. Moving to the ubuntu-website project.

Matthew Nuzum (newz) on 2011-04-14
Changed in ubuntu-website:
status: New → Confirmed
importance: Undecided → High
Matthew Nuzum (newz) wrote :

I've just published a fix to this, can you confirm if it still happens? It should now take you to https://wiki.ubuntu.com/NattyNarwhal/TechnicalOverview and in about a week it will take you to the actual release notes (once they're written).

Changed in ubuntu-website:
status: Confirmed → Fix Released
Jean-Baptiste Lallement (jibel) wrote :

I confirm the fix and the user is redirected to the technical overview. I'm closing the ubiquity task.

Changed in ubiquity (Ubuntu Natty):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers