oem-config fails to start on headless images

Bug #758858 reported by Tobin Davis on 2011-04-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: ubiquity

When booting an ubuntu-headless-preinstalled image, oem-config is supposed to start in a serial console for final image configuration. Currently, it fails to launch, leaving the user logged in as root with the suggestion of running adduser to create a working account.

I used this to try running "oem-config-firstboot --debug" and still died. Log output attached.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: oem-config 2.6.2
ProcVersionSignature: Ubuntu 2.6.38-1207.10-omap4 2.6.38
Uname: Linux 2.6.38-1207-omap4 armv7l
Architecture: armel
Date: Tue Apr 12 07:02:13 2011
PackageArchitecture: all
ProcEnviron: PATH=(custom, no user)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Tobin Davis (gruemaster) wrote :
Changed in ubiquity (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-2
tags: added: iso-testing
Oliver Grawert (ogra) wrote :
Oliver Grawert (ogra) wrote :

above the output when adding strace -f -s 1024 to oem-config-wrapper

Oliver Grawert (ogra) wrote :

backing out bzr commit 4632 from ubiquity:
 * Do a quick check at startup to see if the debconf database is locked by
    something else, and exit slightly more gracefully than by raising an
    exception (LP: #746020).

...makes oem-config-debconf run fine, i'm just finishing the installation with these lines removed from the code.

Oliver Grawert (ogra) on 2011-04-12
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) on 2011-04-12
Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Fix Committed
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.6.4

---------------
ubiquity (2.6.4) natty; urgency=low

  * Don't check for debconf database locks when ubiquity is itself running
    inside a debconf frontend (LP: #758858).
 -- Colin Watson <email address hidden> Tue, 12 Apr 2011 21:25:47 +0100

Changed in ubiquity (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers