Natty slideshow uses en_GB for all English users

Bug #758658 reported by Chad A. Davis on 2011-04-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Evan
Natty
Low
Evan

Bug Description

One of the headings in the slideshow reads "Customise Ubuntu" when my locale is set to the default: en_US
This is correct for en_GB, translated here:
https://translations.launchpad.net/ubuntu/natty/+source/ubiquity-slideshow-ubuntu/+pots/ubiquity-slideshow-ubuntu/en_GB/+translate
But for en_US it should be "Customize Ubuntu", with a 'z'.

Dylan McCall (dylanmccall) wrote :

Thanks for taking the time to report this, Chad. However, the English translations are all stripped out at this point to reduce our footprint. (And there might be a different reason; I think Evan did it). We just use the base locale for English. For Natty I'm trying en_GB by default because it fits in with the slideshow's place as a kind of bridge between ubuntu.com/desktop and your final system (and all of the web stuff is en_GB).

Changed in ubiquity-slideshow-ubuntu:
importance: Undecided → Low
importance: Low → Wishlist
status: New → Confirmed
Chad A. Davis (chadadavis) wrote :

I see. Thanks for explaining that. Just wanted to double check.

Jeremy Bicha (jbicha) wrote :

I'm annoyed that the slideshow shows "Ubuntu Software Centre" for en-us users.

summary: - Using "customise" with en_US
+ Natty slideshow uses en_GB for all English users
tags: added: regression
Evan (ev) wrote :

The English variant translations were removed because they are not in the list of supported languages for use during installation. The full list can be found here:
http://bazaar.launchpad.net/~ubuntu-core-dev/localechooser/ubuntu/view/head:/languagelist

Evan (ev) wrote :

Okay, the current plan is to add back location-specific pofiles when the difference isn't just noise and retranslate after the timezone page (the first point at which we have a complete locale). I'm going to try to squeeze this in for natty.

Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
importance: Undecided → Low
milestone: none → ubuntu-11.04
status: New → Confirmed
Evan (ev) on 2011-04-19
Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.6.6

---------------
ubiquity (2.6.6) natty; urgency=low

  [ Jonathan Riddell ]
  * bin/ubiquity-dm: use correct KDE wallpaper path

  [ Colin Watson ]
  * Don't copy keyboard-configuration questions to /target in OEM mode, and
    reset any values that come from the live filesystem build. oem-config
    will ask them later, and copying these confuses it (LP: #741304).
  * GTK frontend:
    - Avoid a crash if the automatic partitioning page is never displayed.

  [ Evan Dandrea ]
  * Remove the 'Bootloader device' line. See LP #726740.
  * Do not reset the bootloader choice unless it's absolutely necessary
    (LP: #756920). Thanks Stéphane Graber!
  * Move installation of the nvidia driver to after the removal of
    unneeded kernels. Divert update-initramfs for the duration and
    trigger it afterwards (LP: #759804).
  * Make the 'name already exists on the network' warning message not
    block the user from moving forward (LP: #760884).
  * Briefly shut down the debconf database to flush any changes before
    starting the parallel database (LP: #761094).
  * Fix removal of slideshow packages for non-GTK frontends
    (LP: #745607).
  * Set the locale again after the timezone page so that the slideshow
    can have country-specific translations (LP: #758658).
  * Automatic update of included source packages: base-installer
    1.116ubuntu2, choose-mirror 2.37ubuntu2, console-setup 1.57ubuntu19,
    flash-kernel 2.28ubuntu19, user-setup 1.28ubuntu15.
  * Update translations from Launchpad.

  [ Mario Limonciello ]
  * Show the oem-config slideshow in oem-config rather than the ubuntu one.
  * Uninstall the oem-config slideshow after install is done (LP: #759935).

  [ Julien Lavergne ]
  * Disable ubiquity panel for openbox session.

  [ Mackenzie Morgan ]
  * Make radio buttons use label wording for screen reader (LP: #749653)
 -- Evan Dandrea <email address hidden> Tue, 19 Apr 2011 11:45:53 +0100

Changed in ubiquity (Ubuntu Natty):
status: Fix Committed → Fix Released
no longer affects: ubiquity-slideshow-ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers