Natty Beta 2 test-image ubiquity ignores existing free space

Bug #758236 reported by Erick Brunzell on 2011-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Evan

Bug Description

Binary package hint: ubiquity

I need to get in a more visually acceptable environment for me. I've saved some data/screenshots that may be helpful but ATM I wanted to save apport info. I apologize for the inconvenience.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubiquity 2.6.2 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Tue Apr 12 00:30:21 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110411.1)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :

Oops, first goof. This is obviously not yet the beta 2 as such does not exist. This is the first iso-testing image. Sorry.

I'm rebooting now and I'll attach more info.

summary: - Natty Beta 2 ubiquity ignores existing free space
+ Natty Beta 2 test-image ubiquity ignores existing free space
Erick Brunzell (lbsolost) wrote :

OK, I began with:

ubuntu@ubuntu:~$ sudo parted -l
Model: ATA WDC WD5000AAKS-0 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 32.3kB 43.3GB 43.3GB primary ext3 boot
 2 43.3GB 86.2GB 42.8GB primary ext3
 3 86.2GB 129GB 43.0GB primary ext3
 4 129GB 500GB 371GB extended
18 129GB 151GB 21.8GB logical ext4
14 151GB 172GB 21.1GB logical ext4
15 172GB 193GB 21.1GB logical ext4
16 193GB 215GB 21.4GB logical ext4
17 215GB 236GB 21.4GB logical ext4
13 236GB 258GB 22.0GB logical ext4
12 258GB 280GB 21.6GB logical ext3
11 280GB 301GB 21.7GB logical ext4
10 301GB 323GB 21.8GB logical ext4
 5 323GB 378GB 55.1GB logical ext3
 6 378GB 432GB 53.6GB logical ext3
 7 432GB 487GB 54.9GB logical ext3
 8 487GB 498GB 10.7GB logical ext3
 9 498GB 500GB 2517MB logical linux-swap(v1)

Model: ATA WDC WD800JB-00JJ (scsi)
Disk /dev/sdb: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 56.5GB 56.5GB primary ext4
 2 77.9GB 80.0GB 2137MB extended
 5 77.9GB 80.0GB 2136MB logical linux-swap(v1)

I'm also attaching a screenshot named "Gparted.png" that shows my /dev/sdb status pre-install, and another named "Installer.png" showing what the installer was going to do.

Colin Watson and I spoke about this here:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/652852

Please jump to post #35 and go forward.

And about that dart board...................................

I really do hope you know I'm only trying to help :^)

Erick Brunzell (lbsolost) wrote :

Hmmm, that only got the Installer.png, here's the other.

Erick Brunzell (lbsolost) wrote :

You can see I had nearly 20GB cleared for the new install and ubiquity decided not to use it.

I tried one with a 4/10 daily where I had slightly more free space than what was available in the existing partition and it worked as expected.

I'd certainly that if someone creates a free space sufficient for Ubuntu, and they have less than 3 primary partitions, and if that truly is the "largest free space" it should be respected.

tags: added: iso-testing
Evan (ev) on 2011-04-12
Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
importance: Undecided → Medium
milestone: none → ubuntu-11.04
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.6.3

---------------
ubiquity (2.6.3) natty; urgency=low

  * Clean up after the langpacks state on multiple runs of the installer.
  * Prefer biggest_free over resize always now that we make sure the
    biggest_free choice offers at least 5GB (LP: #758236, LP: #652852).
  * Determine the home directory of the target user when copying the
    network configuration (LP: 745607).
  * Select all the ubiquity slideshow packages for removal, and do not
    error out if none can be found (LP: #745607).
  * Update translations from Launchpad.
  * Automatic update of included source packages: console-setup
    1.57ubuntu18, migration-assistant 0.6.10.
 -- Evan Dandrea <email address hidden> Tue, 12 Apr 2011 18:29:53 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers