Natty manual-partitioner is dangerously forgetful

Bug #756920 reported by Grondr on 2011-04-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Stéphane Graber
Nominated for Oneiric by Evan
Natty
High
Stéphane Graber

Bug Description

Binary package hint: live-installer

Using the daily build of 4/8 (AMD64 desktop) and trying to install to a disk that was NOT /dev/sda, I discovered that the manual partitioner kept RESETTING the device on which to install the bootloader to /dev/sda every single time I added or changed a partition! This means that, if I change the pulldown at the bottom of that screen to, say, /dev/sdb, start partitioning it, and then fail to check it before saying "Install", it would have smashed /dev/sda's MBR.

This was repeatable on several different trial installs, and I believe was also true of the 3/30 build and the beta release candidate. It also insisted on showing me the horizontal bargraph of paritioning for /dev/sda at the top, no matter whether I was repartioning /dev/sdb or any other device.

Obviously this is incredibly dangerous behavior---if I change a pulldown to reset where the MBR goes, the installer should respect that and not force me to make it the last thing I do before I hit "Install". Someone less observant could have very easily rendered their machine unbootable if they hadn't noticed this change out from under them---or smashed a LUKS header (destroying an entire disk) or an LVM header (ditto) if the disk wasn't partitioned, unless both of those utilities include a buffer zone before their live data in the unpartitioned case. In any event, a dual-disk, dual-boot machine with Windows on /dev/sda might have had its MBR smashed, and certainly Ubuntu wouldn't have booted, either, since the disk that was partitioned and installed to wasn't the disk which would have had its MBR overwritten.

affects: live-installer (Ubuntu) → ubiquity (Ubuntu)
Evan (ev) on 2011-04-11
Changed in ubiquity (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-11.04
status: New → Confirmed
Changed in ubiquity (Ubuntu Natty):
assignee: nobody → Stéphane Graber (stgraber)
Stéphane Graber (stgraber) wrote :

http://paste.ubuntu.com/593732/ should do the trick, needs a bit more testing though.

Evan (ev) on 2011-04-15
Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.6.6

---------------
ubiquity (2.6.6) natty; urgency=low

  [ Jonathan Riddell ]
  * bin/ubiquity-dm: use correct KDE wallpaper path

  [ Colin Watson ]
  * Don't copy keyboard-configuration questions to /target in OEM mode, and
    reset any values that come from the live filesystem build. oem-config
    will ask them later, and copying these confuses it (LP: #741304).
  * GTK frontend:
    - Avoid a crash if the automatic partitioning page is never displayed.

  [ Evan Dandrea ]
  * Remove the 'Bootloader device' line. See LP #726740.
  * Do not reset the bootloader choice unless it's absolutely necessary
    (LP: #756920). Thanks Stéphane Graber!
  * Move installation of the nvidia driver to after the removal of
    unneeded kernels. Divert update-initramfs for the duration and
    trigger it afterwards (LP: #759804).
  * Make the 'name already exists on the network' warning message not
    block the user from moving forward (LP: #760884).
  * Briefly shut down the debconf database to flush any changes before
    starting the parallel database (LP: #761094).
  * Fix removal of slideshow packages for non-GTK frontends
    (LP: #745607).
  * Set the locale again after the timezone page so that the slideshow
    can have country-specific translations (LP: #758658).
  * Automatic update of included source packages: base-installer
    1.116ubuntu2, choose-mirror 2.37ubuntu2, console-setup 1.57ubuntu19,
    flash-kernel 2.28ubuntu19, user-setup 1.28ubuntu15.
  * Update translations from Launchpad.

  [ Mario Limonciello ]
  * Show the oem-config slideshow in oem-config rather than the ubuntu one.
  * Uninstall the oem-config slideshow after install is done (LP: #759935).

  [ Julien Lavergne ]
  * Disable ubiquity panel for openbox session.

  [ Mackenzie Morgan ]
  * Make radio buttons use label wording for screen reader (LP: #749653)
 -- Evan Dandrea <email address hidden> Tue, 19 Apr 2011 11:45:53 +0100

Changed in ubiquity (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers