ubiquity crashed with ValueError in command(): invalid literal for int() with base 10: ''

Bug #746020 reported by Alessandro Losavio on 2011-03-30
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Colin Watson

Bug Description

Binary package hint: ubiquity

Ubuntu 11.04 amd64

1) click on "install Ubuntu 11.04"

the crash appear to me

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: ubiquity 2.5.32
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
Date: Wed Mar 30 20:18:54 2011
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Beta 1 amd64 (20110329.1)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/5293/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with ValueError in command(): invalid literal for int() with base 10: ''
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Alessandro Losavio (alo21) wrote :
visibility: private → public
tags: added: iso-testing
Colin Watson (cjwatson) wrote :

The debug log says:

debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable

Did you have a package management program running when you started the installer?

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Colin Watson (cjwatson) wrote :

I've made the response to this situation a bit more graceful (so it won't raise an exception and show up as a crash report), although it will still be unsuccessful. The message will say:

  Debconf database is locked!
  This may be because a package management program is running.

Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Low
status: Incomplete → Fix Committed

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #627791, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check

Il 31/03/2011 00:05, Colin Watson ha scritto:
> The debug log says:
>
> debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by
> another process: Resource temporarily unavailable
>
> Did you have a package management program running when you started the
> installer?
Yes. May be I was installing Adobe Reader from Ubuntu Software Centre.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.5.33

---------------
ubiquity (2.5.33) natty; urgency=low

  [ Colin Watson ]
  * Shut down the debconf-communicator instance started in DM.run. This
    should reduce the number of spurious crash reports we get.
  * KDE frontend:
    - Force the SIGCHLD handler installed by QProcessManager to use
      SA_RESTART, in the hope of avoiding problems with Python's lack of
      EINTR-safety (LP: #745014).
    - Show ext2 and btrfs in the same colour as ext3 and ext4, rather than
      in the same colour as free space.
  * localechooser/supported-locales only lists additional locales, so
    calculate the set of language packs to install using the union of it and
    debian-installer/locale (LP: #741304).
  * Do a quick check at startup to see if the debconf database is locked by
    something else, and exit slightly more gracefully than by raising an
    exception (LP: #746020).
  * GTK frontend:
    - Fix the partman plugin to convert the return value of
      gtk.TreeModel.get_value to Unicode before looking it up in a dict
      (LP: #746408).
  * Update translations from Launchpad (LP: #745924, #746500).
  * Automatic update of included source packages: flash-kernel 2.28ubuntu18.

  [ Evan Dandrea ]
  * Clarify substitution variables in the debconf templates using comments.
 -- Colin Watson <email address hidden> Sat, 02 Apr 2011 13:03:38 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers