Installer not localized completely

Bug #745924 reported by Chad A. Davis on 2011-03-30
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned
ubiquity-slideshow-ubuntu (Ubuntu)
Medium
Stéphane Graber

Bug Description

Binary package hint: ubiquity

Maybe just a case of missing translations, but I'm following the localization test cases from here:
http://testcases.qa.ubuntu.com/Install/NonEnglishLanguage#Installation%20Full%20Network%20Support
The screen for setting up the partitioning options is not localized. All of the options are in English (screenshot attached).

This is natty-desktop-amd64.iso from 2009-03-29.1

Chad A. Davis (chadadavis) wrote :
tags: added: natty
Chad A. Davis (chadadavis) wrote :

Also the welcome screens (that display while installing) are not localized, including:
* Welcome to Ubuntu
* Finding software
* (something about organizing your photos)
* etc.

Chad A. Davis (chadadavis) wrote :

I forgot to mention, I ran the installer in German.

summary: - Partitioning setup not localized correctly
+ Installer not localized completely
Colin Watson (cjwatson) wrote :

It'll just be incomplete translations, I guess. In future please file multiple localisation issues as separate bugs, as they generally require fixes in different places. In this case it happened that the two issues you mentioned are in different packages, so I just created a new bug task.

Dylan McCall (dylanmccall) wrote :

Yep, the slideshow is not localized at this point because just about every string was replaced a little while ago. I double checked and that is now available to translators :)

Thanks for reporting!

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
importance: Undecided → Medium
Colin Watson (cjwatson) on 2011-04-02
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.5.33

---------------
ubiquity (2.5.33) natty; urgency=low

  [ Colin Watson ]
  * Shut down the debconf-communicator instance started in DM.run. This
    should reduce the number of spurious crash reports we get.
  * KDE frontend:
    - Force the SIGCHLD handler installed by QProcessManager to use
      SA_RESTART, in the hope of avoiding problems with Python's lack of
      EINTR-safety (LP: #745014).
    - Show ext2 and btrfs in the same colour as ext3 and ext4, rather than
      in the same colour as free space.
  * localechooser/supported-locales only lists additional locales, so
    calculate the set of language packs to install using the union of it and
    debian-installer/locale (LP: #741304).
  * Do a quick check at startup to see if the debconf database is locked by
    something else, and exit slightly more gracefully than by raising an
    exception (LP: #746020).
  * GTK frontend:
    - Fix the partman plugin to convert the return value of
      gtk.TreeModel.get_value to Unicode before looking it up in a dict
      (LP: #746408).
  * Update translations from Launchpad (LP: #745924, #746500).
  * Automatic update of included source packages: flash-kernel 2.28ubuntu18.

  [ Evan Dandrea ]
  * Clarify substitution variables in the debconf templates using comments.
 -- Colin Watson <email address hidden> Sat, 02 Apr 2011 13:03:38 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
assignee: nobody → Stéphane Graber (stgraber)
Stéphane Graber (stgraber) wrote :

Evan's upload this morning fixed the issue. I now have both ubiquity and the slideshow translated.
That's by using today's daily build + updating ubiquity-slideshow-ubuntu to the latest version.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers