Kubuntu natty pre-beta installer crash

Bug #745446 reported by Glen Ditchfield on 2011-03-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

I used usb-creator-gtk to create a live usb key from the Kubuntu desktop image 20110329.1, natty-desktop-i386.iso.
I booted an Elitebook 8440p from the key. "Check disc for defects" reported no errors.
I ran through the "desktop manual partitioning" QA test case without major incidents.

I rebooted from the key again and tried a second installation. This time the installer looked odd, with crude GUI elements. For instance the checkboxes in the "Prepare partition" step were black-bordered squares instead of the usual rounded-corner grey shapes.

I set /dev/sda5 to btrfs, /, format, and /dev/sda7 to ext4, /home, don't format. I don't recall whether I hit the "next" button or not. I got two "Installer Crashed" dialog boxes on screen at once.

dialog box 1:
Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/PartitionModel.py", line 104, in parent
    return self.createIndex(parentItem.row(), 0, parentItem)
AttributeError: Partition instance has no attribute 'row'

Dialog box 2:
Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/PartitionModel.py, line 99, in parent
    parentItem = childItem.parent()
AttributeError: '_ModuleWrapper' object has no attribute 'parent'

I rebooted again, and checked the disc for defects again; again no errors were found.

Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :
tags: added: iso-testing
Jonathan Riddell (jr) wrote :

" This time the installer looked odd, with crude GUI elements"

This is an upstream bug which will be fixed when 4.6.2 is released next week
http://quickgit.kde.org/index.php?=kdelibs.git&a=commitdiff&h=979a19afe93d1e4a5be684c1139b6ab242e6b9b6

The crash is a separate issue

Jonathan Riddell (jr) wrote :

I'm afraid I couldn't recreate the crash. It might be a facet of using btrfs.

Glen Ditchfield (gjditchfield) wrote :

Installation has completed successfully three times out of four with the same key on the same computer.

Glen Ditchfield (gjditchfield) wrote :

Same key, same computer. Installation crashed on the fifth attempt, after choosing "/dev/sda7, /home, don't format". Dialog box contents were the same. Note that this key was set up with persistent files, so the contents of partman and syslog are cumulative

Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Glen Ditchfield (gjditchfield) wrote :

I can reproduce the crash.

* Leave the language set at English, and click [Install Kubuntu...]
* On the "Preparing..." screen, I'm not connected to the internet. Don't check the "install 3rd party..." or "download..." checkboxes.
* On the "Allocate Drive Space" screen, select "Manual"
* On the "Prepare Partitions" screen, select /dev/sda5, and click [Change...] if necessary
  - select "btrfs", _do_not_ check the "format" box, mount on "/", and press [OK]
* Back on "Prepare Partitions", check off /dev/sda5's "format" box
* Still on "Prepare Partitions", select /dev/sda7 and click [Change...] if necessary
  - select "ext4", do not check the "format" box, mount on "/home", and press [OK]

I did this starting from a fresh new key containing 20110329.1 that had been set up with a persistent file area. The first attempt gave me pretty GUI widgets, did not make me press [Change...], and succeeded. The next 4 attempts gave me ugly widgets, and crashed, either by throwing up crash dialogs or by dropping straight to a Kubuntu desktop.

On the next 2 attempts I selected /dev/sda5, and in the dialog box I selected btrfs, _did_ check off the "format" checkbox, and selected mount point "/". Both attempts succeeded.

tags: added: ubiquity-2.5.32
tags: added: natty
dino99 (9d9) wrote :

natty have reached EOL now

Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers