return_to_partitioning fails when the replace option fails

Bug #740903 reported by Evan on 2011-03-23
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
Natty
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned

Bug Description

Binary package hint: ubiquity

This probably affects other options, but I first noticed this using replace. The return_to_partitioning function executes and returns as normal, but seemingly fails to properly clean up after partman-commit and initialize partman, as the debug log shows it hanging part of the way through partman-auo.

Evan (ev) wrote :
Changed in ubiquity (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-11.04
status: New → Confirmed
Evan (ev) wrote :

I can't reproduce this anymore, but I want to keep an eye on it in 11.10.

Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Won't Fix
Changed in ubiquity (Ubuntu):
milestone: ubuntu-11.04 → ubuntu-11.10
Changed in ubiquity (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → High
Changed in ubiquity (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
zpletan (zpletan) wrote :

Sorry if this is a really dumb question: this bug is linked in the Natty release notes, and I just want to make sure that it's not going to mess anything up on Natty install. The only thing I do that's not standard is use the partitioner to set up separate /home partition. Is there a real chance that something will go wrong on install, or does this not mean much to the end-user like me?

Evan (ev) wrote :

You should always make backups before doing an installation of any kind; however, the issue mentioned in this bug report will not affect you.

Colin Watson (cjwatson) on 2011-06-15
Changed in ubiquity (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → nobody
Changed in ubiquity (Ubuntu Oneiric):
assignee: nobody → Evan Dandrea (ev)
tags: added: rls-mgr-o-tracking
Steve Langasek (vorlon) wrote :

Evan, is there anything more to be done on this bug? You said you couldn't reproduce it in April - has it been reproducible since?

Steve Langasek (vorlon) on 2011-09-30
Changed in ubiquity (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in ubiquity (Ubuntu):
milestone: ubuntu-11.10 → none
Colin Watson (cjwatson) on 2011-10-04
Changed in ubiquity (Ubuntu Natty):
milestone: ubuntu-11.04 → none
Colin Watson (cjwatson) on 2011-10-05
tags: added: rls-mgr-p-tracking
removed: rls-mgr-o-tracking
Evan (ev) on 2012-03-15
Changed in ubiquity (Ubuntu Precise):
assignee: Evan Dandrea (ev) → nobody
Changed in ubiquity (Ubuntu Oneiric):
assignee: Evan Dandrea (ev) → nobody
Stéphane Graber (stgraber) wrote :

I'm closing it based on the lack of activity.

Changed in ubiquity (Ubuntu Precise):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments