Kubuntu Natty installer crashed

Bug #740558 reported by Glen Ditchfield on 2011-03-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

I created a USB key from the most recent natty-desktop-i386.iso for Kubuntu, and booted from it.
I launched Kubuntu, and when that appeared to work satisfactorily I ran "install kubuntu". I chose to install the extra packages and download updates.
I selected manual partitioning, reformatted a partition as btrfs, kept an existing ext4 /home partition, and left the others unused.

The installer got as far as choosing a keyboard, but vanished -- without any crash notification -- while I was examining the "USA" keyboard choices.

I reran the installer, and it got to "Checking for packages to remove ... 60%" before crashing.

Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :
Glen Ditchfield (gjditchfield) wrote :

Clarification: that was the most recent alpha of natty-desktop-i386, not a daily build.

Glen Ditchfield (gjditchfield) wrote :

"Check disks for errors" on the USB key never finishes. Perhaps it is corrupted; feel free close this bug.

Fabio Marconi (fabiomarconi) wrote :

Mar 22 22:25:23 ubuntu plugininstall.py: File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 271, in _fetch_archives
Mar 22 22:25:23 ubuntu plugininstall.py: raise LockFailedException("Failed to lock %s" % lockfile)
Mar 22 22:25:23 ubuntu plugininstall.py: LockFailedException: Failed to lock /target/var/cache/apt/archives/lock

Fabio Marconi (fabiomarconi) wrote :

Hello
As request from reporter I close this report.
Feel free to reopen it if you can reproduce this issue
Thanks
Fabio

Changed in ubiquity (Ubuntu):
status: New → Invalid
tags: added: i386 kubuntu natty
Jan Killian (jan-killian) wrote :

Reopening:

1. Created an unetbootin USB key from the release xubuntu-11.04-desktop-amd64.iso (md5 verified).

2. Booted the USB and selected Install Xubuntu in boot menu.

3. Chose to install the extra packages and download updates (wifi did not catch-up, so I plugged ethernet cable and installer detected net successfully).

4. Repartitioned manually all space as 256MB ext4 /boot + 4GB swap + 304GB btrfs /

5. Created user and chose autologon and no home encryption (using acer notebook disk lock in bios instead).

The installer crashed at "Checking for packages to remove".

According to syslog:
plugininstall.py: File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 279, in _fetch_archives
plugininstall.py: LockFailedException: Failed to lock /target/var/cache/apt/archives/lock

Will now retest if it is reproducible, and if apt-get upgrade helps.

Also this bug probably affected Ubuntu 10.10 already, according to imho duplicate bug https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/743359, and another report https://answers.launchpad.net/ubuntu/+question/152359.

Btw, what is the bug tag policy? Should I remove i386+kubuntu tags because the bug is not limited to them, or add amd64+ubuntu+xubuntu tags because the bug affects them too?

Changed in ubiquity (Ubuntu):
status: Invalid → New
summary: - Kubuntu Natty installer crashed
+ 10.10+ installer crashes when ubiquity failed to lock
+ /target/var/cache/apt/archives/lock
tags: added: amd64 installer maverick usb
removed: kubuntu

@791081, As you are not the original report please file a new report.

Changed in ubiquity (Ubuntu):
status: New → Invalid
summary: - 10.10+ installer crashes when ubiquity failed to lock
- /target/var/cache/apt/archives/lock
+ Kubuntu Natty installer crashed
Mike Lovell (mike-lovell) wrote :

I experience this today and you can get around it, I used a USB key to install Lubuntu 11.10 and had the same problem during install.

If you bring up a console and run an "apt-get update && apt-get upgrade" (obviously with an internet connection) then try the install again it works. Whatever was causing it must have been fixed.

(This was with Alpha 3 BTW)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers