Unable to install without format

Bug #72897 reported by Jason Laprade on 2006-11-22
58
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubuntu-desktop

On the Edgy Eft CD, the installer in step 5 will not allow one to continue unless the user formats a partiition which Ubuntu is to be installed.
While this might make sense from a technological standpoint, most Novice users might think to themselves that he or she would want to reinstall the OS without reformating the drive in certain circumstances. This would allow the user to essentially role back a change yet start from scratch. This is particularly relavent to the user who has recently switched from Windows to Ubuntu. They would expect that if they reinstall, most basic modules and setting would be set back to what was from the original CD, but their own files would be instact.
Couple that with the fact that the installer does not encourage or require you to create a /home partition which would work better in this situation. While the solution to reformat the root partition and leave the home partition intact does make more sense, most users do not practice good filesystem management (keeping all personal settings and files in the home partition) anyway.

To make sure that I have my reader understanding the problem I am referring to I will give my example. I installed some of the off repo packages for Compriz. One of these packages required me to install the NVidia beta driver which, it turns out, is incompatible with my video adapter. As this is a computer that I rely on a daily basis I do not have time to research how to completely remove the the NVidia beta driver.
Basically I need this system up and working (if only limping) so that I can work. Originally coming from a Windows world, my first thought is to reinstall via a fresh copy of Edgy. But as the installer insists on formatting, I cannot proceed as I have valuable files on the computer.

I think that this is design flaw that needs to be rectified. If it absolutely necessary to format, then it is absolutely imperitive that the installer (partitioner) forces one to create a /home directory.

Colin Watson (cjwatson) wrote :

For the time being, it is absolutely necessary to format from the point of view of supportability; we cannot support a mutant system that started out as something else and then had Ubuntu's files just dropped over the top of it without cleaning out what was there before. Perhaps in the future we'll figure out a way to have ubiquity wipe out everything but /home.

Sadly, creating a /home partition can't be the default either, because that means you have to dump the decision of what relative partition sizes to use onto the user, and considering that our partition resizing tools really aren't smooth enough to be foisted on ordinary users who make a mistake in this decision I do not believe that this is appropriate.

Changed in ubuntu-meta:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Ian Hinder (ian-hinder) wrote :

I just ran into this problem when trying to install Feisty. I did not want to use the upgrade procedure (I was running Dapper and had heard about all the problems in the Dapper -> Edgy transition) so I decided to do a fresh install. However, I only had a single partition containing both dapper and /home.

I decided to move everything into a /old directory on that partition and attempted to install Feisty. The installer refused to let me install Feisty into that partition unless I formatted it first. This was a problem for me for several reasons:

(1) I had a large amount of multimedia/documents/other files etc on the partition;

(2) I wanted to keep the existing dapper files around for a little while in case I needed to refer back to them (configuration etc)

In the end I had to install Feisty into a new partition and manually copy it back into the original one (leading to all sorts of headaches with repartitioning, editing grub configs, editing fstab...).

I understand the argument that allowing people to install onto a non-formatted partition creates support problems. However, I think it's a very valid thing to want to do, for the following reasons:

(a) There have been problems with upgrading, leading many users to prefer a fresh install;

(b) Most users do not have a separate home partition, and as was pointed out in the previous message, having a separate home partition is not currently the 'standard'.

(c) A fresh install really does not need to format the partition, and there is no easy workaround for users who know what they are doing

I would suggest that instead of telling the user that the partition *must* be formatted, instead produce a warning saying that installing onto an existing partition without formatting is not recommended, and is not a supported configuration. That would be the simplest fix. More complicated would be to say: ok, install without formatting, but all data will be moved into a '/old' directory or similar.

duhblow7 (duhblow7) wrote :

I had the same issue as Ian, where I wanted to save an obscure /archive folder on a large partition. The installer wouldn't let me install ubuntu on the same partition without reformatting the partition and losing my archive. The way I got around the annoying message box and didn't have to format my system was by deleting one file. If you delete or move this file, the formatting of partitions is not checked:

/lib/partman/check.d/12system_partitions_formatted

Let me know if that works, as I also edited some other python files, but I don't think they are required. System is currently installing and no formatting took place. Support.This.Ubuntu.

Ian P. Christian (pookey) wrote :

I personally just installed my system using debootstrap, bypassing the installer. I wasn't best pleased about having to do it , but i'm posting this from my ubuntu install - so it worked :)

I'd like a 'advanced' option perhaps, that allows you to bypass this check, with a warning that states that no-bug reports should be reported perhaps...

This is very frustrating. I can almost understand the need to nuke /, /usr, and /boot, but /var? This is where my databases live and my mail spool, among other things. I can't see why an advanced user would ever want to blow away /var. Yes, I might create a compatibility problem for myself if an application specific file format changed in some program, but as an advanced user, I should be able to sign up for that if I want to. Please provide a convenient way to override this check in the future.

In the meantime I've edited /lib/partman/check.d/12system_partitions_formatted to work around /var.

9johnny (s.j.) wrote :

Yeah, this is very strange behaviour that makes me remember an other (obscure) operating system made by one of the richest companies in the world, that would nuke anything that's on the disk, for the ease of the user? do we really want to mimic the behaviour of that?

Colin Watson (cjwatson) wrote :

In Ubuntu 8.04, you can choose not to format the target partition; if you do that, the installer will prompt you for confirmation, and if you tell it to carry on it will remove various directories liable to clash with the new install. (For the moment it will remove /var; we might want to be a little more fine-grained in future. Still, it fulfils the basic request of this bug report.)

  https://blueprints.launchpad.net/ubuntu/+spec/ubiquity-preserve-home

Changed in ubiquity:
status: Confirmed → Fix Released

Please look in to the latest Ubuntu, it does not install to an
existing RAID, I have started working and it has been 2 months since I
broke my system. I do not have time to file a bug report, as I work
for 14-16hrs a day as an accountant with a 2 hours commute.

The bootloader doesn't install to a non-raid partition. I am not sure
if the new release can read the initrd file and then the boot image
from the raid.

This problem with the bootloader has affected me me since the 2nd
release of Ubuntu and I have basically had it with Ubuntu because of
it. I just want to save my data now and put it on a mobile disk as I
am never home anyway.

To reproduce the bug install on to a raid then reinstall on to the
raid without formatting, just remove the the non-root non-home
directories and go for it.
My /boot is a separate 1G partition.
/target is the raid.

On 7/28/08, Colin Watson <email address hidden> wrote:
> In Ubuntu 8.04, you can choose not to format the target partition; if
> you do that, the installer will prompt you for confirmation, and if you
> tell it to carry on it will remove various directories liable to clash
> with the new install. (For the moment it will remove /var; we might want
> to be a little more fine-grained in future. Still, it fulfils the basic
> request of this bug report.)
>
> https://blueprints.launchpad.net/ubuntu/+spec/ubiquity-preserve-home
>
> ** Changed in: ubiquity (Ubuntu)
> Status: Confirmed => Fix Released
>
> --
> Unable to install without format
> https://bugs.launchpad.net/bugs/72897
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

riyaz (riyazkaware) on 2015-05-24
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers