ubiquity-slideshow tears down oem-config on armel

Bug #727468 reported by Tobin Davis on 2011-03-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
livecd-rootfs (Ubuntu)
High
Michael Casadevall
Natty
High
Michael Casadevall
ubiquity (Ubuntu)
High
Unassigned
Natty
High
Unassigned
webkit (Ubuntu)
High
Ricardo Salveti
Natty
High
Ricardo Salveti

Bug Description

Binary package hint: ubiquity

Images were from http://cdimage.ubuntu.com/ubuntu-netbook/daily-preinstalled/20110301/
This is on both omap & omap4 images.

After oem-config started post-boot configuration, oem-config appeared to have finished, but the system didn't restart gdm, nor was I able to log in via console. After a few minutes, X crashed leaving me with a garbled root console (reset cleared the terminal).

This was found in /var/log/syslog:
ar 1 21:52:29 acorn ubiquity[952]: Step_before = stepUserInfo
Mar 1 21:54:27 acorn ubiquity: umount: /cdrom: not found
Mar 1 21:54:27 acorn ubiquity:
Mar 1 21:54:27 acorn plugininstall.py: log-output -t ubiquity umount /cdrom
Mar 1 21:54:27 acorn ubiquity: grep:
Mar 1 21:54:27 acorn ubiquity: /target/etc/apt/sources.list
Mar 1 21:54:27 acorn ubiquity: : No such file or directory
Mar 1 21:54:27 acorn ubiquity:
Mar 1 21:54:27 acorn plugininstall.py: Exception during installation:
Mar 1 21:54:27 acorn plugininstall.py: Traceback (most recent call last):
Mar 1 21:54:27 acorn plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1486, in <module>
Mar 1 21:54:27 acorn plugininstall.py: install.run()
Mar 1 21:54:27 acorn plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 55, in wrapper
Mar 1 21:54:27 acorn plugininstall.py: func(self)
Mar 1 21:54:27 acorn plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 130, in run
Mar 1 21:54:27 acorn plugininstall.py: self.db.progress('START', self.start, self.end, 'ubiquity/install/title')
Mar 1 21:54:27 acorn plugininstall.py: File "/usr/lib/python2.7/dist-packages/debconf.py", line 65, in <lambda>
Mar 1 21:54:27 acorn plugininstall.py: lambda *args, **kw: self.command(command, *args, **kw))
Mar 1 21:54:27 acorn plugininstall.py: File "/usr/lib/python2.7/dist-packages/debconf.py", line 86, in command
Mar 1 21:54:27 acorn plugininstall.py: status = int(status)
Mar 1 21:54:27 acorn plugininstall.py: ValueError: invalid literal for int() with base 10: ''
Mar 1 21:54:27 acorn plugininstall.py:
Mar 1 21:54:30 acorn ubiquity-dm: Could not find oem, falling back to root.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubiquity 2.5.21
ProcVersionSignature: Ubuntu 2.6.38-5.32-omap 2.6.38-rc6
Uname: Linux 2.6.38-5-omap armv7l
Architecture: armel
Date: Tue Mar 1 22:17:27 2011
ProcEnviron: PATH=(custom, no user)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Tobin Davis (gruemaster) wrote :
Tobin Davis (gruemaster) wrote :

Added syslog.

Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
tags: added: iso-testing
Tobin Davis (gruemaster) on 2011-03-01
Changed in ubiquity (Ubuntu):
milestone: none → natty-alpha-3
Tobin Davis (gruemaster) wrote :

Added /var/log/oem-config.log after booting with debug-oem-config on the kernel cmdline.

Oliver Grawert (ogra) wrote :

as requested by evan, here is the processlist when ubiquity dies

Oliver Grawert (ogra) wrote :

another ps -ef log running in a loop while ubiquity dies

Oliver Grawert (ogra) wrote :

the according syslog (running oem-config with --debug)

Oliver Grawert (ogra) wrote :

and the matching oem-config.log

Oliver Grawert (ogra) wrote :

commenting out the line in plugininstall.py that calls the title it now dies in ubiquity/install/network, it seems that debconf always returns an empty value (instead of an int) here no matter what is called and thus we get the ValueError

Oliver Grawert (ogra) wrote :

complete strace of failed install

Oliver Grawert (ogra) wrote :

excerpt of the plugininstall.py process (PID 2274) from the above strace

Colin Watson (cjwatson) wrote :

This trace shows that the top-level oem-config process is segfaulting, which causes the later failures. I suggest attaching gdb to it before the failure to try to get a stack trace, or else 'ulimit -c unlimited' before starting it so that you get a core dump.

Oliver Grawert (ogra) wrote :

i just noticed that there was also a ubiquity-dm crash report in /var/crash, unlikely thats more helpful than the strace but i'll attach it anyway

Tobin Davis (gruemaster) wrote :

After working around bug 727783 (see comment #3) on an x86 VM install, I was able to get oem-config to run to completion on x86.

Ricardo Salveti (rsalveti) wrote :
Changed in ubiquity (Ubuntu Natty):
status: New → Confirmed
Tobin Davis (gruemaster) wrote :

Appears that uninstalling ubiquity-slideshow-ubuntu allows oem-config to progress through the installation.

Ricardo Salveti (rsalveti) wrote :

Python is crashing with sigsegv at the time it loads webkit to show the installer slides. After removing the package ubiquity-slideshow I was able to finish the installation successfully.

Changed in livecd-rootfs (Ubuntu Natty):
importance: Undecided → Critical
status: New → Confirmed
assignee: nobody → Michael Casadevall (mcasadevall)
milestone: none → natty-alpha-3
Oliver Grawert (ogra) on 2011-03-02
summary: - oem-config crashed during install on armel
+ ubiquity-slideshow tears down oem-config on armel
Ricardo Salveti (rsalveti) wrote :

Fireing up just webkit with /usr/lib/webkitgtk-1.0-0/libexec/GtkLauncher also gets me a sigsegv, so it seems webkit is really broken at ARM.

Tobin Davis (gruemaster) on 2011-03-02
Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Invalid
Martin Pitt (pitti) wrote :

Changelog typo'ed the bug number, closing manually:

livecd-rootfs (1.160) natty; urgency=critical

  * Emergency hack to remove ubiquity-slideshow-* on armel due to python-webkit
    causing a segfault (Works aroud LP: #727368)

Changed in livecd-rootfs (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in ubiquity (Ubuntu Natty):
milestone: natty-alpha-3 → none
Oliver Grawert (ogra) on 2011-03-03
Changed in livecd-rootfs (Ubuntu Natty):
importance: Critical → High
Changed in ubiquity (Ubuntu Natty):
importance: Critical → High
Changed in ubiquity-slideshow-ubuntu (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-11.04-beta-1
Changed in ubiquity-slideshow-ubuntu (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Robbie Williamson (robbiew) wrote :

Based on #17, this bug is not in the slideshow package, but webkit

Changed in ubiquity-slideshow-ubuntu (Ubuntu Natty):
status: Confirmed → Invalid
assignee: Canonical Foundations Team (canonical-foundations) → nobody
milestone: ubuntu-11.04-beta-1 → none
status: Invalid → Confirmed
status: Confirmed → Invalid
affects: ubiquity-slideshow-ubuntu (Ubuntu Natty) → webkit (Ubuntu Natty)
Changed in webkit (Ubuntu Natty):
status: Invalid → Confirmed
Changed in webkit (Ubuntu Natty):
assignee: nobody → Canonical ARM Developers (canonical-arm-dev)
Ricardo Salveti (rsalveti) wrote :

Latest webkit update should have this bug fixed, I'm just testing it with ubiquity-slideshow-ubuntu but it should work fine.

Once tested I'll report back the result to remove the workaround at livecd-rootfs.

Changed in webkit (Ubuntu Natty):
assignee: Canonical ARM Developers (canonical-arm-dev) → Ricardo Salveti (rsalveti)
Ricardo Salveti (rsalveti) wrote :

Tested with image 20110311, by updating webkit and installing ubiquity-slideshow-ubuntu again, and was able to install the image without any issues.

We can safely remove the livecd-rootfs workaround.

Changed in webkit (Ubuntu Natty):
status: Confirmed → Fix Released
Tobin Davis (gruemaster) wrote :

Changed status for livecd-rootfs to remove the workaround.

Changed in livecd-rootfs (Ubuntu Natty):
status: Fix Released → New
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Colin Watson (cjwatson) wrote :

livecd-rootfs (1.165) natty; urgency=low

  * Drop the hack that removes ubiquity-slideshow-* on armel, webkit works
    again.

 -- Oliver Grawert <email address hidden> Wed, 16 Mar 2011 12:09:28 +0100

Changed in livecd-rootfs (Ubuntu Natty):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers