kubuntu amd64: Ubiquity crash on 'Forward' at Timezone step:File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/Keyboard.py", line 233, in loadCodes

Bug #712443 reported by Jean-Baptiste Lallement on 2011-02-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

ISO Testing: Kubuntu DVD AMD64 20110201.2

Got this crash when I clicked 'Forward' on the timezone step.

Exception caught in process_line:
Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 132, in process_line
    return self.dbfilter.process_line()
  File "/usr/lib/ubiquity/ubiquity/debconffilter.py", line 281, in process_line
    if not input_widgets[0].run(priority, question):
  File "/usr/lib/ubiquity/plugins/ubi-console-setup.py", line 407, in run
    self.ui.set_keyboard_variant(self.db.get(question))
  File "/usr/lib/ubiquity/ubiquity/plugin.py", line 44, in wrapper
    return target(self, *args, **kwargs)
  File "/usr/lib/ubiquity/plugins/ubi-console-setup.py", line 307, in set_keyboard_variant
    self.keyboardDisplay.setVariant(var)
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/Keyboard.py", line 68, in setVariant
    self.loadCodes()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/Keyboard.py", line 233, in loadCodes
    cfile = pipe.communicate()[0]
  File "/usr/lib/python2.7/subprocess.py", line 732, in communicate
    stdout = self.stdout.read()
IOError: [Errno 4] Interrupted system call

I clicked on 'Retry' on the alert box and the system installs.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
Date: Thu Feb 3 14:09:00 2011
EcryptfsInUse: Yes
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: ubiquity

Jean-Baptiste Lallement (jibel) wrote :
description: updated
Jean-Baptiste Lallement (jibel) wrote :
  • dm Edit (5.1 KiB, text/plain)
Jean-Baptiste Lallement (jibel) wrote :
tags: added: iso-testing
IKT (ikt) wrote :

Heya,

Are you able to test against the latest dev version?

I can't duplicate the issue :(

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

I'm closing this report because I can't reproduce it.

Changed in ubiquity (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments