[Natty] Couldn't choose correct keyboard layout in Ubiquity

Bug #711926 reported by Jan Rathmann on 2011-02-02
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Natty
High
Colin Watson

Bug Description

Binary package hint: ubiquity

I'm currently trying to test the candidate images for Natty Alpha 2 (20110202, amd64) and ran into the following problem while installing Natty with Ubiquity:

- The screen to select the proper keyboard layout appeared as usual.
- Then I must have pressed some wrong key ('g' to go to 'Germany' in the country list, at least I was trying to do so), the keyboard selection dialog disappeared and Ubiquity went further to next question (entering user name, password, etc.).
- Even if I clicked the 'Back'-button in Ubiquity, I couldn't get the keyboard selection screen back, just the time zone selection.

The result was that to my point of view a random keyboard layout had been selected (Democratic Republic of Kongo) which I had to correct myself in the live environment just to be able to type my user name/password with proper letters.

I was trying to report this bug with 'ubuntu-bug ubiquity', but Apport(?) crashed with the following outpu (maybe a seperate bug?)t:

------------------------

ubuntu-bug ubiquity

(apport-gtk:1920): Gtk-WARNING **: /build/buildd/gtk+2.0-2.24.0/gtk/gtktreestore.c:765: Unable to convert from PyObject to gchararray

(apport-gtk:1920): Gtk-WARNING **: /build/buildd/gtk+2.0-2.24.0/gtk/gtktreestore.c:765: Unable to convert from PyObject to gchararray

(apport-gtk:1920): Gtk-WARNING **: /build/buildd/gtk+2.0-2.24.0/gtk/gtktreestore.c:765: Unable to convert from PyObject to gchararray

(apport-gtk:1920): Gtk-WARNING **: /build/buildd/gtk+2.0-2.24.0/gtk/gtktreestore.c:765: Unable to convert from PyObject to gchararray

Traceback (most recent call last):
  File "/usr/share/apport/apport-gtk", line 357, in <module>
    app.run_argv()
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 563, in run_argv
    return self.run_report_bug()
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 415, in run_report_bug
    self.file_report()
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 951, in file_report
    ticket = upthread.return_value()
  File "/usr/lib/python2.7/dist-packages/apport/REThread.py", line 46, in return_value
    assert not self._exception
AssertionError

------------------------

Thus I had to report it the old manual way.

Kind regards,
Jan
---
Architecture: amd64
DistroRelease: Ubuntu 11.04
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
Package: ubiquity 2.5.32
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=de_DE:en
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
ProcVersionSignature_: Ubuntu 2.6.38-7.39-generic 2.6.38
Tags: natty natty
Uname: Linux 2.6.38-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

tags: added: iso-testing
C de-Avillez (hggdh2) on 2011-02-03
tags: added: natty
Changed in ubiquity (Ubuntu Natty):
milestone: none → natty-alpha-3
Brian Murray (brian-murray) wrote :

I tried recreating this bug report with the daily live cd from 2010-02-02 and was unable to - when I clicked the back button I could indeed go backwards and choose a different keyboard layout. I tried this when the installer was in both the 'copying files' phase and the 'Ready when you are...' phase.

I did notice though that when one starts typing in the keyboard selection dialog a pop-up search box comes up and that if you press enter it does go to the next screen which may be confusing.

Changed in ubiquity (Ubuntu Natty):
importance: Undecided → Low
Jan Rathmann (kaiserclaudius) wrote :

I was able to reproduce this in a more exact way today when I was doing another Natty test installation (20110215, amd64):

- Start the installation process until the keyboard layout dialog appears.
- Then I pressed 'd' to select 'Deutschland' (Germany) in the list on the left side of the window.
- Ubiquity jumped to 'Democratic Republic Kongo' - you could see this only in a twinkling of an eye.
- Then Ubiquity immediately switched forward to the user name/password selected, the keyboard layout was set to 'Democratic Republic Kongo'
- I was _not_ able to go back to correct the choice. If clicked 'back', then just the timezone map appeared again, followed directly by user name dialog - the keyboard layout dialog was silently skipped and I was not able to get it back.

If I can to any further testing to help, please let me know.

Kind regards,
Jan

Martin Pitt (pitti) wrote :

Too late for a3 now.

Changed in ubiquity (Ubuntu Natty):
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
_sAm_ (steffen-inbox) wrote :

I installed Natty Alpha 2 yesterday and hit the wrong language under the «Choose your keyboard layout» (thanks to the touchpad on my laptop).
I tried the "go back" button but will not get the «Choose your keyboard layout» screen back, it skips it, and goes to the partition screen. When I click forward it skips the language menu.
So I had to cancel the installation(I cant enter my name/password under the "Who are you?" menu with wrong language).

finn (finn-uni-bremen) wrote :

Same here with Alpha3.
For others having the same Problem: To correct the keyboard layout I used :

dpkg-reconfigure keyboard-configuration

Evan (ev) wrote :

Can someone who can reproduce this bug please do the following:
- Press 'Try Ubuntu' at the first screen.
- Open a terminal and type `ubiquity -d`
- Run the installer up to the keyboard page and reproduce the bug.
- Open another terminal and type `sudo apport-collect 711926`

Thanks!

Changed in ubiquity (Ubuntu Natty):
importance: Low → Medium
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

Jan Rathmann (kaiserclaudius) wrote :

Note that this time the right country and keyboard layout was preselected in Ubiquity (which is definately an improvement).
But the strange behaviour doesn't change that is:
- When I press "d", "Democratic Republic of Kongo" gets selected as country and keyboard layout and Ubiquity moves to user account page without me pressing the "Next" button
- If I try to go back to change/correct keyboard layout, only the timezone page appears again. If I press "next", the keyboard selection dialog is silently skipped and cannot be brought back.

Kind regards,
Jan

Colin Watson (cjwatson) wrote :

This is only speculation as yet, but I wonder if this has something to do with keyboard layouts that only have a single variant. It's possible that that might make it harder for Ubiquity to control the flow of execution.

I noticed something very similar with the South African layout while testing a fix for another bug.

Changed in ubiquity (Ubuntu Natty):
status: Incomplete → Confirmed
Colin Watson (cjwatson) on 2011-04-08
Changed in ubiquity (Ubuntu Natty):
importance: Medium → High
Mauricio Pretto (pretto) wrote :

I have the very same problem explained on the bug report, it won't happen always but from time to time.
When I go for a Brazilian Portuguese keyboard layout the screen freezes and I can go back or forward, but the install process keep moving.

Colin Watson (cjwatson) on 2011-04-11
Changed in ubiquity (Ubuntu Natty):
status: Confirmed → In Progress
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

Problems with Brazilian are probably a different bug, although I suppose it's possible that my fix for this bug would influence it.

Changed in ubiquity (Ubuntu Natty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.6.2

---------------
ubiquity (2.6.2) natty; urgency=low

  [ Colin Watson ]
  * Handle keyboard layouts with only one variant (LP: #711926).
  * Make sure to set a new variant default when changing keyboard layout
    (LP: #745137).

  [ Evan Dandrea ]
  * Deal with the confirmation key being translated in jockey-text
    (LP: #757208).
  * Update translations from Launchpad.
 -- Evan Dandrea <email address hidden> Mon, 11 Apr 2011 17:51:12 +0100

Changed in ubiquity (Ubuntu Natty):
status: Fix Committed → Fix Released
YamaPlos (yamaplos) wrote :

I had the same problem when trying to selelct Spain (ended up with Sri Lanka!) with Natty official release on March 28th

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers