ubiquity crashed with TypeError in changed(): value is of wrong type for this column

Bug #702898 reported by Wajih Letaief on 2011-01-14
158
This bug affects 31 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: ubiquity

The crash occures when installing from a live session on a virtual machine (VirtualBox PUEL)

The installation continues without another incident but Ubiquity crashed

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: ubiquity 2.5.8
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic i686
Architecture: i386
Date: Fri Jan 14 14:37:59 2011
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110112)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission non accordée: '/proc/4509/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with TypeError in changed(): value is of wrong type for this column
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/ubiquity/plugins/ubi-timezone.py", line 130, in changed
     loc.latitude, loc.longitude])
 TypeError: value is of wrong type for this column
UserGroups:

Wajih Letaief (mawale) wrote :
Wajih Letaief (mawale) wrote :

I'm using an iso file (that i verfied the MD5 sum)
making a new installation on a virtual machine using VirtualBox PUEL
after the crash, even the installation crashes

The iso file used is the daily one (Daily-live from current section : 01-14-2011)

tags: removed: need-duplicate-check
Jonathan Carter (jonathan) wrote :

I'm marking this as high, since it affects all users who's IP addresses are unknown in the geoip database.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
Stéphane Graber (stgraber) wrote :

Marking the bug as public.

Apparently the issue happens when the GeoIP server returns None instead of the location.

Playing with routes at the office, going out from Nuremberg gives:
<?xml version="1.0" encoding="UTF-8"?><Response><Ip>78.46.20.84</Ip><Status>OK</Status><CountryCode>DE</CountryCode><CountryCode3>DEU</CountryCode3><CountryName>Germany</CountryName><RegionCode>None</RegionCode><RegionName>None</RegionName><City>None</City><ZipPostalCode></ZipPostalCode><Latitude>51.0000</Latitude><Longitude>9.0000</Longitude><AreaCode>0</AreaCode><TimeZone>Europe/Berlin</TimeZone></Response>

The same from a Sherbrooke, QC IP that's not in Maxmind's database yet:
<?xml version="1.0" encoding="UTF-8"?><Response><Ip>74.114.101.94</Ip><Status>OK</Status><CountryCode>CA</CountryCode><CountryCode3>CAN</CountryCode3><CountryName>Canada</CountryName><RegionCode>None</RegionCode><RegionName>None</RegionName><City>None</City><ZipPostalCode></ZipPostalCode><Latitude>60.0000</Latitude><Longitude>-95.0000</Longitude><AreaCode>0</AreaCode><TimeZone>None</TimeZone></Response>

The first works fine, the second crashes.

That was tested by doing: wget -O - -q http://geoip.ubuntu.com/lookup

visibility: private → public
Jonathan Carter (jonathan) wrote :

This also happens when networking is disabled.

Erick Brunzell (lbsolost) wrote :

Just experienced this with the iso-testing build for Alpha 2.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Phillip Susi (psusi) wrote :

Ditto, though I found that you can simply ignore the crashed dialog message and the install continues just fine. Just don't click the close button.

Erick Brunzell (lbsolost) wrote :

Ditto what Phillip said although my new install won't successfully boot, I'm still exploring that. I just sit forever on a blank purple screen. The login screen never even appears so I need to investigate a bit further.

I should say though that this bug "popped up" along with bug 652916 and bug 705078 so maybe it's something to do with apport itself?

When I tried it, the installer stopped shortly after the dialog appeared. I wasn't able to proceed with the install just by ignoring it.

Erick Brunzell (lbsolost) wrote :

RE the boot problem, I installed to my internal disc sdb and I have a lot of OS's on sda so I handed boot off to my Lucid and the new install booted just fine.

Since I already have Natty installed (actually two) and I've been trying different things with grub-pc/common version 1.99~rc1-1ubuntu2 I don't think there's a problem with grub itself, so I can only assume that some grub files failed to load properly.

I did look in /etc/grub.d and grub.cfg, and I didn't see anything obvious but I'm tired. And I'm just getting used to the most recent changes in grub. I'm actually impressed.

Regardless I'm tired! I'm going to start my upgrade test and take a nap!

Evan (ev) on 2011-02-02
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.5.14

---------------
ubiquity (2.5.14) natty; urgency=low

  * Append to the timezone model using the correct types (LP: #702898).
  * Update translations from Launchpad.
 -- Evan Dandrea <email address hidden> Wed, 02 Feb 2011 10:24:41 +0000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Erick Brunzell (lbsolost) wrote :

The fix seems to have worked. I've not been able to reproduce this bug with the rebuilt image this AM.

Changed in ubiquity (Ubuntu Natty):
milestone: none → natty-alpha-2
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers