No notification in Ubiquity for bad sectors

Bug #69176 reported by Dean Moreton on 2006-10-29
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Baltix)
Undecided
Unassigned
ubiquity (Ubuntu)
Low
Unassigned
Declined for Jaunty by Brian Murray

Bug Description

Installing Edgy on an IBM A22m Thinkpad, Ubiquity would seemingly hang when either:

a) attempting to resize an NTFS partition for the install or
b) halfway though copying files if / partition already created before running desktop installer

Looking in syslog I noticed ubiquity was detecting bad sectors on the HDD, but it does not relay this information to the end user. Using the alternate CD for the install, a large red box will appear telling the user that the HDD is bad, as opposed to just hanging.

I think notifying the user via the UI that bad sectors have been found would at least help the user know why the installer has hung.

Oddly enough Windows will happily install and run on this HDD, even though chkdsk will consistently find errors/bad sectors.. I guess Linux is a little more picky on what it will install on?

Dean Moreton (dean-moreton) wrote :

attached is the syslog from an install that attempted to resize the NTFS partion of /dev/hda1

Henrik Nilsen Omma (henrik) wrote :

Thank you for your report. You seem to have diagnosed the problem well. I agree that the user should be notified of the errors. We'll probably have to focus on the cases where the installer hangs on 100% functional hardware first though :)

Changed in ubiquity:
importance: Undecided → Low
status: Unconfirmed → Confirmed

I think this makes a very bad impression on a significant number of users who are switching from windows. The installer should definitely tell the user to run chkdsk /R and reboot windows twice. This has been ignored for too long and the priority should be raised.

tags: added: ubiquity-1.2.5
tags: added: edgy
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged

In 13.04 still if a NTFS partition needs chkdsk ubiquity hangs without any further message...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments