Desktop LiveCD install erroneously "requires" NewWorld boot partition (and/or Yaboot) on Pegasos PPC

Bug #68626 reported by Matt Sealey on 2006-10-27
6
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: base-installer

* Boot Edgy Desktop CD on a Genesi Pegasos or ODW
(you will need a vmlinuz-chrp.initrd kernel for this; see http://www.ppczone.org/ - also remove the BusID and UseFBDev lines from /etc/X11/xorg.conf once it fails, and "startx" to hit the installer. Other bugs reported for those)

* Run through the installer until you get to "Prepare mount points"

You cannot click Forward from this point. Genesi recommends using the RigidDiskBlock (Amiga) or MBR parititoning schemes as the Firmware understands these and they are most relevant to Linux. Neither of them are supported in the LiveCD, although manually partitioning using Alternative works just fine.

You do not need Yaboot if you can install a CHRP initrd kernel using mkvmlinuz.

Proposed fixes:

* Detect Pegasos (it's fairly easy using info in /proc/device-tree)
* Provide "mkvmlinuz" on install CD
* Set boot loader to "mkvmlinuz"
* Get rid of that warning if Yaboot isn't the required bootloader, and allow installation to proceed.

Tags: ppc Edit Tag help
Colin Watson (cjwatson) wrote :

(A good deal of work will be required to solve this, including the implementation of a new partitioner and support in Ubiquity for automatically selecting between bootloaders. This will take some time.)

Parthan SR (parth-technofreak) wrote :

Is this bug being considered and work in progress? Or is it a won't fix bug? Marking this as incomplete, as Colin said it will take time but not mentioned as won't fix or in-progress.

Changed in ubiquity:
status: New → Incomplete
wolfger (wolfger) wrote :

Probably should have been an "in progress", but is now definitely a "won't fix", since Edgy is out of support. If this bug is still an issue in the currently supported Ubuntu releases, please reopen. Thanks!

Changed in ubiquity:
status: Incomplete → Invalid
Matt Sealey (mwsealey) wrote :

Still present in Hardy and probably every future revision since it's not been dealt with. NewWorld partitions aren't required on Pegasos, Efika or any other PPC system that doesn't use Apple partitioning. openSuSE 11.0 beta has implemented a check for these systems (via "hwinfo") to enable Mac bootloader and partitioning requirements to be skipped or disabled automatically by the Installer.

A similar solution should be simple to add (a check for /proc/cpuinfo or /proc/device-tree/openprom/CODEGEN,vendor property for "bplan" would do it).

Changed in ubiquity:
status: Invalid → New

Thank you for taking the time to make Ubuntu better. Since what you submitted is not really a bug, or a problem, but rather an idea to improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm at [WWW] https://brainstorm.ubuntu.com/ where it can be discussed, voted by the community and reviewed by developers. Thanks for taking the time to share your opinion!

Changed in ubiquity:
status: New → Confirmed
Przemek K. (azrael) on 2010-01-08
tags: added: ppc
summary: - Edgy Desktop LiveCD install erroneously "requires" NewWorld boot
- partition (and/or Yaboot) on Pegasos
+ Desktop LiveCD install erroneously "requires" NewWorld boot partition
+ (and/or Yaboot) on Pegasos PPC
Phillip Susi (psusi) on 2014-01-07
Changed in ubiquity (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers