Ubiquity cannot install if you are booting LiveCD directly from ISO

Bug #684280 reported by komputes on 2010-12-02
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Ubiquity cannot install if you are booting LiveCD directly from ISO. Booting directly from GRUB to the ISO, mounts the ISO to /isodevice. Ubiquity will not install (even if on separate disk) if this is not unmounted. The result being that one cannot install Ubuntu in this method. This method can be used to create a recovery partition or a multi-usb bootable drive. For more explanation on how to do this:

========== START ==========

    * Run the following commands which will create the directory /boot/iso and download the iso file to that directory.

$ sudo -s
# mkdir /boot/iso
# cd /boot/iso
# wget http://releases.ubuntu.com/maverick/ubuntu-10.10-desktop-i386.iso

    * Add a custom menu entry in GRUB2 configuration file. Edit /etc/grub.d/40_custom as root to look like this:

#!/bin/sh
echo "Adding 40_custom." >&2
exec tail -n +3 $0

menuentry "Maverick CD Image ISO" {
set isofile=/boot/iso/ubuntu-10.10-desktop-i386.iso
loopback loop (hd0,1)$isofile
linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=$isofile noprompt noeject
initrd (loop)/casper/initrd.lz
}

    * Afterwards, run update-grub for the changes to be propagated to /boot/grub/grub.cfg

# update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-...
Found initrd image: /boot/initrd.img-...

========== STOP ==========

The result of booting from the ISO directly from GRUB, is that the CD is that the partition where the ISO is located is mounted to /isodevice. Ubiquity seems to want to have control of all disks and unmount all disks before it starts installing. In the images here you see the example is sda2 for / and sda for the MBR. I have also tried this with a secondary disk where sdb1 was to be used for / and sdb for the MBR and ubiquity still complained that it had to to unmount /isodevice, even though it is on sda1. Doesn't make much sense to unmount a disk if you will not be editing any part of it.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: ubiquity 2.4.8
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Thu Dec 2 16:34:42 2010
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity

komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) wrote :
komputes (komputes) on 2010-12-02
description: updated
description: updated
Evan Dandrea (ev) wrote :

You need to preseed the following:

d-i partman/filter_mounted boolean false
d-i ubiquity/partman-skip-unmount boolean true

Changed in ubiquity (Ubuntu):
status: New → Invalid
komputes (komputes) wrote :

How can one preseed d-i values on a LiveCD with ubiquity? Can you please provide instructions and I will test and get back to you.

Changed in ubiquity (Ubuntu):
status: Invalid → New
tags: added: ubiquity-2.4.8
komputes (komputes) wrote :

This no longer affects me with the latest version.

Changed in baltix:
status: New → Invalid
Changed in ubiquity (Ubuntu):
status: New → Invalid
Krainov Lev (lev-krainov) wrote :

reproduced in kubuntu-11.10-desktop-amd64.iso , workaround with exit 0 in /lib/partman/commit.d/01unmount_busy solved the problem

Aditya (meta1729) wrote :

Present in xubuntu-14.04-desktop-i386.iso. The installer says it needs to unmount /isodevice even if NO partition changes (create/delete/resize) are requested. All that is requested is formatting of other partition as ext4.

Please reopen this bug.

OpenITeX (experimancer) wrote :

Still present in ubuntu-14.04-desktop iso, booted from grub2.

No way to continue with installation cause "/isodevice cannot be unmounted" (the operation of which is not even needed).

Not "invalid" or "fixed" not even in any of this bugs duplicates.

Wonder why this has ever been closed, even if it has been around for atleast 4 years in each and every Ubunut installatiion .iso image.?

The quality of Ubuntu distributions is getting worse and worse every year.. And seems that rven this severe installation bugs are not fixed :(

tags: added: installer ubuntu-14.04
OpenITeX (experimancer) wrote :

Fix is actully here: https://help.ubuntu.com/community/Grub2/ISOBoot (i.e add "toram" to relevant Grub2 menuentry or manually umount the /isodevice with "sudo umount -lrf /isodevice" and re-start the installation.

Changed in ubiquity (Ubuntu):
status: Invalid → New
OpenITeX (experimancer) on 2014-10-21
no longer affects: ubiquity
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers